<!doctype html>
<html class="no-js" lang="en" dir="ltr">
  <head id="Meta_HeadTag"><title>Seth Meyers Takes a Closer Look at Trump&#39;s Fake &quot;ObamaGate&quot; Nonsense and Obama&#39;s Criticism of the Coronavirus Response - Paste</title><meta charset="utf-8" />
<link rel="shortcut icon" href="/pastemagazine.img/favicon.ico" type="image/vnd.microsoft.icon"/>
<script>
var pm = {
   servers: {
       pastemagazine: "www.pastemagazine.com",
       wolfgangs: "www.wolfgangs.com"
   },
   version: "39.2020.10409.11618.2",
   page: {"type":"Article","mediaType":"Comedy","articleType":"News","articleId":344742,"author":"Garrett Martin","services":"/pastemagazine.svc/pastemagazine/","isMobile":false,"isIos":false,"videoEmbedPlayerId":30540132,"testGroup":null,"adblocker":true}
};
</script>
<!-- Google Tag Manager -->
<script id="gtm-script">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P8HM6Q9');</script>
<!-- End Google Tag Manager -->
<script>window.pageloadTimer = new Date()</script>
<link rel="standout" href="https://www.pastemagazine.com/movies/youtube/the-50-best-movies-on-youtube-free-and-paid/" />
<link rel="alternate" type="application/rss+xml" title="Recent Paste Articles" href="https://www.pastemagazine.com/recent.xml" />
<link rel="canonical" href="https://www.pastemagazine.com/comedy/seth-meyers/seth-meyers-obama-trump-coronavirus/" />
<link rel="amphtml" href="https://www.pastemagazine.com/comedy/seth-meyers/seth-meyers-obama-trump-coronavirus/?amp">
<meta http-equiv="x-ua-compatible" content="ie=edge" />
<meta name="title" content="Seth Meyers Takes a Closer Look at Trump's Fake &quot;ObamaGate&quot; Nonsense and Obama's Criticism of the Coronavirus Response - Paste Magazine" />
<meta name="description" content="There's a lot to take a closer look at today." />
<meta name="keywords" content="barack obama, coronavirus, donald trump, seth meyers, Seth Meyers Takes a Closer Look at Trump's Fake &quot;ObamaGate&quot; Nonsense and Obama's Criticism of the Coronavirus Response, News, News, Articles, Paste" />
<meta name="news_keywords" content="barack obama, coronavirus, donald trump, seth meyers" />
<meta property="fb:admins" content="679468950" />
<meta property="fb:admins" content="1185614656" />
<meta property="fb:app_id" content="127550380613969" />
<meta property="fb:pages" content="18512903240" />
<meta name="apple-mobile-web-app-title" content="Paste Magazine"/>
<link rel="icon" sizes="196x196" href="https://cdn.pastemagazine.com/images/mobile-icon-196.png"/>
<link rel="icon" sizes="128x128" href="https://cdn.pastemagazine.com/images/mobile-icon-128.png" />
<link rel="apple-touch-icon" sizes="57x57" href="https://cdn.pastemagazine.com/images/mobile-icon-57.png" />
<link rel="apple-touch-icon" sizes="72x72" href="https://cdn.pastemagazine.com/images/mobile-icon-72.png" />
<link rel="apple-touch-icon" sizes="144x144" href="https://cdn.pastemagazine.com/images/mobile-icon-144.png" />
<meta property="og:image" content="https://cdn.pastemagazine.com/www/articles/2020/05/19/meyers_trump_obama.JPG" />
<meta property="og:image:width" content="915" />
<meta property="og:image:height" content="480" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.pastemagazine.com/comedy/seth-meyers/seth-meyers-obama-trump-coronavirus/" />
<meta property="og:title" content="Seth Meyers Takes a Closer Look at Trump's Fake &quot;ObamaGate&quot; Nonsense and Obama's Criticism of the Coronavirus Response" />
<meta property="og:site_name" content="pastemagazine.com" />
<meta property="og:description" content="There's a lot to take a closer look at today." />
<meta property="article:tag" content="barack obama" />
<meta property="article:tag" content="coronavirus" />
<meta property="article:tag" content="donald trump" />
<meta property="article:tag" content="seth meyers" />
<meta property="article:section" content="Comedy" />
<meta property="article:published_time" content="2020-05-19T15:07:08-07:00" />
<meta property="article:modified_time" content="2020-05-19T15:45:22-07:00" />
<meta property="article:publisher" content="https://www.facebook.com/PasteMagazine" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@pastemagazine" />
<meta name="twitter:title" content="Seth Meyers Takes a Closer Look at Trump's Fake &quot;ObamaGate&quot; Nonsense and Obama's Criticism of the Coronavirus Response" />
<meta name="twitter:description" content="There's a lot to take a closer look at today." />
<meta name="twitter:image" content="https://cdn.pastemagazine.com/www/articles/2020/05/19/meyers_trump_obama.JPG" />
<meta name="p:domain_verify" content="8f36922bc91ba221f10d82c407d8b6a9"/>
<meta name="viewport" content="viewport-fit=cover, width=device-width, initial-scale=1.0, maximum-scale=1.0" />
<link rel="prefetch" href="https://securepubads.g.doubleclick.net/tag/js/gpt.js" />
<link rel="prefetch" href="//c.amazon-adsystem.com/aax2/apstag.js" />
<link rel="dns-prefetch" href="https://analytics.wolfgangs.com" />
<link rel="dns-prefetch" href="https://hb.adtelligent.com" />
<link rel="dns-prefetch" href="https://ib.adnxs.com" />
<link rel="dns-prefetch" href="https://web.hb.ad.cpe.dotomi.comm" />
<link rel="dns-prefetch" href="https://ap.lijit.com" />
<link rel="dns-prefetch" href="https://cdn.ampproject.org" />
<link rel="dns-prefetch" href="https://aax-eu.amazon-adsystem.com" />
<link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin />
<link rel="preload" as="font" type="font/woff" href="/pastemagazine.fnt/montserrat-regular-webfont.woff" crossorigin />
<link rel="preload" as="font" type="font/woff" href="/pastemagazine.fnt/montserrat-bold-webfont.woff" crossorigin />
<link rel="preload" as="font" type="font/woff" href="/pastemagazine.fnt/28EF9A_0_0.woff" crossorigin />
<link rel="preload" as="font" type="font/woff" href="/pastemagazine.fnt/28EF9A_1_0.woff" crossorigin />
<script type="application/ld+json">[{"@context":"https://schema.org","@type":"Article","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.pastemagazine.com/comedy/seth-meyers/seth-meyers-obama-trump-coronavirus/","inLanguage":"en-US"},"datePublished":"2020-05-19T15:07:08-07:00","dateModified":"2020-05-19T15:45:22-07:00","articleSection":"Comedy","author":{"@type":"Person","name":"Garrett Martin"},"headline":"Seth Meyers Takes a Closer Look at Trump\u0027s Fake \"ObamaGate\" Nonsense and Obama\u0027s Criticism of the Coronavirus Response","url":"https://www.pastemagazine.com/comedy/seth-meyers/seth-meyers-obama-trump-coronavirus/","thumbnailUrl":"https://cdn.pastemagazine.com/www/articles/2020/05/19/meyers_trump_obama.JPG","image":{"@type":"ImageObject","url":"https://cdn.pastemagazine.com/www/articles/2020/05/19/meyers_trump_obama.JPG","width":633,"height":356},"publisher":{"@type":"Organization","url":"https://pastemagazine.com/","name":"Paste Magazine","logo":{"@type":"ImageObject","url":"https://cdn.pastemagazine.com/images/master-header-logo.png","width":650,"height":179},"potentialAction":{"@type":"SearchAction","target":"https://pastemagazine.com/search?t={search_term_string}","query-input":"required name=search_term_string"}},"keywords":["barack obama","coronavirus","donald trump","seth meyers"]},{"@type":"BreadcrumbList","@id":"https://www.pastemagazine.com/comedy/seth-meyers/seth-meyers-obama-trump-coronavirus/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"/","url":"https://pastemagazine.com/","name":"Paste Magazine"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"/comedy","url":"https://pastemagazine.com/comedy","name":"Paste Comedy"}},{"@type":"ListItem","position":3,"item":{"@type":"WebPage","@id":"/articles/comedy/news/","url":"https://pastemagazine.com/articles/comedy/news/","name":"Most Recent Comedy News"}},{"@type":"ListItem","position":4,"item":{"@type":"WebPage","@id":"/search?t=Seth+Meyers","url":"https://pastemagazine.com/search?t=Seth+Meyers","name":"Seth Meyers"}}]}]</script>
<style>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</style>
<link rel="stylesheet" type="text/css" href="https://www.pastemagazine.com/pastemagazine.css/stylesheet.css?cb=39.2020.10409.11618.2"/>

<script>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
// GDPR patch for Conversant for RhythmOne
!function(){var c=window,t=document,n=function(){if(!c.frames.__cmpLocator)if(t.body){var a=t.body,e=t.createElement("iframe");e.style="display:none",e.name="__cmpLocator",a.appendChild(e)}else setTimeout(n,5)};n();var a=function(t){var n="string"==typeof t.data;try{var a=n?JSON.parse(t.data):t.data;if(a.__cmpCall){var p=a.__cmpCall;c.__cmp(p.command,p.parameter,function(a,e){var c={__cmpReturn:{returnValue:a,success:e,callId:p.callId}};t.source.postMessage(n?JSON.stringify(c):c,"*")})}}catch(a){}};"function"!=typeof __cmp&&(c.__cmp=function(){var a=arguments;if(__cmp.a=__cmp.a||[],!a.length)return __cmp.a;"ping"===a[0]?a[2]({gdprAppliesGlobally:!1,cmpLoaded:!1},!0):__cmp.a.push([].slice.apply(a))},__cmp.msgHandler=a,c.addEventListener("message",a,!1))}();
</script>
<script src="https://tagan.adlightning.com/pastemagazine/op.js"></script>
<script async="async" src="https://c.amazon-adsystem.com/aax2/apstag.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>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</script>
<script>let retries=0,alreadySent=false;window.gtmEventSend=function(){if(dataLayer && !alreadySent){alreadySent=true;dataLayer.push({'event':'detectioncomplete'});}else if(retries<6 && !alreadySent){retries++;setTimeout(gtmEventSend,250);}}</script>
<script async="async" src="/pastemagazine.js/ads.js?cb=39.2020.10409.11618.2" onerror="gtmEventSend()"></script>

</head>
  <body>
    <!-- Google Tag Manager (noscript) -->
    
    <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-P8HM6Q9" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
    <!-- End Google Tag Manager (noscript) -->
    <div class="screen"></div>
    <form method="post" action="/comedy/seth-meyers/seth-meyers-obama-trump-coronavirus/" id="PageForm">
<div class="aspNetHidden">
<input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="Hv1Odk9v2TcfcVhQht+shNzo2DJvAwSy+yq8XWGoS0gN0IIgUP2w556llWhC2hTMfMlUUFg5ue4HylCPtP4zN4AfCQLYgYNh0HrO82QGr5c=" />
</div>

      <div class="expanded site-navigation" id="site_navigation" data-pagetype="Article">
  <div class="grid-container">
    <header id="master-header" class="grid-y detail top-bar sticky" data-sticky="" data-options="anchor: page; marginTop: 0; stickyOn: small;">
      <div class="header-top-ad cell center dfp">
        <div id="top_leaderboard">
          <script>adCommands.push(function(ads){ads.prime("top_leaderboard")});</script>
        </div>
      </div>
      <div class="title-bar grid-x cell align-bottom">
        <a href="/" class="large-1 medium-1 small-5 cell logo">
          <svg id="Layer_1" data-name="Layer 1" viewBox="0 0 650 179.07" xmlns="http://www.w3.org/2000/svg">
            <defs>
              <style>path{fill:#363636;}</style>
            </defs>
            <title>Paste Magazine</title>
            <path d="M-23,430c32.81.05,65.63-.15,98.44.3A80.51,80.51,0,0,1,109.31,438c15.81,7.56,23.79,20.31,24.42,37.65.64,17.58-6.38,30.94-22.21,39.32-12.48,6.61-25.85,9.62-39.84,10-10.33.24-20.66.22-31,0-3.54-.06-4.54,1.16-4.52,4.58q.18,30.48,0,61c0,3.52,1.15,4.63,4.62,4.52,7.44-.21,14.89-.06,22.62-.06V604H-23v-9H2.77V440H-23Zm60.22,9.06a13.11,13.11,0,0,0-.87,2.61q-.08,35.46-.13,70.93c0,2.71,1.33,3.34,3.73,3.32,10.66-.1,21.32,0,32-.13,10.26-.12,17.35-5.09,21.22-14.56,6.16-15.11,6.39-30.46,1.29-45.86-2.46-7.44-7.51-13.3-15.4-14.09C65.05,439.88,51,439.73,37.22,439.06Z" transform="translate(23 -427.93)" />
            <path d="M173,607c-1.92-.47-3.84-1-5.78-1.41-21.1-4.74-33.91-22-32.63-44,1.3-22.15,11.19-38,33.16-44.78q18.81-5.85,37.67-11.57c27-8.15,26.39-16.89,24.43-39.1-1.23-14-11.62-23.39-27-24.85-7.66-.72-15.63.06-23.29,1.27-10.07,1.59-17.22,7.85-21.11,17.23-2.34,5.64-3.58,11.74-5.62,17.53-.55,1.58-2.2,2.79-3.34,4.17-.64-1.57-1.81-3.13-1.83-4.71-.24-12.65-.19-25.31-.39-38-.06-4.11,1.88-5.37,5.7-5.81,13-1.5,26-3.34,39.07-5.05h12c2.77.44,5.53.9,8.31,1.32,24.22,3.64,37,17.29,38.5,42.25.87,14.77.68,29.62.75,44.43.11,22,0,44,0,66,0,10.76,3,14.22,13.61,15.94,1.8.3,3.73.29,5.38,1s2.76,1.93,4.12,2.94c-1.49.72-2.95,2-4.46,2-6,.24-12,.1-18,.1h-7c-8.12,0-8.12,0-11.14-7.58-2.7-6.76-3.07-6.86-9-2.73a73.15,73.15,0,0,1-32.34,12.32c-1.63.22-3.21.7-4.82,1.06Zm57.46-67.13c0-7.66.12-15.32,0-23-.1-5.29-2.06-6.57-7-4.74q-23.65,8.73-47.23,17.64a27.25,27.25,0,0,0-15,13.27c-6.19,11.83-3.68,32.87,5.89,42.16a29.83,29.83,0,0,0,14.07,7.72c14.31,2.87,27.42-1,38.66-10.35a28.14,28.14,0,0,0,10.66-22.73C230.43,553.2,230.47,546.54,230.46,539.87Z" transform="translate(23 -427.93)" />
            <path d="M340,428c5.45,1.42,11.08,2.34,16.28,4.39,5.36,2.1,10.29,5.3,15.59,8.11,4.72-2.23,6-10.39,13.77-9.36v46.52h-7.35c-1-11.74-7.82-20.39-16.15-28.12-15.35-14.24-40.23-14.54-54.46-.65-13.06,12.75-9.67,29.86,7.55,36,11.9,4.25,24.14,7.51,36.22,11.24,2.86.88,5.72,1.79,8.52,2.84,18.88,7.15,30.54,20.4,33.34,40.62,2.61,18.82-.69,36.21-14.23,50.55-15.06,16-41.2,20.94-63.45,11.93-5.35-2.17-10.37-5.15-15.86-7.91-5.51,2.14-8,10.35-16.2,9.86V552.42h6.89c1.48,4.45,2.78,9.06,4.52,13.5,9.84,25.07,36.86,36.49,61.64,26.16,14.51-6.06,23-18,22.48-31.63-.23-6.55-2.39-12.5-8-15.86A184,184,0,0,0,346.35,532c-8.28-3.4-17.07-5.56-25.65-8.22-32.73-10.17-41-41.25-32.19-66.28,5.66-16.11,18.2-24.91,34.68-28.37,1.61-.34,3.21-.75,4.81-1.13Z" transform="translate(23 -427.93)" />
            <path d="M616.8,570.12l9.63,8.64c-1.67,1.84-3.11,3.58-4.7,5.17-26.38,26.35-73.09,29.56-102.91,7.1-18.08-13.62-25.64-34-19.75-53.56,4.15-13.81,13.89-22.8,26.18-29.39,4-2.17,8.27-4,12.83-6.13-3.89-2.17-7.46-3.86-10.71-6-16.35-10.85-20-30.8-8.66-46.7,19.31-27.11,69.5-27.3,88.45.07-2.52,2.4-5.11,4.84-7.91,7.5-6.75-7.16-14.49-11.61-24.11-12.4-19.19-1.58-33.29,12.48-30.33,30.33,1.87,11.24,11.67,19.61,24.5,20.4,6.61.41,13.27.07,20.27.07v12.41H579.17a53,53,0,0,0-28.53,7.76c-25.12,15.62-25.59,49.34-.95,65.74,19.49,13,47,10,63.31-6.86C614.16,573.05,615.26,571.8,616.8,570.12Z" transform="translate(23 -427.93)" />
            <path d="M420.11,481.56h-20V469.69H420V431.85l33.92-2.18v39.89h30.23v12H454.07v5.93q0,42.72,0,85.46a51.83,51.83,0,0,0,.28,6c.61,5.39,2.2,10.45,8.14,11.92,6.18,1.52,12.19.54,16.27-4.84,2.86-3.76,4.91-8.15,7.46-12.51l5,2.61c-1.74,13.29-14.42,26.2-28.52,27.55-8.66.82-17.59,0-26.28-1s-13.72-7.05-15.25-15.61a68.72,68.72,0,0,1-1-11.9c-.08-29,0-58,0-87Z" transform="translate(23 -427.93)" />
          </svg>
        </a><div class="grid-x article-shares-links four">
  <a href="https://www.pastemagazine.com/comedy/seth-meyers/seth-meyers-obama-trump-coronavirus/" data-title="Seth Meyers Takes a Closer Look at Trump's Fake &quot;ObamaGate&quot; Nonsense and Obama's Criticism of the Coronavirus Response" class="small-3 icon-facebook">Share</a>
  <a href="https://www.pastemagazine.com/comedy/seth-meyers/seth-meyers-obama-trump-coronavirus/" data-title="Seth Meyers Takes a Closer Look at Trump's Fake &quot;ObamaGate&quot; Nonsense and Obama's Criticism of the Coronavirus Response" class="small-3 icon-twitter">Tweet</a>
  <a href="https://www.pastemagazine.com/comedy/seth-meyers/seth-meyers-obama-trump-coronavirus/" data-title="Seth Meyers Takes a Closer Look at Trump's Fake &quot;ObamaGate&quot; Nonsense and Obama's Criticism of the Coronavirus Response" class="small-3 icon-reddit-alien only-view-large">Submit</a>
  <a href="https://www.pastemagazine.com/comedy/seth-meyers/seth-meyers-obama-trump-coronavirus/" data-title="Seth Meyers Takes a Closer Look at Trump's Fake &quot;ObamaGate&quot; Nonsense and Obama's Criticism of the Coronavirus Response" data-image="https://cdn.pastemagazine.com/www/articles/2020/05/19/meyers_trump_obama.JPG" class="small-3 icon-pinterest">Pin</a>
</div><div class="large-auto medium-auto small-7 cell search"><input type="search" id="master-search" placeholder="Search" value="" aria-label="Search" /><a href="#" class="non icon-search" id="master-search-button" aria-label="Search"><!--search--></a></div><div class="show-for-medium cell horizontal"><a href="/noisetrade/music/" class="icon-rss large-auto">NoiseTrade</a><a href="/studio" class="icon-video large-auto">Video</a><a href="/podcasts" class="icon-podcasts large-auto">Podcasts</a><a href="/daytrotter" class="icon-daytrotter-horse large-auto">Daytrotter</a></div><div class="top-bar-right show-for-small-only small-1 cell"><a href="#" class="icon-menu" aria-label="Section Menu" data-toggle="small-navigation-menu"><!--phone menu--></a><ul class="vertical dropdown-pane menu" id="small-navigation-menu" data-dropdown="" data-position="left" data-alignment="top" data-close-on-click="true" data-auto-focus="false"><li><a href="/music" class="large-1 cell">Music</a></li><li><a href="/movies" class="large-1 cell">Movies</a></li><li><a href="/tv" class="large-1 cell">TV</a></li><li><a href="/comedy" class="active">Comedy</a></li><li><a href="/games" class="large-1 cell">Games</a></li><li><a href="/books" class="large-1 cell">Books</a></li><li><a href="/drink" class="large-1 cell">Drink</a></li><li><a href="/politics" class="large-1 cell">Politics</a></li><li><a href="/travel" class="large-1 cell">Travel</a></li><li><a href="/tech" class="large-1 cell">Tech</a></li><li class="hide-not-small"><a href="/noisetrade/music/">NoiseTrade</a></li><li class="hide-not-small"><a href="/studio">Video</a></li><li class="hide-not-small"><a href="/podcasts">Podcasts</a></li><li class="hide-not-small"><a href="/daytrotter">Daytrotter</a></li><li><a href="/tag/what+to+watch?s=1">Netflix</a></li><li><a href="https://www.wolfgangs.com/paste-magazine-merch/" target="_blank" rel="noopener">Merch</a></li><li><a href="/advertise">Advertise</a></li><li class="empty"><!--to force order--></li></ul></div></div>
      <nav class="show-for-medium">
        <a href="/music">Music</a>
        <a href="/movies">Movies</a>
        <a href="/tv">TV</a>
        <a href="/comedy" class="active">Comedy</a>
        <a href="/games">Games</a>
        <a href="/books">Books</a>
        <a href="/drink">Drink</a>
        <a href="/politics">Politics</a>
        <a href="/travel">Travel</a>
        <a href="/tech">Tech</a>
      </nav></header>
  </div>
</div>
<div class="expanded header-bottom-ad">
  <div class="grid-x large-12 cell center dfp">
    <div id="top_pushdown">
      <script>adCommands.push(function(ads){ads.prime("top_pushdown")});</script>
    </div>
  </div>
</div>
      <main class="expanded site-body" id="site_body">
        <div class="grid-container">
          
<div class="grid-x article-wrapper">
  <div class="large-12 cell">
    <div class="grid-x small-up-1 medium-up-2 large-up-12">
      <div class="large-auto medium-auto small-auto">
        <article id="article-detail-container">
  <div class="header" data-entry-id="344742">
    <h1 class="title">Seth Meyers Takes a Closer Look at Trump's Fake "ObamaGate" Nonsense and Obama's Criticism of the Coronavirus Response</h1>
    <div class="bylinepublished">By <a class="ovr" href="/writers?name=garrett+martin">Garrett Martin</a>  |  May 19, 2020  |  3:45pm</div>
    <b class="type">
      <a class="non" href="/comedy">Comedy</a> <a class="non" href="/articles/comedy/news/">News</a> <a class="non" href="/search?t=Seth+Meyers">Seth Meyers</a></b>
  </div>
  <div class="grid-x article-shares-links four">
    <a href="https://www.pastemagazine.com/comedy/seth-meyers/seth-meyers-obama-trump-coronavirus/" data-title="Seth Meyers Takes a Closer Look at Trump's Fake &quot;ObamaGate&quot; Nonsense and Obama's Criticism of the Coronavirus Response" class="small-3 icon-facebook">Share</a>
    <a href="https://www.pastemagazine.com/comedy/seth-meyers/seth-meyers-obama-trump-coronavirus/" data-title="Seth Meyers Takes a Closer Look at Trump's Fake &quot;ObamaGate&quot; Nonsense and Obama's Criticism of the Coronavirus Response" class="small-3 icon-twitter">Tweet</a>
    <a href="https://www.pastemagazine.com/comedy/seth-meyers/seth-meyers-obama-trump-coronavirus/" data-title="Seth Meyers Takes a Closer Look at Trump's Fake &quot;ObamaGate&quot; Nonsense and Obama's Criticism of the Coronavirus Response" class="small-3 icon-reddit-alien only-view-large">Submit</a>
    <a href="https://www.pastemagazine.com/comedy/seth-meyers/seth-meyers-obama-trump-coronavirus/" data-title="Seth Meyers Takes a Closer Look at Trump's Fake &quot;ObamaGate&quot; Nonsense and Obama's Criticism of the Coronavirus Response" data-image="https://cdn.pastemagazine.com/www/articles/2020/05/19/meyers_trump_obama.JPG" class="small-3 icon-pinterest">Pin</a>
  </div>
  <div class="main-image">
    <img src="https://cdn.pastemagazine.com/www/articles/2020/05/19/meyers_trump_obama.JPG" alt="Seth Meyers Takes a Closer Look at Trump's Fake &quot;ObamaGate&quot; Nonsense and Obama's Criticism of the Coronavirus Response" />
  </div>
  <div class="copy entry">
    <p>We are still so very tired.<!--work-around to avoid self-close--></p>
    <p>Donald Trump clearly wants to act like the pandemic is over with. Between encouraging people to protest stay-at-home measures, to recently claiming that “we have met the moment and we have prevailed,” Trump obviously wants to dump the coronavirus down the memory hole in hopes of preserving his poll numbers. Seth Meyers takes a look at this in a far-ranging Closer Look, gliding from Trump’s misunderstanding of testing and unearned coronavirus triumphalism, to the return of pro sports in Germany, to Obama’s recent implicit criticism of Trump, to Trump’s nonsensical, nonexistent “Obamagate” conspiracy that he’s been touting on Twitter over the last week. If you want to get a quick refresher on the most recent Trump absurdities, let Seth Meyers rush you through ‘em in the video below.<!--work-around to avoid self-close--></p>
    <div class="responsive-embed widescreen">
      <div class="lazyload-youtube" data-values="{&quot;id&quot;:&quot;5LBSZnZ2BbY&quot;,&quot;width&quot;:688,&quot;height&quot;:432}">
        <!--YouTube-->
      </div>
    </div>
  </div><div class="grid-x grid-padding-x tags"><b class="large-1 medium-1 small-1 cell label">Tags</b><ul class="large-11 medium-11 small-11 cell"><li><a class="non" href="/tag/barack+obama">barack obama</a></li><li><a class="non" href="/tag/coronavirus">coronavirus</a></li><li><a class="non" href="/tag/donald+trump">donald trump</a></li><li><a class="non" href="/tag/seth+meyers">seth meyers</a></li></ul></div></article>
        <div id="zergnet-widget-83184"></div>
<script language="javascript" type="text/javascript">
  (function() {
       var zergnet = document.createElement('script');
      zergnet.type = 'text/javascript'; zergnet.async = true;
     zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=83184';
      var znscr = document.getElementsByTagName('script')[0];
      znscr.parentNode.insertBefore(zergnet, znscr);
   })(); +vbcrlf</script>
<div class="grid-x articles-standard">
  <div class="large-12 cell articles-header">
    <a class="float-left hed" href="/tag/Seth+Meyers">Also from Seth Meyers</a>
  </div>
  <ul class="no-bullet articles grid-margin-x flex-container flex-dir-column">
    <li class="grid-x grid-padding-x">
      <a href="/comedy/seth-meyers/seth-meyers-takes-a-closer-look-at-trumps-mask-fac/" aria-label="Seth Meyers Takes a Closer Look at Trump's Mask Factory Tour and Rush to Reopen the Country" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/586/meyers_trump_live_and_let_die_square-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/586/meyers_trump_live_and_let_die_square-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/586/meyers_trump_live_and_let_die_square-151x151.jpg&quot;]">
          <img alt="Seth Meyers Takes a Closer Look at Trump's Mask Factory Tour and Rush to Reopen the Country" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/comedy/seth-meyers/seth-meyers-takes-a-closer-look-at-trumps-mask-fac/">
        <b class="title">Seth Meyers Takes a Closer Look at Trump's Mask Factory Tour and Rush to Reopen the Country</b>
        <b class="byline">By Garrett Martin</b>
        <b class="time" data-iso-date="2020-05-07T17:30:26-06:00">May 7, 2020  |  5:30pm</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/comedy/seth-meyers/a-closer-look-trump-disinfectant/" aria-label="Seth Meyers Takes a Closer Look at Trump's Disinfectant Claims and Falling Poll Numbers" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/456/seth_meyers_trump_disinfectant_square-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/456/seth_meyers_trump_disinfectant_square-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/456/seth_meyers_trump_disinfectant_square-151x151.jpg&quot;]">
          <img alt="Seth Meyers Takes a Closer Look at Trump's Disinfectant Claims and Falling Poll Numbers" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/comedy/seth-meyers/a-closer-look-trump-disinfectant/">
        <b class="title">Seth Meyers Takes a Closer Look at Trump's Disinfectant Claims and Falling Poll Numbers</b>
        <b class="byline">By Garrett Martin</b>
        <b class="time" data-iso-date="2020-04-29T15:15:47-06:00">April 29, 2020  |  3:15pm</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/comedy/seth-meyers/seth-meyers-trump-reopen-economy/" aria-label="Seth Meyers Looks at Trump's Rush to Reopen the Economy, and How It Repeats His COVID Mistakes" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/288/seth_meyers_trump_economy_square-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/288/seth_meyers_trump_economy_square-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/288/seth_meyers_trump_economy_square-151x151.jpg&quot;]">
          <img alt="Seth Meyers Looks at Trump's Rush to Reopen the Economy, and How It Repeats His COVID Mistakes" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/comedy/seth-meyers/seth-meyers-trump-reopen-economy/">
        <b class="title">Seth Meyers Looks at Trump's Rush to Reopen the Economy, and How It Repeats His COVID Mistakes</b>
        <b class="byline">By Garrett Martin</b>
        <b class="time" data-iso-date="2020-04-16T14:30:34-06:00">April 16, 2020  |  2:30pm</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/comedy/seth-meyers/seth-meyers-takes-a-closer-look-at-jared-kushners/" aria-label="Seth Meyers Takes a Closer Look at Jared Kushner's Role in the COVID-19 Response" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/125/meyers_kusher_covid_square-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/125/meyers_kusher_covid_square-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/125/meyers_kusher_covid_square-151x151.jpg&quot;]">
          <img alt="Seth Meyers Takes a Closer Look at Jared Kushner's Role in the COVID-19 Response" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/comedy/seth-meyers/seth-meyers-takes-a-closer-look-at-jared-kushners/">
        <b class="title">Seth Meyers Takes a Closer Look at Jared Kushner's Role in the COVID-19 Response</b>
        <b class="byline">By Garrett Martin</b>
        <b class="time" data-iso-date="2020-04-03T16:43:08-06:00">April 3, 2020  |  4:43pm</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/comedy/seth-meyers/seth-meyers-donald-trump-lies/" aria-label="Seth Meyers Takes a Closer Look at Trump's Coronavirus Lies" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/107/meyers_trump_covid_lies_square-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/107/meyers_trump_covid_lies_square-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/107/meyers_trump_covid_lies_square-151x151.jpg&quot;]">
          <img alt="Seth Meyers Takes a Closer Look at Trump's Coronavirus Lies" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/comedy/seth-meyers/seth-meyers-donald-trump-lies/">
        <b class="title">Seth Meyers Takes a Closer Look at Trump's Coronavirus Lies</b>
        <b class="byline">By Garrett Martin</b>
        <b class="time" data-iso-date="2020-04-02T19:15:30-06:00">April 2, 2020  |  7:15pm</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/comedy/seth-meyers/seth-meyers-a-closer-look-trump-coronavirus/" aria-label="Seth Meyers Workshops His WFH Approach in A Closer Look at Trump’s Delusional Coronavirus Response" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/951/acloserlookCoronaMismanagementLead-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/951/acloserlookCoronaMismanagementLead-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/951/acloserlookCoronaMismanagementLead-151x151.jpg&quot;]">
          <img alt="Seth Meyers Workshops His WFH Approach in A Closer Look at Trump’s Delusional Coronavirus Response" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/comedy/seth-meyers/seth-meyers-a-closer-look-trump-coronavirus/">
        <b class="title">Seth Meyers Workshops His WFH Approach in A Closer Look at Trump&#8217;s Delusional Coronavirus Response</b>
        <b class="byline">By Katy Mayfield</b>
        <b class="time" data-iso-date="2020-03-26T12:38:15-06:00">March 26, 2020  |  12:38pm</b>
      </a>
    </li>
    <li class="more">
      <a href="/tag/Seth+Meyers">More from Seth Meyers</a>
    </li>
  </ul>
</div><div class="dfp"><div id="mid_leaderboard_rectangle_1"><script>adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_1")});</script></div></div><div class="grid-x articles-standard" id="article-detail-studio-highlights">
  <div class="large-12 cell articles-header">
    <b class="float-left hed">Also in Comedy</b>
  </div>
  <ul class="no-bullet articles grid-margin-x flex-container flex-dir-column">
    <li class="grid-x grid-padding-x">
      <a href="/games/comics/pvp-comic-reboot-scott-kurtz/" aria-label="After 22 Years, Scott Kurtz Just Rebooted Seminal Gaming Webcomic PvP" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/732/pvp-reboot-lead-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/732/pvp-reboot-lead-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/732/pvp-reboot-lead-151x151.jpg&quot;]">
          <img alt="After 22 Years, Scott Kurtz Just Rebooted Seminal Gaming Webcomic PvP" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/games/comics/pvp-comic-reboot-scott-kurtz/">
        <b class="title">After 22 Years, Scott Kurtz Just Rebooted Seminal Gaming Webcomic <i>PvP</i></b>
        <b class="byline">By Jim Vorel</b>
        <b class="time" data-iso-date="2020-05-19T12:19:00-06:00">May 19, 2020  |  12:19pm</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/games/animal-crossing/snl-animal-crossing/" aria-label="Saturday Night Live: When Your Animal Crossing Animals Hate You" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/713/snl_acnh_square-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/713/snl_acnh_square-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/713/snl_acnh_square-151x151.jpg&quot;]">
          <img alt="Saturday Night Live: When Your Animal Crossing Animals Hate You" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/games/animal-crossing/snl-animal-crossing/">
        <b class="title"><i>Saturday Night Live</i>: When Your Animal Crossing Animals Hate You</b>
        <b class="byline">By Garrett Martin</b>
        <b class="time" data-iso-date="2020-05-18T14:15:13-06:00">May 18, 2020  |  2:15pm</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/comedy/coronavirus/john-oliver-sports-coronavirus/" aria-label="John Oliver Examines the Relationship Between Sports and the Coronavirus—and Introduces Your New Sports Obsession" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/704/john_oliver_sports_square-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/704/john_oliver_sports_square-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/704/john_oliver_sports_square-151x151.jpg&quot;]">
          <img alt="John Oliver Examines the Relationship Between Sports and the Coronavirus—and Introduces Your New Sports Obsession" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/comedy/coronavirus/john-oliver-sports-coronavirus/">
        <b class="title">John Oliver Examines the Relationship Between Sports and the Coronavirus&#8212;and Introduces Your New Sports Obsession</b>
        <b class="byline">By Garrett Martin</b>
        <b class="time" data-iso-date="2020-05-18T12:45:00-06:00">May 18, 2020  |  12:45pm</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/comedy/mr-show/mr-show-zoomtacular-charity/" aria-label="David Cross and Bob Odenkirk Brought Mr. Show Back for Charity; Here's How to Watch" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/681/mr_show_zoom_getty_square-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/681/mr_show_zoom_getty_square-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/681/mr_show_zoom_getty_square-151x151.jpg&quot;]">
          <img alt="David Cross and Bob Odenkirk Brought Mr. Show Back for Charity; Here's How to Watch" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/comedy/mr-show/mr-show-zoomtacular-charity/">
        <b class="title">David Cross and Bob Odenkirk Brought Mr. Show Back for Charity; Here's How to Watch</b>
        <b class="byline">By Garrett Martin</b>
        <b class="time" data-iso-date="2020-05-14T14:45:21-06:00">May 14, 2020  |  2:45pm</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/comedy/coronavirus/weird-al-eat-it-celebrities/" aria-label="Watch an All-Star Team of Celebrities Sing a Heart-stirring, Empowering Version of Weird Al's &quot;Eat It&quot;" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/672/weird_al_eat_it_square-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/672/weird_al_eat_it_square-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/672/weird_al_eat_it_square-151x151.jpg&quot;]">
          <img alt="Watch an All-Star Team of Celebrities Sing a Heart-stirring, Empowering Version of Weird Al's &quot;Eat It&quot;" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/comedy/coronavirus/weird-al-eat-it-celebrities/">
        <b class="title">Watch an All-Star Team of Celebrities Sing a Heart-stirring, Empowering Version of Weird Al's "Eat It"</b>
        <b class="byline">By Garrett Martin</b>
        <b class="time" data-iso-date="2020-05-14T12:00:00-06:00">May 14, 2020  |  12:00pm</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/comedy/stephen-colbert/colbert-fauci-senate-testimony/" aria-label="Stephen Colbert Looks at Dr. Fauci's Senate Testimony and Bernie's Red Hot Chili Peppers Fandom" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/662/late_show_colbert_fauci_Square-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/662/late_show_colbert_fauci_Square-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/662/late_show_colbert_fauci_Square-151x151.jpg&quot;]">
          <img alt="Stephen Colbert Looks at Dr. Fauci's Senate Testimony and Bernie's Red Hot Chili Peppers Fandom" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/comedy/stephen-colbert/colbert-fauci-senate-testimony/">
        <b class="title">Stephen Colbert Looks at Dr. Fauci's Senate Testimony and Bernie's Red Hot Chili Peppers Fandom</b>
        <b class="byline">By Garrett Martin</b>
        <b class="time" data-iso-date="2020-05-13T15:15:36-06:00">May 13, 2020  |  3:15pm</b>
      </a>
    </li>
  </ul>
</div><div class="dfp"><div id="mid_leaderboard_rectangle_2"><script>adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_2")});</script></div></div><!--Detail Page Bottom Rendered: 5/19/2020 1:38:36 PM -->

      </div>
      <aside class="large-3 medium-3 small-auto">
<!--MOREMEDIATYPEORARTICLETYPE-->
<div class="grid-x articles-abbreviated live-music-at-home" id="detail_youtube">
  <div class="large-12 cell articles-header header-center">
    <b class="float-left hed">Live Music at Home</b>
  </div>
  <ul class="no-bullet articles grid-margin-x flex-container flex-dir-column">
    <li class="grid-x grid-padding-x">
      <a class="auto cell copy-container noimage" href="/music/bruce-springsteen-the-e-street-band/bruce-springsteen-the-e-street-band-badlands2/">
        <b class="title">Bruce Springsteen</b>
        <b class="time unparsed notime">09/20/1978</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a class="auto cell copy-container noimage" href="/music/jason-isbell/jason-isbell-streetlights2/">
        <b class="title">Jason Isbell</b>
        <b class="time unparsed notime">10/20/2011</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a class="auto cell copy-container noimage" href="/music/bonnie-raitt/bonnie-raitt-about-to-make-me-leave-home234567/">
        <b class="title">Bonnie Raitt</b>
        <b class="time unparsed notime">12/31/1989</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a class="auto cell copy-container noimage" href="/music/bob-dylan/bob-dylan-san-francisco-bay-blues2/">
        <b class="title">Bob Dylan</b>
        <b class="time unparsed notime">12/04/1988</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a class="auto cell copy-container noimage" href="/music/sarah-mclachlan/sarah-mclachlan-adia23/">
        <b class="title">Sarah McLachlan</b>
        <b class="time unparsed notime">10/17/1998</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a class="auto cell copy-container noimage" href="/music/paula-cole/paula-cole-full-session/">
        <b class="title">Paula Cole</b>
        <b class="time unparsed notime">09/12/2019</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a class="auto cell copy-container noimage" href="/music/lynyrd-skynyrd/lynyrd-skynyrd-sweet-home-alabama/">
        <b class="title">Lynyrd Skynyrd</b>
        <b class="time unparsed notime">07/02/1977</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a class="auto cell copy-container noimage" href="/music/peter-frampton/peter-frampton-baby-i-love-your-way2345678910/">
        <b class="title">Peter Frampton</b>
        <b class="time unparsed notime">07/02/1977</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a class="auto cell copy-container noimage" href="/music/vintage-trouble/vintage-trouble-high-times-are-coming2/">
        <b class="title">Vintage Trouble</b>
        <b class="time unparsed notime">03/15/2012</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a class="auto cell copy-container noimage" href="/music/ac-dc/acdc-live-wire2/">
        <b class="title">AC/DC</b>
        <b class="time unparsed notime">07/21/1979</b>
      </a>
    </li>
  </ul>
</div><div class="dfp"><div id="top_rectangle"><script>adCommands.push(function(ads){ads.prime("top_rectangle")});</script></div></div>
<div class="grid-x articles-abbreviated" id="article-detail-most-read">
  <div class="large-12 cell articles-header">
    <a href="/articles/comedy/most-read/" class="float-left hed">Most Popular</a>
  </div>
  <ul class="articles grid-margin-x flex-container flex-dir-column">
    <li class="grid-x grid-padding-x">
      <a href="/comedy/netflix/the-50-best-sitcoms-on-netflix-right-now/" aria-label="The 40 Best Sitcoms on Netflix Right Now (April 2020)" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/316/the_good_place_netflix_sitcoms_square_nbc-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/316/the_good_place_netflix_sitcoms_square_nbc-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/316/the_good_place_netflix_sitcoms_square_nbc-151x151.jpg&quot;]">
          <img alt="The 40 Best Sitcoms on Netflix Right Now (April 2020)" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/comedy/netflix/the-50-best-sitcoms-on-netflix-right-now/">
        <b class="title">The 40 Best Sitcoms on Netflix Right Now (April 2020)</b>
        <b class="byline hide-for-large">By Garrett Martin and Paste Staff</b>
        <b class="time hide-for-medium" data-iso-date="2020-04-20T17:00:00-06:00">April 20, 2020</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/comedy/netflix/the-best-comedies-on-netflix-right-now/" aria-label="The 45 Best Comedies on Netflix Right Now (May 2020)" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/066/life_of_brian_poster_square-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/066/life_of_brian_poster_square-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/066/life_of_brian_poster_square-151x151.jpg&quot;]">
          <img alt="The 45 Best Comedies on Netflix Right Now (May 2020)" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/comedy/netflix/the-best-comedies-on-netflix-right-now/">
        <b class="title">The 45 Best Comedies on Netflix Right Now (May 2020)</b>
        <b class="byline hide-for-large">By Garrett Martin and Paste Staff</b>
        <b class="time hide-for-medium" data-iso-date="2020-05-04T17:00:00-06:00">May 4, 2020</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/comedy/coronavirus/weird-al-eat-it-celebrities/" aria-label="Watch an All-Star Team of Celebrities Sing a Heart-stirring, Empowering Version of Weird Al's &quot;Eat It&quot;" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/672/weird_al_eat_it_square-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/672/weird_al_eat_it_square-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/672/weird_al_eat_it_square-151x151.jpg&quot;]">
          <img alt="Watch an All-Star Team of Celebrities Sing a Heart-stirring, Empowering Version of Weird Al's &quot;Eat It&quot;" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/comedy/coronavirus/weird-al-eat-it-celebrities/">
        <b class="title">Watch an All-Star Team of Celebrities Sing a Heart-stirring, Empowering Version of Weird Al's "Eat It"</b>
        <b class="byline hide-for-large">By Garrett Martin</b>
        <b class="time hide-for-medium" data-iso-date="2020-05-14T12:00:00-06:00">May 14, 2020</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/comedy/mr-show/mr-show-zoomtacular-charity/" aria-label="David Cross and Bob Odenkirk Brought Mr. Show Back for Charity; Here's How to Watch" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/681/mr_show_zoom_getty_square-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/681/mr_show_zoom_getty_square-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/681/mr_show_zoom_getty_square-151x151.jpg&quot;]">
          <img alt="David Cross and Bob Odenkirk Brought Mr. Show Back for Charity; Here's How to Watch" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/comedy/mr-show/mr-show-zoomtacular-charity/">
        <b class="title">David Cross and Bob Odenkirk Brought Mr. Show Back for Charity; Here's How to Watch</b>
        <b class="byline hide-for-large">By Garrett Martin</b>
        <b class="time hide-for-medium" data-iso-date="2020-05-14T14:45:21-06:00">May 14, 2020</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/comedy/tweets-of-the-week/funniest-tweets-of-the-week-31/" aria-label="The Funniest Tweets of the Week" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/692/quarantine_space_square_getty-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/692/quarantine_space_square_getty-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/692/quarantine_space_square_getty-151x151.jpg&quot;]">
          <img alt="The Funniest Tweets of the Week" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/comedy/tweets-of-the-week/funniest-tweets-of-the-week-31/">
        <b class="title">The Funniest Tweets of the Week</b>
        <b class="byline hide-for-large">By Garrett Martin</b>
        <b class="time hide-for-medium" data-iso-date="2020-05-15T13:15:35-06:00">May 15, 2020</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/comedy/coronavirus/john-oliver-sports-coronavirus/" aria-label="John Oliver Examines the Relationship Between Sports and the Coronavirus—and Introduces Your New Sports Obsession" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/704/john_oliver_sports_square-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/704/john_oliver_sports_square-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/704/john_oliver_sports_square-151x151.jpg&quot;]">
          <img alt="John Oliver Examines the Relationship Between Sports and the Coronavirus—and Introduces Your New Sports Obsession" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/comedy/coronavirus/john-oliver-sports-coronavirus/">
        <b class="title">John Oliver Examines the Relationship Between Sports and the Coronavirus&#8212;and Introduces Your New Sports Obsession</b>
        <b class="byline hide-for-large">By Garrett Martin</b>
        <b class="time hide-for-medium" data-iso-date="2020-05-18T12:45:00-06:00">May 18, 2020</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/comedy/hulu/best-comedies-on-hulu-right-now/" aria-label="The Best Comedies on Hulu Right Now (May 2020)" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/625/hulu_comedies_square-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/625/hulu_comedies_square-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/625/hulu_comedies_square-151x151.jpg&quot;]">
          <img alt="The Best Comedies on Hulu Right Now (May 2020)" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/comedy/hulu/best-comedies-on-hulu-right-now/">
        <b class="title">The Best Comedies on Hulu Right Now (May 2020)</b>
        <b class="byline hide-for-large">By Paste Staff</b>
        <b class="time hide-for-medium" data-iso-date="2020-05-12T14:10:00-06:00">May 12, 2020</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/games/animal-crossing/snl-animal-crossing/" aria-label="Saturday Night Live: When Your Animal Crossing Animals Hate You" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/713/snl_acnh_square-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/713/snl_acnh_square-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/713/snl_acnh_square-151x151.jpg&quot;]">
          <img alt="Saturday Night Live: When Your Animal Crossing Animals Hate You" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/games/animal-crossing/snl-animal-crossing/">
        <b class="title"><i>Saturday Night Live</i>: When Your Animal Crossing Animals Hate You</b>
        <b class="byline hide-for-large">By Garrett Martin</b>
        <b class="time hide-for-medium" data-iso-date="2020-05-18T14:15:13-06:00">May 18, 2020</b>
      </a>
    </li>
    <li class="more">
      <a href="/articles/comedy/most-read/">More Comedy Most Popular</a>
    </li>
  </ul>
</div><div class="dfp"><div id="middle_rectangle"><script>adCommands.push(function(ads){ads.prime("middle_rectangle")});</script></div></div>
<div class="grid-x articles-abbreviated" id="article-detail-news">
  <div class="large-12 cell articles-header">
    <a href="/articles/comedy/news/" class="float-left hed">News</a>
  </div>
  <ul class="articles grid-margin-x flex-container flex-dir-column">
    <li class="grid-x grid-padding-x">
      <a href="/comedy/seth-meyers/seth-meyers-obama-trump-coronavirus/" aria-label="Seth Meyers Takes a Closer Look at Trump's Fake &quot;ObamaGate&quot; Nonsense and Obama's Criticism of the Coronavirus Response" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/742/meyers_trump_obama_square-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/742/meyers_trump_obama_square-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/742/meyers_trump_obama_square-151x151.jpg&quot;]">
          <img alt="Seth Meyers Takes a Closer Look at Trump's Fake &quot;ObamaGate&quot; Nonsense and Obama's Criticism of the Coronavirus Response" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/comedy/seth-meyers/seth-meyers-obama-trump-coronavirus/">
        <b class="title">Seth Meyers Takes a Closer Look at Trump's Fake "ObamaGate" Nonsense and Obama's Criticism of the Coronavirus Response</b>
        <b class="byline hide-for-large">By Garrett Martin</b>
        <b class="time hide-for-medium" data-iso-date="2020-05-19T15:45:22-06:00">May 19, 2020</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/games/comics/pvp-comic-reboot-scott-kurtz/" aria-label="After 22 Years, Scott Kurtz Just Rebooted Seminal Gaming Webcomic PvP" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/732/pvp-reboot-lead-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/732/pvp-reboot-lead-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/732/pvp-reboot-lead-151x151.jpg&quot;]">
          <img alt="After 22 Years, Scott Kurtz Just Rebooted Seminal Gaming Webcomic PvP" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/games/comics/pvp-comic-reboot-scott-kurtz/">
        <b class="title">After 22 Years, Scott Kurtz Just Rebooted Seminal Gaming Webcomic <i>PvP</i></b>
        <b class="byline hide-for-large">By Jim Vorel</b>
        <b class="time hide-for-medium" data-iso-date="2020-05-19T12:19:00-06:00">May 19, 2020</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/games/animal-crossing/snl-animal-crossing/" aria-label="Saturday Night Live: When Your Animal Crossing Animals Hate You" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/713/snl_acnh_square-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/713/snl_acnh_square-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/713/snl_acnh_square-151x151.jpg&quot;]">
          <img alt="Saturday Night Live: When Your Animal Crossing Animals Hate You" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/games/animal-crossing/snl-animal-crossing/">
        <b class="title"><i>Saturday Night Live</i>: When Your Animal Crossing Animals Hate You</b>
        <b class="byline hide-for-large">By Garrett Martin</b>
        <b class="time hide-for-medium" data-iso-date="2020-05-18T14:15:13-06:00">May 18, 2020</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/comedy/coronavirus/john-oliver-sports-coronavirus/" aria-label="John Oliver Examines the Relationship Between Sports and the Coronavirus—and Introduces Your New Sports Obsession" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/704/john_oliver_sports_square-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/704/john_oliver_sports_square-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/704/john_oliver_sports_square-151x151.jpg&quot;]">
          <img alt="John Oliver Examines the Relationship Between Sports and the Coronavirus—and Introduces Your New Sports Obsession" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/comedy/coronavirus/john-oliver-sports-coronavirus/">
        <b class="title">John Oliver Examines the Relationship Between Sports and the Coronavirus&#8212;and Introduces Your New Sports Obsession</b>
        <b class="byline hide-for-large">By Garrett Martin</b>
        <b class="time hide-for-medium" data-iso-date="2020-05-18T12:45:00-06:00">May 18, 2020</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/comedy/mr-show/mr-show-zoomtacular-charity/" aria-label="David Cross and Bob Odenkirk Brought Mr. Show Back for Charity; Here's How to Watch" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/681/mr_show_zoom_getty_square-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/681/mr_show_zoom_getty_square-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/681/mr_show_zoom_getty_square-151x151.jpg&quot;]">
          <img alt="David Cross and Bob Odenkirk Brought Mr. Show Back for Charity; Here's How to Watch" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/comedy/mr-show/mr-show-zoomtacular-charity/">
        <b class="title">David Cross and Bob Odenkirk Brought Mr. Show Back for Charity; Here's How to Watch</b>
        <b class="byline hide-for-large">By Garrett Martin</b>
        <b class="time hide-for-medium" data-iso-date="2020-05-14T14:45:21-06:00">May 14, 2020</b>
      </a>
    </li>
    <li class="more">
      <a href="/articles/comedy/news/">More Comedy News</a>
    </li>
  </ul>
</div>      <div id="right-column-sticky" class="dfp cell" data-sticky-container><div class="sticky" data-sticky data-sticky-on="large" data-anchor="right-column-sticky"><div id="bottom_rectangle"><script>adCommands.push(function(ads){ads.prime("bottom_rectangle")});</script></div></div></div>
<!--Detail Page Right Column Rendered: 5/19/2020 1:38:36 PM -->
</aside>

    </div>
  </div>
</div>

        </div>
      </main>
      <footer id="master-footer" class="row">
  <ul>
    <li><a href="/about">About</a></li>
    <li><a href="/advertise">Advertise</a></li>
    <li><a href="/contributor-information">Masthead</a></li>
    <li><a href="/privacy">Privacy</a></li>
    <li><a href="/copyright">Copyright</a></li>
    <li class="break"></li>
    <li><a href="/newsletter">Newsletter</a></li>
	<li><a href="https://www.wolfgangs.com/paste-magazine-merch/" target="_blank" rel="noopener">Merch</a></li>
    <li><a class="non" href="/install-the-paste-app.html">Mobile App</a></li>
	<li><a href="https://www.facebook.com/PasteMagazine" target="_blank" rel="noopener">Facebook</a></li>
	<li><a href="https://twitter.com/pastemagazine" target="_blank" rel="noopener">Twitter</a></li>
    <li><a href="/customer-service">Contact Us</a></li>
  </ul>
  <p>&copy; 2020 Paste Media Group. All Rights Reserved</p>
</footer>
<script async src="https://ap.lijit.com/www/sovrn_beacon_standalone/sovrn_standalone_beacon.js?iid=13403293" id="sBeacon"></script>
<script>var captify_kw_query_12314 = "";(function(c,a,p,t,i,f,y){i=c.createElement(a);t=c.getElementsByTagName(a)[0];i.type='text/javascript';i.async=true;i.src=p;t.parentNode.insertBefore(i,t);})(document,'script','https://p.cpx.to/p/12314/px.js');</script>
      <div id="bottom-fixed-unit" class="dfp"><div><div id="bottom_leaderboard_rectangle" class="show"><script>adCommands.push(function(ads){ads.prime("bottom_leaderboard_rectangle")});</script></div><a href="#" class="non icon-cancel"><!--hide button--></a></div></div>
    
<div class="aspNetHidden">

	<input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="4408B798" />
</div></form>
    <script src="https://www.pastemagazine.com/pastemagazine.js/javascript.js?cb=39.2020.10409.11618.2"></script>
<script src="https://cdn.conversant.mgr.consensu.org/gdpr/cmp/config/p/a/pastemagazine.com/config.js"></script>
<script src="https://secure-cdn.mplxtms.com/gdpr/cmp/gdpr-cmp-bootstrap.js"></script>
<!--Rendered: 5/19/2020 1:38:36 PM -->
<!--HealthCheckOK:PM-->

  </body>
</html>
