<!doctype html>
<html class="no-js" lang="en" dir="ltr">
  <head id="Meta_HeadTag"><title>Record Time: New &amp; Notable Vinyl Releases - RSD Drops 2022 Edition - Paste</title><meta charset="utf-8" />
<link rel="shortcut icon" href="/pastemagazine.img/favicon.ico" type="image/vnd.microsoft.icon"/>
<script>
var pm = {
   servers: {
       pastemagazine: "www.pastemagazine.com",
       wolfgangs: "www.wolfgangs.com"
   },
   version: "39.2022.10209.11821.2",
   page: {"type":"Article","mediaType":"Music","articleType":"Features","articleId":361293,"author":"Robert Ham","services":"/pastemagazine.svc/pastemagazine/","isMobile":false,"isIos":false,"videoEmbedPlayerId":30540132,"testGroup":null,"adblocker":true}
};
</script>
<!-- Google Tag Manager -->
<script id="gtm-script">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P8HM6Q9');</script>
<!-- End Google Tag Manager -->
<script>window.pageloadTimer = new Date()</script>
<link rel="standout" href="https://www.pastemagazine.com/movies/in-theaters/the-10-best-movies-in-theaters-right-now/" />
<link rel="alternate" type="application/rss+xml" title="Recent Paste Articles" href="https://www.pastemagazine.com/recent.xml" />
<link rel="canonical" href="https://www.pastemagazine.com/music/record-time-new-notable-vinyl-releases-rsd-drops/" />
<meta http-equiv="x-ua-compatible" content="ie=edge" />
<meta name="title" content="Record Time: New & Notable Vinyl Releases - RSD Drops 2022 Edition - Paste Magazine" />
<meta name="keywords" content="abba, collective soul, dave douglas, frank sinatra, michael rault, record store day, record time, roxy music, the cranberries, Record Time: New & Notable Vinyl Releases - RSD Drops 2022 Edition, Features, Features, Articles, Paste" />
<meta name="news_keywords" content="abba, collective soul, dave douglas, frank sinatra, michael rault, record store day, record time, roxy music, the cranberries" />
<meta property="fb:admins" content="679468950" />
<meta property="fb:admins" content="1185614656" />
<meta property="fb:app_id" content="127550380613969" />
<meta property="fb:pages" content="18512903240" />
<meta name="apple-mobile-web-app-title" content="Paste Magazine"/>
<link rel="icon" sizes="196x196" href="https://cdn.pastemagazine.com/images/mobile-icon-196.png"/>
<link rel="icon" sizes="128x128" href="https://cdn.pastemagazine.com/images/mobile-icon-128.png" />
<link rel="apple-touch-icon" sizes="57x57" href="https://cdn.pastemagazine.com/images/mobile-icon-57.png" />
<link rel="apple-touch-icon" sizes="72x72" href="https://cdn.pastemagazine.com/images/mobile-icon-72.png" />
<link rel="apple-touch-icon" sizes="144x144" href="https://cdn.pastemagazine.com/images/mobile-icon-144.png" />
<meta property="og:image" content="https://cdn.pastemagazine.com/www/articles/recordtime1.jpg" />
<meta property="og:image:width" content="633" />
<meta property="og:image:height" content="356" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.pastemagazine.com/music/record-time-new-notable-vinyl-releases-rsd-drops/" />
<meta property="og:title" content="Record Time: New & Notable Vinyl Releases - RSD Drops 2022 Edition" />
<meta property="og:site_name" content="pastemagazine.com" />
<meta property="og:description" content="" />
<meta property="article:tag" content="abba" />
<meta property="article:tag" content="collective soul" />
<meta property="article:tag" content="dave douglas" />
<meta property="article:tag" content="frank sinatra" />
<meta property="article:tag" content="michael rault" />
<meta property="article:tag" content="record store day" />
<meta property="article:tag" content="record time" />
<meta property="article:tag" content="roxy music" />
<meta property="article:tag" content="the cranberries" />
<meta property="article:section" content="Music" />
<meta property="article:published_time" content="2022-06-17T02:51:45-07:00" />
<meta property="article:modified_time" content="2022-06-17T10:00:07-07:00" />
<meta property="article:publisher" content="https://www.facebook.com/PasteMagazine" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@pastemagazine" />
<meta name="twitter:title" content="Record Time: New & Notable Vinyl Releases - RSD Drops 2022 Edition" />
<meta name="twitter:description" content="" />
<meta name="twitter:image" content="https://cdn.pastemagazine.com/www/articles/recordtime1.jpg" />
<meta name="p:domain_verify" content="8f36922bc91ba221f10d82c407d8b6a9"/>
<meta name="viewport" content="viewport-fit=cover, width=device-width, initial-scale=1.0, maximum-scale=1.0" />
<link rel="dns-prefetch" href="https://hb.adtelligent.com" />
<link rel="dns-prefetch" href="https://ib.adnxs.com" />
<link rel="dns-prefetch" href="https://web.hb.ad.cpe.dotomi.comm" />
<link rel="dns-prefetch" href="https://ap.lijit.com" />
<link rel="preload"  as="style"  type="text/css" href="https://images.wolfgangsvault.com/images/css/article/inline-39.2022.10209.11821.css"/>
<link rel="preload"  as="style"  type="text/css" href="https://images.wolfgangsvault.com/images/css/article/stylesheet-39.2022.10209.11821.css"/>
<link rel="preload" as="image" type="image/jpeg" href="https://cdn.pastemagazine.com/www/articles/recordtime1.jpg"/>

<link rel="preload" as="script"  href="https://www.pastemagazine.com/pastemagazine.js/article/javascript.js?cb=39.2022.10209.11821.2"></script>
<link rel="preload" as="image" type="image/png" href="https://cdn.pastemagazine.com/images/landing-header-bg.png"/>
<link rel="stylesheet" type="text/css" href="https://images.wolfgangsvault.com/images/css/article/inline-39.2022.10209.11821.css"/>
<link rel="stylesheet"  type="text/css" href="https://images.wolfgangsvault.com/images/css/article/stylesheet-39.2022.10209.11821.css"/>
<script type="application/ld+json">[{"@context":"https://schema.org","@type":"Article","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.pastemagazine.com/music/record-time-new-notable-vinyl-releases-rsd-drops/","inLanguage":"en-US"},"datePublished":"2022-06-17T02:51:45-07:00","dateModified":"2022-06-17T10:00:07-07:00","articleSection":"Music","author":{"@type":"Person","name":"Robert Ham"},"headline":"Record Time: New \u0026 Notable Vinyl Releases - RSD Drops 2022 Edition","url":"https://www.pastemagazine.com/music/record-time-new-notable-vinyl-releases-rsd-drops/","thumbnailUrl":"https://cdn.pastemagazine.com/www/articles/recordtime1.jpg","image":{"@type":"ImageObject","url":"https://cdn.pastemagazine.com/www/articles/recordtime1.jpg","width":633,"height":356},"publisher":{"@type":"Organization","url":"https://pastemagazine.com/","name":"Paste Magazine","logo":{"@type":"ImageObject","url":"https://cdn.pastemagazine.com/images/master-header-logo.png","width":650,"height":179},"potentialAction":{"@type":"SearchAction","target":"https://pastemagazine.com/search?t={search_term_string}","query-input":"required name=search_term_string"}},"keywords":["abba","collective soul","dave douglas","frank sinatra","michael rault","record store day","record time","roxy music","the cranberries"]},{"@type":"BreadcrumbList","@id":"https://www.pastemagazine.com/music/record-time-new-notable-vinyl-releases-rsd-drops/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"/","url":"https://pastemagazine.com/","name":"Paste Magazine"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"/music","url":"https://pastemagazine.com/music","name":"Paste Music"}},{"@type":"ListItem","position":3,"item":{"@type":"WebPage","@id":"/articles/music/features/","url":"https://pastemagazine.com/articles/music/features/","name":"Most Recent Music Features"}}]}]</script>
<script>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];</script>
<script>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</script>
<script>let retries=0,alreadySent=false;window.gtmEventSend=function(){if(dataLayer && !alreadySent){alreadySent=true;dataLayer.push({'event':'detectioncomplete'});}else if(retries<6 && !alreadySent){retries++;setTimeout(gtmEventSend,250);}}</script>

</head>
  <body class="undecided">
    <!-- Google Tag Manager (noscript) -->
    
    <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-P8HM6Q9" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
    <!-- End Google Tag Manager (noscript) -->
    <div class="screen"></div>
    <form method="post" action="/music/record-time-new-notable-vinyl-releases-rsd-drops/" id="PageForm">
<div class="aspNetHidden">
<input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="nwguyPtsJV4wZnFSyzXyqSqtg2Gdbq8ggJ+AIzpGzq6UmCgCTKhw05QpDKT+r1l41GP7pmAkIy6Lx2P7aHW2mNztWUDcLcUgmyoDw2Cp9wk=" />
</div>

      <div id="top_leaderboard">
  <script>adCommands.push(function(ads){ads.prime("top_leaderboard")});</script>
</div>
<div class="expanded site-navigation" id="site_navigation" data-pagetype="Article">
  <div class="grid-container">
    <header id="master-header" class="grid-y detail top-bar">
      <div class="top-bar-container grid-x">
        <div class="top-bar-right hide-for-large cell">
          <a href="#" class="menu" aria-label="Section Menu" data-toggle="small-navigation-menu">Sections <i class="icon-menu"><!--icon--></i></a>
          <ul class="vertical dropdown-pane menu" id="small-navigation-menu" data-dropdown="" data-position="left" data-alignment="top" data-close-on-click="true" data-auto-focus="false">
            <li>
              <a href="/music" class="active">Music</a>
            </li>
            <li>
              <a href="/movies" class="large-1 cell">Movies</a>
            </li>
            <li>
              <a href="/tv" class="large-1 cell">TV</a>
            </li>
            <li>
              <a href="/comedy" class="large-1 cell">Comedy</a>
            </li>
            <li>
              <a href="/games" class="large-1 cell">Games</a>
            </li>
            <li>
              <a href="/books" class="large-1 cell">Books</a>
            </li>
            <li>
              <a href="/food" class="large-1 cell">Food</a>
            </li>
            <li>
              <a href="/drink" class="large-1 cell">Drink</a>
            </li>
            <li>
              <a href="/travel" class="large-1 cell">Travel</a>
            </li>
            <li>
              <a href="/tech" class="large-1 cell">Tech</a>
            </li>
            <li class="empty">
              <!--to force order-->
            </li>
            <li class="hide-not-large">
              <a href="/noisetrade/music/">NoiseTrade</a>
            </li>
            <li class="hide-not-large">
              <a href="/studio">Video</a>
            </li>
            <li class="hide-not-large">
              <a href="/newsletter">Newletter</a>
            </li>
            <li class="hide-not-large">
              <a href="/movies/best-movies-on-netflix/">Netflix</a>
            </li>
            <li class="hide-not-large">
              <a href="/movies/best-movies-amazon-prime/">Amazon</a>
            </li>
            <li class="hide-not-large">
              <a href="/movies/hbo-max/best-movies-on-hbo-max/">HBO Max</a>
            </li>
            <li class="hide-not-large">
              <a href="/movies/hulu/best-movies-hulu/">Hulu</a>
            </li>
            <li class="hide-not-large">
              <a href="/movies/disney-/best-movies-on-disney/">Disney+</a>
            </li>
          </ul>
        </div>
        <div class="title-bar grid-x cell align-bottom">
          <div class="large-1 medium-1 small-5 cell logo">
            <a href="/">
              <svg id="Layer_1" data-name="Layer 1" viewBox="0 0 650 179.07" xmlns="http://www.w3.org/2000/svg">
                <defs>
                  <style>path{fill:#363636;}</style>
                </defs>
                <title>Paste Magazine</title>
                <path d="M-23,430c32.81.05,65.63-.15,98.44.3A80.51,80.51,0,0,1,109.31,438c15.81,7.56,23.79,20.31,24.42,37.65.64,17.58-6.38,30.94-22.21,39.32-12.48,6.61-25.85,9.62-39.84,10-10.33.24-20.66.22-31,0-3.54-.06-4.54,1.16-4.52,4.58q.18,30.48,0,61c0,3.52,1.15,4.63,4.62,4.52,7.44-.21,14.89-.06,22.62-.06V604H-23v-9H2.77V440H-23Zm60.22,9.06a13.11,13.11,0,0,0-.87,2.61q-.08,35.46-.13,70.93c0,2.71,1.33,3.34,3.73,3.32,10.66-.1,21.32,0,32-.13,10.26-.12,17.35-5.09,21.22-14.56,6.16-15.11,6.39-30.46,1.29-45.86-2.46-7.44-7.51-13.3-15.4-14.09C65.05,439.88,51,439.73,37.22,439.06Z" transform="translate(23 -427.93)" />
                <path d="M173,607c-1.92-.47-3.84-1-5.78-1.41-21.1-4.74-33.91-22-32.63-44,1.3-22.15,11.19-38,33.16-44.78q18.81-5.85,37.67-11.57c27-8.15,26.39-16.89,24.43-39.1-1.23-14-11.62-23.39-27-24.85-7.66-.72-15.63.06-23.29,1.27-10.07,1.59-17.22,7.85-21.11,17.23-2.34,5.64-3.58,11.74-5.62,17.53-.55,1.58-2.2,2.79-3.34,4.17-.64-1.57-1.81-3.13-1.83-4.71-.24-12.65-.19-25.31-.39-38-.06-4.11,1.88-5.37,5.7-5.81,13-1.5,26-3.34,39.07-5.05h12c2.77.44,5.53.9,8.31,1.32,24.22,3.64,37,17.29,38.5,42.25.87,14.77.68,29.62.75,44.43.11,22,0,44,0,66,0,10.76,3,14.22,13.61,15.94,1.8.3,3.73.29,5.38,1s2.76,1.93,4.12,2.94c-1.49.72-2.95,2-4.46,2-6,.24-12,.1-18,.1h-7c-8.12,0-8.12,0-11.14-7.58-2.7-6.76-3.07-6.86-9-2.73a73.15,73.15,0,0,1-32.34,12.32c-1.63.22-3.21.7-4.82,1.06Zm57.46-67.13c0-7.66.12-15.32,0-23-.1-5.29-2.06-6.57-7-4.74q-23.65,8.73-47.23,17.64a27.25,27.25,0,0,0-15,13.27c-6.19,11.83-3.68,32.87,5.89,42.16a29.83,29.83,0,0,0,14.07,7.72c14.31,2.87,27.42-1,38.66-10.35a28.14,28.14,0,0,0,10.66-22.73C230.43,553.2,230.47,546.54,230.46,539.87Z" transform="translate(23 -427.93)" />
                <path d="M340,428c5.45,1.42,11.08,2.34,16.28,4.39,5.36,2.1,10.29,5.3,15.59,8.11,4.72-2.23,6-10.39,13.77-9.36v46.52h-7.35c-1-11.74-7.82-20.39-16.15-28.12-15.35-14.24-40.23-14.54-54.46-.65-13.06,12.75-9.67,29.86,7.55,36,11.9,4.25,24.14,7.51,36.22,11.24,2.86.88,5.72,1.79,8.52,2.84,18.88,7.15,30.54,20.4,33.34,40.62,2.61,18.82-.69,36.21-14.23,50.55-15.06,16-41.2,20.94-63.45,11.93-5.35-2.17-10.37-5.15-15.86-7.91-5.51,2.14-8,10.35-16.2,9.86V552.42h6.89c1.48,4.45,2.78,9.06,4.52,13.5,9.84,25.07,36.86,36.49,61.64,26.16,14.51-6.06,23-18,22.48-31.63-.23-6.55-2.39-12.5-8-15.86A184,184,0,0,0,346.35,532c-8.28-3.4-17.07-5.56-25.65-8.22-32.73-10.17-41-41.25-32.19-66.28,5.66-16.11,18.2-24.91,34.68-28.37,1.61-.34,3.21-.75,4.81-1.13Z" transform="translate(23 -427.93)" />
                <path d="M616.8,570.12l9.63,8.64c-1.67,1.84-3.11,3.58-4.7,5.17-26.38,26.35-73.09,29.56-102.91,7.1-18.08-13.62-25.64-34-19.75-53.56,4.15-13.81,13.89-22.8,26.18-29.39,4-2.17,8.27-4,12.83-6.13-3.89-2.17-7.46-3.86-10.71-6-16.35-10.85-20-30.8-8.66-46.7,19.31-27.11,69.5-27.3,88.45.07-2.52,2.4-5.11,4.84-7.91,7.5-6.75-7.16-14.49-11.61-24.11-12.4-19.19-1.58-33.29,12.48-30.33,30.33,1.87,11.24,11.67,19.61,24.5,20.4,6.61.41,13.27.07,20.27.07v12.41H579.17a53,53,0,0,0-28.53,7.76c-25.12,15.62-25.59,49.34-.95,65.74,19.49,13,47,10,63.31-6.86C614.16,573.05,615.26,571.8,616.8,570.12Z" transform="translate(23 -427.93)" />
                <path d="M420.11,481.56h-20V469.69H420V431.85l33.92-2.18v39.89h30.23v12H454.07v5.93q0,42.72,0,85.46a51.83,51.83,0,0,0,.28,6c.61,5.39,2.2,10.45,8.14,11.92,6.18,1.52,12.19.54,16.27-4.84,2.86-3.76,4.91-8.15,7.46-12.51l5,2.61c-1.74,13.29-14.42,26.2-28.52,27.55-8.66.82-17.59,0-26.28-1s-13.72-7.05-15.25-15.61a68.72,68.72,0,0,1-1-11.9c-.08-29,0-58,0-87Z" transform="translate(23 -427.93)" />
              </svg>
            </a>
          </div><div class="grid-x article-shares-links four">
  <a href="https://www.pastemagazine.com/music/record-time-new-notable-vinyl-releases-rsd-drops/" data-title="Record Time: New &amp; Notable Vinyl Releases - RSD Drops 2022 Edition" class="small-3 icon-facebook">Share</a>
  <a href="https://www.pastemagazine.com/music/record-time-new-notable-vinyl-releases-rsd-drops/" data-title="Record Time: New &amp; Notable Vinyl Releases - RSD Drops 2022 Edition" class="small-3 icon-twitter">Tweet</a>
  <a href="https://www.pastemagazine.com/music/record-time-new-notable-vinyl-releases-rsd-drops/" data-title="Record Time: New &amp; Notable Vinyl Releases - RSD Drops 2022 Edition" class="small-3 icon-reddit-alien only-view-large">Submit</a>
  <a href="https://www.pastemagazine.com/music/record-time-new-notable-vinyl-releases-rsd-drops/" data-title="Record Time: New &amp; Notable Vinyl Releases - RSD Drops 2022 Edition" data-image="https://cdn.pastemagazine.com/www/articles/recordtime1.jpg" class="small-3 icon-pinterest">Pin</a>
</div></div>
        <nav>
          <div class="show-for-medium cell horizontal">
            <a href="/noisetrade/music/" class="icon-rss large-auto">NoiseTrade</a>
            <b class="div">
              <!--divider-->
            </b>
            <a href="/studio" class="icon-video large-auto">Video</a>
            <b class="div">
              <!--divider-->
            </b>
            <a href="/newsletter" class="icon-newspaper large-auto">Newsletter</a>
            <b class="div">
              <!--divider-->
            </b>
            <a href="/movies/best-movies-on-netflix/" class="icon-newspaper large-auto">Netflix</a>
            <b class="div">
              <!--divider-->
            </b>
            <a href="/movies/best-movies-amazon-prime/" class="icon-newspaper large-auto">Amazon</a>
            <b class="div">
              <!--divider-->
            </b>
            <a href="/movies/hbo-max/best-movies-on-hbo-max/" class="icon-newspaper large-auto">HBO Max</a>
            <b class="div">
              <!--divider-->
            </b>
            <a href="/movies/hulu/best-movies-hulu/" class="icon-newspaper large-auto">Hulu</a>
            <b class="div">
              <!--divider-->
            </b>
            <a href="/movies/disney-/best-movies-on-disney/" class="icon-newspaper large-auto">Disney+</a>
          </div>
          <a href="/music" class="active">Music</a>
          <a href="/movies">Movies</a>
          <a href="/tv">TV</a>
          <a href="/comedy">Comedy</a>
          <a href="/games">Games</a>
          <a href="/books">Books</a>
          <a href="/food">Food</a>
          <a href="/drink">Drink</a>
          <a href="/travel">Travel</a>
          <a href="/tech">Tech</a>
          <a class="large-auto medium-auto cell search closed icon-search" href="/search" aria-label="Search">
            <!--search-->
          </a>
          <div class="top-bar-right show-for-large cell">
            <a href="#" class="menu" aria-label="Section Menu" data-toggle="large-navigation-menu">
              <i class="icon-menu">
                <!--icon-->
              </i>
            </a>
            <ul class="vertical dropdown-pane menu" id="large-navigation-menu" data-dropdown="" data-position="left" data-alignment="top" data-close-on-click="true" data-auto-focus="false">
              <li>
                <a href="/noisetrade/music/">NoiseTrade</a>
              </li>
              <li>
                <a href="/studio">Video</a>
              </li>
              <li>
                <a href="/newsletter">Newsletter</a>
              </li>
              <li>
                <a href="/movies/best-movies-on-netflix/">Netflix</a>
              </li>
              <li>
                <a href="/movies/best-movies-amazon-prime/">Amazon</a>
              </li>
              <li>
                <a href="/movies/hbo-max/best-movies-on-hbo-max/">HBO Max</a>
              </li>
              <li>
                <a href="/movies/hulu/best-movies-hulu/">Hulu</a>
              </li>
              <li>
                <a href="/movies/disney-/best-movies-on-disney/">Disney+</a>
              </li>
            </ul>
          </div>
        </nav>
      </div></header>
    <div class="header-top-ad cell center dfp">
    </div>
  </div>
</div>
      <main class="expanded site-body" id="site_body">
        <div class="grid-container">
          
   
<div id="article_detail_wrapper" class="grid-x article-wrapper">
  <div class="large-12 cell">
    <div class="grid-x small-up-1 medium-up-2 large-up-12">
      <div class="large-auto medium-auto small-auto">
        <article id="article-detail-container">
  <div class="header" data-entry-id="361293">
    <h1 class="title">Record Time: New & Notable Vinyl Releases - RSD Drops 2022 Edition</h1>
    <div class="bylinepublished">By <a class="ovr" href="/writers?name=robert+ham">Robert Ham</a>  |  June 17, 2022  |  10:00am</div>
    <b class="type">
      <a class="non" href="/music">Music</a> <a class="non" href="/articles/music/features/">Features</a></b>
  </div>
  <div class="grid-x article-shares-links four">
    <a href="https://www.pastemagazine.com/music/record-time-new-notable-vinyl-releases-rsd-drops/" data-title="Record Time: New &amp; Notable Vinyl Releases - RSD Drops 2022 Edition" class="small-3 icon-facebook">Share</a>
    <a href="https://www.pastemagazine.com/music/record-time-new-notable-vinyl-releases-rsd-drops/" data-title="Record Time: New &amp; Notable Vinyl Releases - RSD Drops 2022 Edition" class="small-3 icon-twitter">Tweet</a>
    <a href="https://www.pastemagazine.com/music/record-time-new-notable-vinyl-releases-rsd-drops/" data-title="Record Time: New &amp; Notable Vinyl Releases - RSD Drops 2022 Edition" class="small-3 icon-reddit-alien only-view-large">Submit</a>
    <a href="https://www.pastemagazine.com/music/record-time-new-notable-vinyl-releases-rsd-drops/" data-title="Record Time: New &amp; Notable Vinyl Releases - RSD Drops 2022 Edition" data-image="https://cdn.pastemagazine.com/www/articles/recordtime1.jpg" class="small-3 icon-pinterest">Pin</a>
  </div>
  <div class="main-image">
    <img src="https://cdn.pastemagazine.com/www/articles/recordtime1.jpg" alt="Record Time: New &amp; Notable Vinyl Releases - RSD Drops 2022 Edition" />
  </div>
  <div class="copy entry manual-ads">
    <p>Record Time <i>is Paste’s monthly column that takes a glimpse into the wide array of new vinyl releases currently flooding record stores around the world, and all the gear that is part of the ongoing surge in vinyl culture. Rather than run down every fresh bit of wax in the marketplace, we’ll home in on special editions, reissues and unusual titles that come across our desk with an interest in discussing both the music and how it is pressed and presented. This month we prepare you for this month’s RSD Drops with a rundown of some of the exclusive releases out on Saturday, as well as a listen to some fresh new wax from The Cranberries, Roxy Music, Dave Douglas and more.</i></p>
    <p>
      <img data-sources="[&quot;https://cdn.pastemagazine.com/www/articles/2022/06/17/NRTR1758.jpg&quot;]" data-sizes="[]" alt="NRTR1758.jpg" class="mt-image-center lazyload" style="text-align: center; display: block; margin: 0 auto 20px;" />
      <!--work-around to avoid self-close-->
    </p>
    <div class="dfp" data-chars="1474">
      <div id="mid_leaderboard_rectangle_1">
        <script>adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_1")});</script>
      </div>
    </div>
    <h2>
      <a class="big jumplink" id="the-james-brand-x-vinyl-me-please-knife-the-abbey">The James Brand X Vinyl Me, Please Knife: The Abbey</a>
    </h2>
    <p />
    <p>What is your go-to tool to help remove the shrinkwrap from a new record? For the past few years, I’ve been using a branded guitar pick thrown at me from the stage by Anthrax bassist Frank Bello. I poke the business end of the pick into the plastic where the sleeve opens up and slice away. It may be time to retire this practice now that I have The Abbey, a fixed blade knife made by The James Brand for the good people at Vinyl Me, Please. It does the exact same job as my trusty guitar pick but with a lot more flair. Each one features an inlay made from a recycled VMP album and is packaged in a lovely leather sheath. This is not a tool for the faint of heart as the sharp instrument requires a touch of precision to make sure you’re not also slicing up the outer or inner sleeve. Still, using it is inarguably more satisfying than a box cutter or guitar pick or whatever method you might otherwise lean on. Also makes for a nice last minute Father’s Day gift for the record nerd in your life.<!--work-around to avoid self-close--></p>
    <div class="dfp" data-chars="1048">
      <div id="mid_leaderboard_rectangle_2">
        <script>adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_2")});</script>
      </div>
    </div>
    <hr />
    <p>
      <img data-sources="[&quot;https://cdn.pastemagazine.com/www/articles/2022/04/21/CollectiveSoul_DisciplinedBreakdown_CoverArt.jpg&quot;]" data-sizes="[]" alt="CollectiveSoul_DisciplinedBreakdown_CoverArt.jpg" class="mt-image-center lazyload" style="text-align: center; display: block; margin: 0 auto 20px;" />
      <!--work-around to avoid self-close-->
    </p>
    <h2>
      <a class="big jumplink" id="collective-soul-disciplined-breakdown">Collective Soul: <i>Disciplined Breakdown</i> (Craft Recordings)</a>
    </h2>
    <p />
    <p>Love them or hate them, the least you can do is respect what Collective Soul have achieved since the Georgia-based alt-rock band arrived on the scene amid the tidal wave that was grunge. They found a sound and a zone and stuck to it through the ’90s and beyond, and they’re still making hay with it as you read this. <i>Disciplined Breakdown</i>, the group’s third studio album, came along at the peak of the band’s success, landing a couple of Mainstream Rock hits and rolling them forward even as they struggled with behind-the-scenes drama. If anything, Ed Roland and co. dialed back the fist-pumping anthemics on this record to better serve their exhausted spirit. To celebrate the 25th anniversary of its release, the album is being re-released on some nice translucent red wax made from lacquers cut by the hardest working man in the vinyl business Kevin Gray.</p>
    <div class="dfp" data-chars="1716">
      <div id="mid_leaderboard_rectangle_3">
        <script>adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_3")});</script>
      </div>
    </div>
    <hr />
    <p>
      <img data-sources="[&quot;https://cdn.pastemagazine.com/www/articles/2022/04/21/EstherMarrow_SisterWoman_Cover.jpg&quot;]" data-sizes="[]" alt="EstherMarrow_SisterWoman_Cover.jpg" class="mt-image-center lazyload" style="text-align: center; display: block; margin: 0 auto 20px;" />
      <!--work-around to avoid self-close-->
    </p>
    <h2>
      <a class="big jumplink" id="esther-marrow-sister-woman">Esther Marrow: <i>Sister Woman</i> (Craft Recordings)</a>
    </h2>
    <p />
    <p>Virginia-born vocalist Esther Marrow’s career in the secular music world was short-lived, lasting only two albums — the second of which, <i>Sister Woman</i>, is an underappreciated treasure of socially-conscious soul and funk that found her holding her own against some of absolute titans: Idris Muhammad, Jimmy Johnson, Cornell Dupree, and Chuck Rainey, to name but a few. The next step of Marrow’s career wasn’t far from this album, as heard in spiritually-minded songs like “And When I Die” and the unexpectedly sultry “Turn On To Jesus.” Original pressings of this album are coveted, making this reissue from Craft Recordings, overseen by the steady hands of mastering engineer Kevin Gray, particularly welcome. Put this on your RSD shopping list right next to the recent reissue of Marvin Gaye’s equally powerful <i>What’s Going On</i>.</p>
    <div class="dfp" data-chars="1673">
      <div id="mid_leaderboard_rectangle_4">
        <script>adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_4")});</script>
      </div>
    </div>
    <hr />
    <p>
      <img data-sources="[&quot;https://cdn.pastemagazine.com/www/articles/2022/04/21/GoAheadPunkCover-01.jpg&quot;]" data-sizes="[]" alt="GoAheadPunkCover-01.jpg" class="mt-image-center lazyload" style="text-align: center; display: block; margin: 0 auto 20px;" />
      <!--work-around to avoid self-close-->
    </p>
    <h2>
      <a class="big jumplink" id="various-go-ahead-punk…-make-my-day">Various: <i>Go Ahead Punk… Make My Day</i> (Nitro / Craft Recordings)</a>
    </h2>
    <p />
    <p>CD versions of this compilation from punk label Nitro Records, which brings together album cuts from artists like Guttermouth and AFI alongside a then-exclusive version of “Hey Joe” recorded by The Offspring are abundant at used record shops the world over. Which has me immediately questioning the necessity for a vinyl pressing of this collection rather than reissues of the albums that these songs were borrowed from. Perhaps this is merely the opening volley for Craft Recordings and we will soon see fresh pressings of Guttermouth’s <i>Friendly People</i> or <i>Image is Everything</i>, the 1996 album by Jughead’s Revenge. Even if that’s the case, my suspicion is that this is one of the RSD releases that is going to remain in shops ad infinitum.</p>
    <div class="dfp" data-chars="1601">
      <div id="mid_leaderboard_rectangle_5">
        <script>adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_5")});</script>
      </div>
    </div>
    <hr />
    <p>
      <img data-sources="[&quot;https://cdn.pastemagazine.com/www/articles/2022/06/17/Linda_Martell_CMC.jpg&quot;]" data-sizes="[]" alt="Linda_Martell_CMC.jpg" class="mt-image-center lazyload" style="text-align: center; display: block; margin: 0 auto 20px;" />
      <!--work-around to avoid self-close-->
    </p>
    <h2>
      <a class="big jumplink" id="linda-martell-color-me-country">Linda Martell: <i>Color Me Country</i> (Sun / ORG Music)</a>
    </h2>
    <p />
    <p>The lone studio album by Black country singer Linda Martell has been reissued at the perfect time as Nashville continues to undergo a reckoning for its tendency to ignore minority voices and works to correct this glaring oversight. In the case of this talented artist, Martell had a moment in the sun with some radio hits in the late ’60s that led to appearances on <i>Hee-Haw</i> and multiple performances for the Grand Ole Opry. But as a more successful (and white) artist started to eclipse Martell, her label put her on the back burner. She never really recovered and wound up retiring from performing. What an absolute shame as her LP <i>Color Me Country</i>, recently reissued on orange wax for the RSD June Drop, has a swing and verve that fits right alongside the work of Glen Campbell, Bobbie Gentry and Loretta Lynn. Leaning into material like “Before The Next Teardrop Falls” and “Color Him Father,” Martell brought in her gospel and R&amp;B roots and gave the songs — and country music as a whole — some much needed life. </p>
    <div class="dfp" data-chars="1865">
      <div id="mid_leaderboard_rectangle_6">
        <script>adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_6")});</script>
      </div>
    </div>
    <hr />
    <p>
      <img data-sources="[&quot;https://cdn.pastemagazine.com/www/articles/2022/06/17/YHU_PSF.jpg&quot;]" data-sizes="[]" alt="YHU_PSF.jpg" class="mt-image-center lazyload" style="text-align: center; display: block; margin: 0 auto 20px;" />
      <!--work-around to avoid self-close-->
    </p>
    <h2>
      <a class="big jumplink" id="young-holt-unlimited-plays-super-fly">Young-Holt Unlimited: <i>Plays Super Fly</i> (Liberation Hall) </a>
    </h2>
    <p />
    <p>Through the ’60s and ’70s, former Ramsey Lewis sidemen Isaac Holt and Eldee Young collaborated on a series of releases that gave a soul / funk overhaul to pop hits like “Wichita Lineman” and “Little Green Apples.” But where they excelled is in making a meal of compositions from other artists in their chosen genre. That’s why this 1973 release, re-issued on yellow wax for the RSD Drop, is one of their best. Much of the first side is taken up with the group’s renditions of material from Curtis Mayfield’s classic Blaxploitation soundtrack <i>Super Fly</i>. Each one is better than the one before, with the highlight being their fuzzy, Latin-tinged version of the title track. Things get even more interesting on the flipside with a 3/4 time breakdown of Tom Bell’s “People Make The World Go Round” and a cover of “Could It Be I’m Falling In Love” that rivals the Spinners’ original. </p>
    <div class="dfp" data-chars="1735">
      <div id="mid_leaderboard_rectangle_7">
        <script>adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_7")});</script>
      </div>
    </div>
    <hr />
    <p>
      <img data-sources="[&quot;https://cdn.pastemagazine.com/www/articles/2022/06/17/DL_TMSOL.jpg&quot;]" data-sizes="[]" alt="DL_TMSOL.jpg" class="mt-image-center lazyload" style="text-align: center; display: block; margin: 0 auto 20px;" />
      <!--work-around to avoid self-close-->
    </p>
    <h2>
      <a class="big jumplink" id="darlene-love-the-many-sides-of-love-—-the-complete-reprise-recordings-plus-">Darlene Love: <i>The Many Sides of Love — The Complete Reprise Recordings Plus!</i> (Real Gone) </a>
    </h2>
    <p />
    <p>We’re not done with Record Store Day proper. One release we missed the first and second time around was this collection of recordings the great Darlene Love made for Reprise Records through her career. It’s a fascinating collection that ranges from the early chirpy pop of her tenure in The Blossoms to some later work that she recorded for the 1990 film <i>Dick Tracy</i> and a duet with Bette Midler. To that end, the first side of the record featuring her ’60s work is far stronger than anything that is more contemporary. Nor is any of it as instantly knee-knockingly great as the material she recorded with Phil Spector. Still, it’s a tidy, nicely designed set that gives Love her due. She’s still going strong today, but it all started right here. </p>
    <div class="dfp" data-chars="1636">
      <div id="mid_leaderboard_rectangle_8">
        <script>adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_8")});</script>
      </div>
    </div>
    <hr />
    <p>
      <img data-sources="[&quot;https://cdn.pastemagazine.com/www/articles/2022/06/17/ABBA_CVBS.jpg&quot;]" data-sizes="[]" alt="ABBA_CVBS.jpg" class="mt-image-center lazyload" style="text-align: center; display: block; margin: 0 auto 20px;" />
      <!--work-around to avoid self-close-->
    </p>
    <h2>
      <a class="big jumplink" id="abba-vinyl-album-box-set">ABBA: <i>Vinyl Album Box Set</i> (Polar)</a>
    </h2>
    <p />
    <p>Record collectors know how plentiful ABBA vinyl is on the secondary market. You don’t sell an estimated 400 million copies of your albums without a few of them ending up in the used bins at record shops or at garage sales and thrift shops. Why then consider dropping a healthy amount of coin on a hulking set containing new vinyl pressing of the Swedish pop titan’s discography up to and including their 2021 reunion album <i>Voyage</i>? Honestly, there’s plenty to tip the needle into the affirmative. The final disc in the set is <i>Tracks</i>, a collection of fantastic non-album tracks, like the <i>very</i> recognizable singles “Gimme Gimme Gimme” and “Fernando” and the underrated “Happy Hawaii.” There’s era-appropriate reproduction inner sleeves for the band’s debut and 1974’s <i>Waterloo</i>. And the pressings sound great, even with the abundance of paper scuffs on each copy. Besides, for the folks who are just now coming to appreciate the brilliance of ABBA’s music, what better way to snap up nearly every note the quartet recorded during their illustrious career? </p>
    <div class="dfp" data-chars="1885">
      <div id="mid_leaderboard_rectangle_9">
        <script>adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_9")});</script>
      </div>
    </div>
    <hr />
    <p>
      <img data-sources="[&quot;https://cdn.pastemagazine.com/www/articles/2022/06/17/RM_Siren.png&quot;]" data-sizes="[]" alt="RM_Siren.png" class="mt-image-center lazyload" style="text-align: center; display: block; margin: 0 auto 20px;" />
      <!--work-around to avoid self-close-->
    </p>
    <h2>
      <a class="big jumplink" id="roxy-music-siren">Roxy Music: <i>Siren</i> / <i>Manifesto</i> (Virgin / UMC)</a>
    </h2>
    <p />
    <p>The latest releases in the ongoing campaign to reissue the discography of Roxy Music lands at an inflection point for the band — the years when the group was slowly shedding the angular, glammy attack of their earliest work and incorporating a sleeker, more commercial sound that would result in chart hits like “Dance Away” and “Angel Eyes,” both songs from 1979’s <i>Manifesto</i>. To get to that point, they had to get through <i>Siren</i>, another album of catty, neon-lit songs brimming with lustful intent and modern malaise, released first in 1975. Between the two, Ferry spun off on his own with a series of solo albums where he played the part of lounge lizard or jet setting rake. By the time Roxy Music reconvened to record <i>Manifesto</i>, Ferry brought those elements of his musical personality with him, as well as a mood of exhaustion. The so-called good life has left him wanting and desperate for any kind of connection. The music follows his lead with yearning tones and anxious energy. Both are the secret masterworks of Roxy’s storied career, and they sound better than ever on these carefully remastered re-releases. </p>
    <div class="dfp" data-chars="1962">
      <div id="mid_leaderboard_rectangle_10">
        <script>adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_10")});</script>
      </div>
    </div>
    <hr />
    <p>
      <img data-sources="[&quot;https://cdn.pastemagazine.com/www/articles/2022/06/17/YT_WAM.jpg&quot;]" data-sizes="[]" alt="YT_WAM.jpg" class="mt-image-center lazyload" style="text-align: center; display: block; margin: 0 auto 20px;" />
      <!--work-around to avoid self-close-->
    </p>
    <h2>
      <a class="big jumplink" id="yukihiro-takahashi-wild-moody">Yukihiro Takahashi: <i>Wild &amp; Moody</i> (ALFA Music)</a>
    </h2>
    <p />
    <p>While not as widely celebrated as his YMO bandmates, Yukihiro Takahashi has had a solo career that is just as dynamic and prolific as Ryuichi Sakamoto and Haruomi Hosono. The difference may be that Yukihiro’s work had a far more commercial sheen. His 1984 release <i>Wild &amp; Moody</i> is unadulterated synthpop given a hard snap via Yukihiro’s live drumming and some musical ballast provided by guests like Be-Bop Deluxe’s Bill Nelson who lends his vocals and guitar to a fist-pumping take on CSNY’s “Helpless,” Icehouse member Iva Davies and both Sakamoto and Hosono. Bouncy enough for the dancefloor but artsy enough for the new school of city pop obsessives. This is just part of a wonderful series of reissues that ALFA Music is doing of Yukihiro’s ’80s work. Each one is worth tracking down and adding to your home library or DJ crate. </p>
    <hr />
    <p>
      <img data-sources="[&quot;https://cdn.pastemagazine.com/www/articles/2022/06/17/SInatra_WT.jpg&quot;]" data-sizes="[]" alt="SInatra_WT.jpg" class="mt-image-center lazyload" style="text-align: center; display: block; margin: 0 auto 20px;" />
      <!--work-around to avoid self-close-->
    </p>
    <h2>
      <a class="big jumplink" id="frank-sinatra-watertown">Frank Sinatra: <i>Watertown</i> (Capitol / UMe) </a>
    </h2>
    <p />
    <p>As rock and R&amp;B continued to dominate the listening habits of the world’s citizens, old hands who came up in the jazz era like Frank Sinatra were finding it more and more difficult to connect. To his credit, he made the bold decision to shake things up a bit rather than stay the course. Which is what led him to cut <i>Watertown</i>, a bleak concept album written for him by Bob Gaudio, a member of the Four Seasons, and songsmith Jake Holmes. The songs track the mental anguish of a man left to raise his two sons alone after his wife left the family for an unnamed city, set to music that adds a Wrecking Crew-type groove to the otherwise orchestral backdrop. When it was released in 1970, <i>Watertown</i> tanked, but its stature has only grown since as collectors recognized the Jimmy Webb-like grandeur of the music and the depth of Sinatra’s vocal work. All credit is due to Capitol and UMe for committing the resources to remixing and remastering this cult favorite and reissuing it in this lovely vinyl edition. Original copies of <i>Watertown</i> aren’t that hard to find, but they won’t sound as good as this. </p>
    <hr />
    <p>
      <img data-sources="[&quot;https://cdn.pastemagazine.com/www/articles/2022/06/17/CSTBO.jpg&quot;]" data-sizes="[]" alt="CSTBO.jpg" class="mt-image-center lazyload" style="text-align: center; display: block; margin: 0 auto 20px;" />
      <!--work-around to avoid self-close-->
    </p>
    <h2>
      <a class="big jumplink" id="the-cranberries-stars-the-best-of-1992-2002">The Cranberries: <i>Stars: The Best of 1992-2002</i> (Island / UMC)</a>
    </h2>
    <p />
    <p>Originally released in 2002, the greatest hits compilation <i>Stars</i> marked the end of the Cranberries’ first era as a band. The following year, the Irish alt-rockers would take an extended hiatus to pursue solo projects and tend to their families. Re-released this month on vinyl for the first time, it still serves as a quick overview of the rapid progression this band took from the dreampop sound of its 1993 debut, represented here by the still-impactful “Dreams” and “Linger,” to the jagged tone of their 2001 album <i>Wake Up And Smell The Coffee</i>. For fans of the Cranberries, this set is especially enticing as it features different edits of several singles and a pair of songs recorded for the compilation: the grunge-y “New New York” and the title track. The music suffers a bit in the transition to a vinyl release with a few songs sounding fuzzy and digitized. The same goes for the photos on the inner sleeves, which look like they were awkwardly blown up from the CD booklet. </p>
    <hr />
    <p>
      <img data-sources="[&quot;https://cdn.pastemagazine.com/www/articles/2022/06/17/americanarailroad.jpeg&quot;]" data-sizes="[]" alt="americanarailroad.jpeg" class="mt-image-center lazyload" style="text-align: center; display: block; margin: 0 auto 20px;" />
      <!--work-around to avoid self-close-->
    </p>
    <h2>
      <a class="big jumplink" id="v-a-americana-railroad">V/A: <i>Americana Railroad</i> (Renew / BMG)</a>
    </h2>
    <p />
    <p>The train and rail travel have been mainstays of folk, blues and country songs, representing as it does the possibilities of travel and exploration and the heartbreak of watching a loved one disappear over the horizon. This collection of tunes celebrating the thrills and pitfalls of the railroad originally dropped on vinyl last year on RSD Black Friday, but is getting a wider release this week digitally and on CD. It’s great that folks will be able to hear this music on the go, as this fine compilation, which includes contributions from Dave Alvin, Carla Olson (who also served as producer for the project), Peter Case and John Fogerty, the latter of which performs a loose and lively take on “City of New Orleans,” works well as the soundtrack to a road trip or morning commute. But if we’re being honest, the vinyl version is best with its rich analog tone adding that perfect layer of nasty warmth to Gary Myrick’s ripping version of “Train Kept A-Rollin’” and spiritual longing on Deborah Poppink’s lovely spin through “People Get Ready.” <!--work-around to avoid self-close--></p>
    <hr />
    <p>
      <img data-sources="[&quot;https://cdn.pastemagazine.com/www/articles/2022/06/17/CF_BTWT.png&quot;]" data-sizes="[]" alt="CF_BTWT.png" class="mt-image-center lazyload" style="text-align: center; display: block; margin: 0 auto 20px;" />
      <!--work-around to avoid self-close-->
    </p>
    <h2>
      <a class="big jumplink" id="cleveland-francis-beyond-the-willow-tree">Cleveland Francis: <i>Beyond The Willow Tree</i> (Forager)</a>
    </h2>
    <p />
    <p>The story of Cleveland Francis is, sadly, not an unusual one. When this Southern artist emerged in the late ’60s, playing contemplative folk music, he was ignored by a record industry that couldn’t wrap its collective heads around a Black man singing plaintive covers of Joni Mitchell songs and protest ballads. Instead, he self-released his 1970 album <i>Follow Me</i> to little attention. But no great music stays hidden forever as collectors have discovered Francis’ work and now new label Forager Records is re-releasing it along with an assortment of demos and rarities from the early part of his career. Taken as a whole, <i>Beyond The Willow Tree</i> becomes a heartrending story. Francis’ lightly quavering tenor and the quiet power of his performances should have made him a star. It’s taken over four decades, but now is the chance to elevate this talented artist to his richly deserved place in the folk pantheon alongside the likes of Richie Havens, Dion and Buffy Sainte-Marie. </p>
    <hr />
    <p>
      <img data-sources="[&quot;https://cdn.pastemagazine.com/www/articles/2022/06/17/EK_IGAL.jpg&quot;]" data-sizes="[]" alt="EK_IGAL.jpg" class="mt-image-center lazyload" style="text-align: center; display: block; margin: 0 auto 20px;" />
      <!--work-around to avoid self-close-->
    </p>
    <h2>
      <a class="big jumplink" id="elizabeth-king-i-got-a-love">Elizabeth King: <i>I Got A Love</i> (Bible &amp; Tire)</a>
    </h2>
    <p />
    <p>The new album from gospel queen Elizabeth King looks back as much as it looks forward. Much of the material on this soulful collection pulls from the catalog of D-Vine Spirituals, the Memphis record label that was releasing spiritual soul on 45s during the early ’70s, including some singles by a performer named Sister Elizabeth King. Many years later, she and her friend / producer Juan Shipp plucked some great tunes from the D-Vine catalog and re-recorded them with the help of guitarist Will Sexton and an army of great Tennessee R&amp;B players. The sound is hip-shaking perfection in the mode of Daptone’s throwback magic — all sweet heat and lip-smacking grease. At the same time, King was handed some fresh material from Squirrel Nut Zippers leader Jimbo Mathus, who wrote the smoky title track that beautifully melds the sacred and profane into one slow boiling groove. This is gonna make you sweat and swoon and maybe speak in tongues. <!--work-around to avoid self-close--></p>
    <hr />
    <p>
      <img data-sources="[&quot;https://cdn.pastemagazine.com/www/articles/2022/06/17/SC_TTT.jpg&quot;]" data-sizes="[]" alt="SC_TTT.jpg" class="mt-image-center lazyload" style="text-align: center; display: block; margin: 0 auto 20px;" />
      <!--work-around to avoid self-close-->
    </p>
    <h2>
      <a class="big jumplink" id="stephen-clair-to-the-trees">Stephen Clair: <i>To The Trees</i> (Rock City) </a>
    </h2>
    <p />
    <p>As good as Stephen Clair’s previous eight albums have been, he has found an impressive new gear to slide into on record #9 <i>To The Trees</i>. It may have everything to do with his choice of collaborators. Working with celebrated Athens trio The Restless Age has brought some added bulk to his usually lean and mean tunes thanks to their deep pocket rhythm section and cartwheeling backing vocals. Together, they perfect everything from swinging alt-country (“Make A Bed”) to synthtastic pop (“A Human Echo”) to downcast mood rock (“Lousy Butterfly”) and beyond. The glue for this album is Clair. His lyrics are everyman poetry with a dash of self-deprecation and gallows humor to go with his otherwise uncluttered views of the world around and within him. </p>
    <hr />
    <p>
      <img data-sources="[&quot;https://cdn.pastemagazine.com/www/articles/2022/06/17/Rault.jpg&quot;]" data-sizes="[]" alt="Rault.jpg" class="mt-image-center lazyload" style="text-align: center; display: block; margin: 0 auto 20px;" />
      <!--work-around to avoid self-close-->
    </p>
    <h2>
      <a class="big jumplink" id="michael-rault-michael-rault">Michael Rault: <i>Michael Rault</i> (Wick)</a>
    </h2>
    <p />
    <p>The latest, self-titled album by Michael Rault follows in the footsteps of his previous effort, 2018’s <i>It’s A New Day Tonight</i>, a record on which the Canadian singer-songwriter worked with Daptone Records engineer Wayne Gordon to craft a polyester and sequin pop sound that cushioned Rault’s light and reedy vocals. Though self-produced by the artist, this new LP follows a similar throwback line in a mode similar to the late, great Jellyfish and his buddy Mac Demarco who earned a co-production credit and added percussion and synth on a pair of tracks. But where those two artists could occasionally slide into glam rock and new wave mode, Rault stays comfortable within the silky tones that could easily work in a Yacht Rock playlist or get mixed up in a pot with ’70s-era Todd Rundgren, Paul McCartney and Gerry Rafferty. If this isn’t being blasted in roller rinks around the U.S. before the end of the year, we’ve done something seriously wrong as a nation. </p>
    <hr />
    <p>
      <img data-sources="[&quot;https://cdn.pastemagazine.com/www/articles/2022/06/17/NB_ADR.jpg&quot;]" data-sizes="[]" alt="NB_ADR.jpg" class="mt-image-center lazyload" style="text-align: center; display: block; margin: 0 auto 20px;" />
      <!--work-around to avoid self-close-->
    </p>
    <h2>
      <a class="big jumplink" id="nikki-bluhm-avondale-drive">Nikki Bluhm: <i>Avondale Drive</i> (Compass)</a>
    </h2>
    <p />
    <p>Though singer-songwriter Nikki Bluhm calls Nashville home, she chose to record her new album in L.A. with the help of producer / multi-instrumentalist Jesse Noah Wilson. That combination of sun-soaked musical approaches would generally suggest a kind of Laurel Canyon throwback vibe, there’s something far more funky going on throughout <i>Avondale Drive</i> that feels born of another music-centric town in Tennessee. And like some of the best music to come out of Memphis, Bluhm’s songs come from a place where the soul feels its deepest aches, whether that’s lust, regret, anger or despair. She plumbs the nether regions for fresh insight into the human condition on breathtaking songs like “Leaving Me (Is The Loving Thing To Do)” and “Juniper Woodsmoke.” Spare some credit as well to the crackerjack batch of studio musicians — husband / wife rhythm section Jay Bellerose and Jen Condos, vocalist Paula Frazer and pedal steel player James Pennebaker — that brought all the necessary colors to turn these songs from a simple landscape to a Monet-like masterpiece. </p>
    <hr />
    <p>
      <img data-sources="[&quot;https://cdn.pastemagazine.com/www/articles/2022/06/17/W_Melt.jpg&quot;]" data-sizes="[]" alt="W_Melt.jpg" class="mt-image-center lazyload" style="text-align: center; display: block; margin: 0 auto 20px;" />
      <!--work-around to avoid self-close-->
    </p>
    <h2>
      <a class="big jumplink" id="whimsical-melt">Whimsical: <i>Melt</i> (Through Love / Shelflife)</a>
    </h2>
    <p />
    <p>Indiana dreampop duo Whimsical wear their influences right on their record sleeve. The artwork for their latest album <i>Melt</i> is a knowing homage to familiar 4AD fare like <i>Heaven or Las Vegas</i> and <i>Sweetness and Light</i>. The music on each side of this delicious LP bears the touches of classic shoegaze / dreampop acts too, but never to the point of imitation. Vocalist Krissy Vanderwoude has far more grit in her otherwise delicate performance and the music that her creative partner Neil Burkdoll surrounds her with bubbles and crumbles with a corrosive edge that speaks to the pair’s Midwestern roots. It is those same elements that will help keep the listener alert rather than fully drifting off into a fugue state and keep them attuned to Vanderwoude’s lyrics that go giddy with crushed out desire and go bleak as she sorts through the pieces of a broken relationship. Listen closely. You’ll melt too. </p>
    <hr />
    <p>
      <img data-sources="[&quot;https://cdn.pastemagazine.com/www/articles/2022/06/17/Mohler_anatomy.png&quot;]" data-sizes="[]" alt="Mohler_anatomy.png" class="mt-image-center lazyload" style="text-align: center; display: block; margin: 0 auto 20px;" />
      <!--work-around to avoid self-close-->
    </p>
    <h2>
      <a class="big jumplink" id="billy-mohler-anatomy">Billy Mohler: <i>Anatomy</i> (Contagious Music) </a>
    </h2>
    <p />
    <p>Bassist Billy Mohler is the very model of a modern musician. His resume spans genres and decades, including collaborations with his godfather Bill Medley (of the Righteous Brothers), Sia, Alison Krauss and Airborne Toxic Event. He doesn’t dare sit still. For his latest album under his own name, Mohler returns to pure jazz mode, collaborating once again with a quartet that includes saxophonist Chris Speed, drummer Nate Wood and trumpeter Shane Endsley and locking into a sound that gives a contemporary shine to the modal beauty of Ornette Coleman’s early ’60s releases. Put this LP on at the right high volume or slap on a pair of headphones to spin it or else you might miss what’s happening at the periphery of this recording. Sounds spin off into the distance like a firework or echo into oblivion as if guided by King Tubby, even as the band rides a laidback groove on “Speed Kills” (a tune written by Mohler in honor of his buddy Speed) or kicks into a more tempestuous mood on “Fight Song.” There are layers and layers to <i>Anatomy</i> just waiting to be excavated. Get digging. </p>
    <hr />
    <p>
      <img data-sources="[&quot;https://cdn.pastemagazine.com/www/articles/2022/06/17/DDouglas_OC.jpg&quot;]" data-sizes="[]" alt="DDouglas_OC.jpg" class="mt-image-center lazyload" style="text-align: center; display: block; margin: 0 auto 20px;" />
      <!--work-around to avoid self-close-->
    </p>
    <h2>
      <a class="big jumplink" id="dave-douglas-overcome">Dave Douglas: <i>Overcome</i> (Greenleaf Music) </a>
    </h2>
    <p />
    <p>Much like the aforementioned Billy Mohler, trumpeter Dave Douglas isn’t one to sit still for very long. He keeps a busy calendar of performances around the world, teaches, produces podcasts, writes and records new music constantly and oversees his innovative indie label Greenleaf Music. Through it all, Douglas is still paying close attention to the waves of protest and calls for justice going on here at home and beyond. Inspired by these new civil rights movements, he has gathered together a core group of collaborators — among them, trombonist Ryan Keberle, drummer Rudy Royston and vocalists Camila Meza and Fay Victor — to musically meet the moment with a set of modern jazz songs speaking to the heart of the new social activism through unbound tunes like the scrabbling “Perspective” and a powerful take on the anthem “We Shall Overcome.” The whole album is beautifully shattering as it calls up the spirits of forebears like Langston Hughes and John Lewis and uses their words and history, along with the rolling momentum of the music, to push listeners forward to action.<!--work-around to avoid self-close--></p>
  </div><div class="grid-x grid-padding-x tags"><b class="large-1 medium-1 small-1 cell label">Tags</b><div class="large-11 medium-11 small-11 cell"><h2><a class="non" href="/tag/abba">abba</a></h2><h2><a class="non" href="/tag/collective+soul">collective soul</a></h2><h2><a class="non" href="/tag/dave+douglas">dave douglas</a></h2><h2><a class="non" href="/tag/frank+sinatra">frank sinatra</a></h2><h2><a class="non" href="/tag/michael+rault">michael rault</a></h2><h2><a class="non" href="/tag/record+store+day">record store day</a></h2><h2><a class="non" href="/tag/record+time">record time</a></h2><h2><a class="non" href="/tag/roxy+music">roxy music</a></h2><h2><a class="non" href="/tag/the+cranberries">the cranberries</a></h2></div></div><div class="newsletter-container"><div class="newsletter-copy-container"><p class="copy-a">GET PASTE RIGHT IN YOUR INBOX</p><p class="copy-b">The best music, movies, TV, books, comedy and more.</p><p id="newsletter-signup-result" class="copy-a" /><div id="newsletter-signup" class="copy newsletter-signup"><p class="grid-x grid-margin-x"><input id="newsletter-signup-email" class="medium-8 small-8 cell" type="email" placeholder="email address" name="newsletter-signup-email" /><button type="button" id="newsletter-signup-submit" class="medium-2 small-4 button" text="Sign Up">Sign Up</button><span class="row" style="display:none"><input type="checkbox" id="newsletter-signup-optin" name="newsletter-signup-optin" checked="checked" required="" /><label for="nl-opt-in">Yes, I would like to receive Paste's newsletter</label></span></p></div></div></div></article>
        <div class="grid-x articles-standard" id="article-detail-studio-highlights">
  <div class="large-12 cell articles-header" style="height: auto;">
    <b class="float-left hed">Also in Music</b>
    <ul class="no-bullet articles grid-margin-x flex-container flex-dir-column">
      <li class="grid-x grid-padding-x">
        <a href="/music/perfume-genius-interview-ugly-season/" class="auto cell copy-container noimage">
          <b class="title">Perfume Genius on <i>Ugly Season</i>, "Unfolding" and Finding Harmony in the Body</b>
          <b class="byline">By Natalie Marlin</b>
          <b class="time" data-iso-date="2022-06-15T12:00:00-06:00">June 15, 2022  |  12:00pm</b>
        </a>
      </li>
      <li class="grid-x grid-padding-x">
        <a href="/music/enumclaw/enumclaw-the-best-of-whats-next/" class="auto cell copy-container noimage">
          <b class="title">Enumclaw: The Best of What's Next</b>
          <b class="byline">By Jade Gomez</b>
          <b class="time" data-iso-date="2022-06-15T10:00:00-06:00">June 15, 2022  |  10:00am</b>
        </a>
      </li>
      <li class="grid-x grid-padding-x">
        <a href="/music/bartees-strange/interview-farm-to-table/" class="auto cell copy-container noimage">
          <b class="title">Bartees Strange on <i>Farm to Table</i> and the Joy of Community</b>
          <b class="byline">By Matt Mitchell</b>
          <b class="time" data-iso-date="2022-06-13T12:30:00-06:00">June 13, 2022  |  12:30pm</b>
        </a>
      </li>
      <li class="grid-x grid-padding-x">
        <a href="/music/vince-staples/limbo-beach-interview/" class="auto cell copy-container noimage">
          <b class="title">Vince Staples' Song Remains the Same in <I>Limbo Beach</i></b>
          <b class="byline">By Jade Gomez</b>
          <b class="time" data-iso-date="2022-06-09T13:55:46-06:00">June 9, 2022  |  1:55pm</b>
        </a>
      </li>
      <li class="grid-x grid-padding-x">
        <a href="/music/syd/exclusive-photos-broken-hearts-club-tour/" class="auto cell copy-container noimage">
          <b class="title">Exclusive Photos: Syd at Brooklyn Steel</b>
          <b class="byline">By Jade Gomez</b>
          <b class="time" data-iso-date="2022-06-07T15:50:00-06:00">June 7, 2022  |  3:50pm</b>
        </a>
      </li>
      <li class="grid-x grid-padding-x">
        <a href="/music/solid-sound-festival-2022-recap/" class="auto cell copy-container noimage">
          <b class="title">Solid Sound Festival 2022 Recap: Neko Case, Japanese Breakfast, Wilco and More</b>
          <b class="byline">By Pat King</b>
          <b class="time" data-iso-date="2022-06-06T15:45:00-06:00">June 6, 2022  |  3:45pm</b>
        </a>
      </li>
    </ul>
  </div>
</div><!--Detail Page Bottom Rendered: 6/17/2022 8:11:48 AM -->

      </div>
      <aside class="large-3 medium-3 small-auto">
<!--MOREMEDIATYPEORARTICLETYPE-->
<div class="dfp"><div id="top_rectangle"><script>adCommands.push(function(ads){ads.prime("top_rectangle")});</script></div></div>
<div class="grid-x articles-abbreviated" id="article-detail-most-read">
  <div class="large-12 cell articles-header">
    <a href="/articles/music/most-read/" class="float-left hed">Most Popular</a>
  </div>
  <ul class="articles grid-margin-x flex-container flex-dir-column">
    <li class="grid-x grid-padding-x">
      <a href="/music/mars-junction/winklevoss-twins-band/" class="auto cell copy-container noimage">
        <b class="title">The Winklevi Have a Band</b>
        <b class="byline hide-for-large">By Scott Russell</b>
        <b class="time hide-for-medium" data-iso-date="2022-06-13T16:14:29-06:00">June 13, 2022</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/music/best-new-songs/" class="auto cell copy-container noimage">
        <b class="title">The 10 Best New Songs</b>
        <b class="byline hide-for-large">By Paste Staff</b>
        <b class="time hide-for-medium" data-iso-date="2022-06-16T16:15:00-06:00">June 16, 2022</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/music/new-music/" class="auto cell copy-container noimage">
        <b class="title">10 New Albums to Listen to Today</b>
        <b class="byline hide-for-large">By Paste Staff</b>
        <b class="time hide-for-medium" data-iso-date="2022-06-10T15:25:00-06:00">June 10, 2022</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/music/primavera-sound-porto-2022-best-sets/" class="auto cell copy-container noimage">
        <b class="title">The 12 Best Sets We Saw at Primavera Sound Porto 2022</b>
        <b class="byline hide-for-large">By Clare Martin</b>
        <b class="time hide-for-medium" data-iso-date="2022-06-16T12:15:59-06:00">June 16, 2022</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/music/perfume-genius-interview-ugly-season/" class="auto cell copy-container noimage">
        <b class="title">Perfume Genius on <i>Ugly Season</i>, "Unfolding" and Finding Harmony in the Body</b>
        <b class="byline hide-for-large">By Natalie Marlin</b>
        <b class="time hide-for-medium" data-iso-date="2022-06-15T12:00:00-06:00">June 15, 2022</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/music/broken-bells/james-mercer-brian-burton-teaser/" class="auto cell copy-container noimage">
        <b class="title">Broken Bells Are Teasing Something</b>
        <b class="byline hide-for-large">By Scott Russell</b>
        <b class="time hide-for-medium" data-iso-date="2022-06-15T17:30:41-06:00">June 15, 2022</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/music/bartees-strange/interview-farm-to-table/" class="auto cell copy-container noimage">
        <b class="title">Bartees Strange on <i>Farm to Table</i> and the Joy of Community</b>
        <b class="byline hide-for-large">By Matt Mitchell</b>
        <b class="time hide-for-medium" data-iso-date="2022-06-13T12:30:00-06:00">June 13, 2022</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/music/dehd-best-songs/" class="auto cell copy-container noimage">
        <b class="title">The 10 Best Dehd Songs</b>
        <b class="byline hide-for-large">By Samantha Sullivan</b>
        <b class="time hide-for-medium" data-iso-date="2022-06-14T10:30:00-06:00">June 14, 2022</b>
      </a>
    </li>
    <li class="more">
      <a href="/articles/music/most-read/">More Music Most Popular</a>
    </li>
  </ul>
</div><div class="dfp"><div id="middle_rectangle"><script>adCommands.push(function(ads){ads.prime("middle_rectangle")});</script></div></div>
<div class="grid-x articles-abbreviated" id="article-detail-news">
  <div class="large-12 cell articles-header">
    <a href="/articles/music/news/" class="float-left hed">News</a>
  </div>
  <ul class="articles grid-margin-x flex-container flex-dir-column">
    <li class="grid-x grid-padding-x">
      <a href="/music/whitney/whitney-share-new-single-real-love-announce-forthc/" class="auto cell copy-container noimage">
        <b class="title">Whitney Share New Single "REAL LOVE," Announce Forthcoming Album <i>SPARK</i></b>
        <b class="byline hide-for-large">By Samantha Sullivan</b>
        <b class="time hide-for-medium" data-iso-date="2022-06-16T12:52:37-06:00">June 16, 2022</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/music/beyonce/beyonce-announces-renaissance/" class="auto cell copy-container noimage">
        <b class="title">Beyoncé Announces New Album <I>RENAISSANCE</i></b>
        <b class="byline hide-for-large">By Jade Gomez</b>
        <b class="time hide-for-medium" data-iso-date="2022-06-16T02:20:10-06:00">June 16, 2022</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/music/broken-bells/james-mercer-brian-burton-teaser/" class="auto cell copy-container noimage">
        <b class="title">Broken Bells Are Teasing Something</b>
        <b class="byline hide-for-large">By Scott Russell</b>
        <b class="time hide-for-medium" data-iso-date="2022-06-15T17:30:41-06:00">June 15, 2022</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/music/santigold/santigold-shares-new-single-aint-ready-along-with/" class="auto cell copy-container noimage">
        <b class="title">Santigold Announces New Album <i>Spirituals</i>, Shares New Single "Ain't Ready"</b>
        <b class="byline hide-for-large">By Samantha Sullivan</b>
        <b class="time hide-for-medium" data-iso-date="2022-06-15T14:39:20-06:00">June 15, 2022</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/music/grace-ives/north-american-tour-on-the-ground-video/" class="auto cell copy-container noimage">
        <b class="title">Grace Ives Announces North American Tour, Shares "On the Ground" Video</b>
        <b class="byline hide-for-large">By Scott Russell</b>
        <b class="time hide-for-medium" data-iso-date="2022-06-15T13:32:51-06:00">June 15, 2022</b>
      </a>
    </li>
    <li class="more">
      <a href="/articles/music/news/">More Music News</a>
    </li>
  </ul>
</div>      <div id="right-column-sticky" class="dfp cell" data-sticky-containerx><div class="sticky" data-stickyx data-sticky-onx="large" data-anchor="right-column-sticky"><div id="bottom_rectangle"><script>adCommands.push(function(ads){ads.prime("bottom_rectangle")});</script></div></div></div>
<!--Detail Page Right Column Rendered: 6/17/2022 8:11:48 AM -->
</aside>

    </div>
  </div>
</div>

        </div>
      </main>
      <footer id="master-footer" class="row">
   
  
  <ul style="margin-bottom:0;">
   <li><a href="/about">About</a></li>
    <li><a href="/advertise">Advertise</a></li>
    <li><a href="/contributor-information">Masthead</a></li>
    <li><a href="/privacy">Privacy</a></li>
    <li><a href="/copyright">Copyright</a></li>
	<li><a href="/daytrotter">Daytrotter</a></li>
	<li><a href="https://www.wolfgangs.com/paste-magazine-merch/" target="_blank" rel="noopener">Merch</a></li>
  <!--  <li><a class="non" href="/install-the-paste-app.html">Mobile App</a></li> -->
	<li><a href="https://www.facebook.com/PasteMagazine" target="_blank" rel="noopener">Facebook</a></li>
	<li><a href="https://twitter.com/pastemagazine" target="_blank" rel="noopener">Twitter</a></li>
    <li><a href="/customer-service">Contact Us</a></li>
	</ul>
    
	
	 
  
  <p>&copy; 2022 Paste Media Group. All Rights Reserved</p>
</footer>


      <div id="bottom-fixed-unit" class="dfp"><div><div id="bottom_leaderboard"><script>adCommands.push(function(ads){ads.prime("bottom_leaderboard")});</script></div></div></div>
    
<div class="aspNetHidden">

	<input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="4408B798" />
</div></form>
    <script src="https://www.pastemagazine.com/pastemagazine.js/article/javascript.js?cb=39.2022.10209.11821.2"></script>
<!--Rendered: 6/17/2022 8:11:48 AM -->
<!--HealthCheckOK:PM-->

  </body>
</html>
