<!doctype html>
<html class="no-js" lang="en" dir="ltr">
  <head id="Meta_HeadTag"><title>Whatever Happened to Season 8 of MasterChef Junior? - Paste</title><meta charset="utf-8" />
<link rel="shortcut icon" href="/pastemagazine.img/favicon.ico" type="image/vnd.microsoft.icon"/>
<script>
var pm = {
   servers: {
       pastemagazine: "www.pastemagazine.com",
       wolfgangs: "www.wolfgangs.com"
   },
   version: "39.2021.11029.11229.2",
   page: {"type":"Article","mediaType":"TV","articleType":"Features","articleId":357324,"author":"Jim Vorel","services":"/pastemagazine.svc/pastemagazine/","isMobile":false,"isIos":false,"videoEmbedPlayerId":30540132,"testGroup":null,"adblocker":true}
};
</script>
<!-- Google Tag Manager -->
<script id="gtm-script">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P8HM6Q9');</script>
<!-- End Google Tag Manager -->
<script>window.pageloadTimer = new Date()</script>
<link rel="standout" href="https://www.pastemagazine.com/movies/netflix/best-thrillers-netflix/" />
<link rel="alternate" type="application/rss+xml" title="Recent Paste Articles" href="https://www.pastemagazine.com/recent.xml" />
<link rel="canonical" href="https://www.pastemagazine.com/tv/masterchef/masterchef-junior-season-8-canceled-renewed-gordon-ramsay-daphne-oz/" />
<meta http-equiv="x-ua-compatible" content="ie=edge" />
<meta name="title" content="Whatever Happened to Season 8 of MasterChef Junior? - Paste Magazine" />
<meta name="description" content="Apparently filmed in mid-2019, the cooking show season has never seen the light of day." />
<meta name="keywords" content="cooking shows, daphne oz, fox, gordon ramsay, masterchef, masterchef junior, Whatever Happened to Season 8 of MasterChef Junior?, Features, Features, Articles, Paste" />
<meta name="news_keywords" content="cooking shows, daphne oz, fox, gordon ramsay, masterchef, masterchef junior" />
<meta property="fb:admins" content="679468950" />
<meta property="fb:admins" content="1185614656" />
<meta property="fb:app_id" content="127550380613969" />
<meta property="fb:pages" content="18512903240" />
<meta name="apple-mobile-web-app-title" content="Paste Magazine"/>
<link rel="icon" sizes="196x196" href="https://cdn.pastemagazine.com/images/mobile-icon-196.png"/>
<link rel="icon" sizes="128x128" href="https://cdn.pastemagazine.com/images/mobile-icon-128.png" />
<link rel="apple-touch-icon" sizes="57x57" href="https://cdn.pastemagazine.com/images/mobile-icon-57.png" />
<link rel="apple-touch-icon" sizes="72x72" href="https://cdn.pastemagazine.com/images/mobile-icon-72.png" />
<link rel="apple-touch-icon" sizes="144x144" href="https://cdn.pastemagazine.com/images/mobile-icon-144.png" />
<meta property="og:image" content="https://cdn.pastemagazine.com/www/articles/2021/11/09/gordon-ramsay-masterchef-junior-main.jpg" />
<meta property="og:image:width" content="678" />
<meta property="og:image:height" content="381" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.pastemagazine.com/tv/masterchef/masterchef-junior-season-8-canceled-renewed-gordon-ramsay-daphne-oz/" />
<meta property="og:title" content="Whatever Happened to Season 8 of MasterChef Junior?" />
<meta property="og:site_name" content="pastemagazine.com" />
<meta property="og:description" content="Apparently filmed in mid-2019, the cooking show season has never seen the light of day." />
<meta property="article:tag" content="cooking shows" />
<meta property="article:tag" content="daphne oz" />
<meta property="article:tag" content="fox" />
<meta property="article:tag" content="gordon ramsay" />
<meta property="article:tag" content="masterchef" />
<meta property="article:tag" content="masterchef junior" />
<meta property="article:section" content="TV" />
<meta property="article:published_time" content="2021-11-09T12:01:55-08:00" />
<meta property="article:modified_time" content="2021-11-09T15:14:08-08:00" />
<meta property="article:publisher" content="https://www.facebook.com/PasteMagazine" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@pastemagazine" />
<meta name="twitter:title" content="Whatever Happened to Season 8 of MasterChef Junior?" />
<meta name="twitter:description" content="Apparently filmed in mid-2019, the cooking show season has never seen the light of day." />
<meta name="twitter:image" content="https://cdn.pastemagazine.com/www/articles/2021/11/09/gordon-ramsay-masterchef-junior-main.jpg" />
<meta name="p:domain_verify" content="8f36922bc91ba221f10d82c407d8b6a9"/>
<meta name="viewport" content="viewport-fit=cover, width=device-width, initial-scale=1.0, maximum-scale=1.0" />
<link rel="dns-prefetch" href="https://hb.adtelligent.com" />
<link rel="dns-prefetch" href="https://ib.adnxs.com" />
<link rel="dns-prefetch" href="https://web.hb.ad.cpe.dotomi.comm" />
<link rel="dns-prefetch" href="https://ap.lijit.com" />
<link rel="preload"  as="style"  type="text/css" href="https://images.wolfgangsvault.com/images/css/article/inline-39.2021.11029.11229.css"/>
<link rel="preload"  as="style"  type="text/css" href="https://images.wolfgangsvault.com/images/css/article/stylesheet-39.2021.11029.11229.css"/>
<link rel="preload" as="image" type="image/jpeg" href="https://cdn.pastemagazine.com/www/articles/2021/11/09/gordon-ramsay-masterchef-junior-main.jpg"/>

<link rel="preload" as="script"  href="https://www.pastemagazine.com/pastemagazine.js/article/javascript.js?cb=39.2021.11029.11229.2"></script>
<link rel="preload" as="image" type="image/png" href="https://cdn.pastemagazine.com/images/landing-header-bg.png"/>
<link rel="stylesheet" type="text/css" href="https://images.wolfgangsvault.com/images/css/article/inline-39.2021.11029.11229.css"/>
<link rel="stylesheet"  type="text/css" href="https://images.wolfgangsvault.com/images/css/article/stylesheet-39.2021.11029.11229.css"/>
<script type="application/ld+json">[{"@context":"https://schema.org","@type":"Article","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.pastemagazine.com/tv/masterchef/masterchef-junior-season-8-canceled-renewed-gordon-ramsay-daphne-oz/","inLanguage":"en-US"},"datePublished":"2021-11-09T12:01:55-08:00","dateModified":"2021-11-09T15:14:08-08:00","articleSection":"TV","author":{"@type":"Person","name":"Jim Vorel"},"headline":"Whatever Happened to Season 8 of MasterChef Junior?","url":"https://www.pastemagazine.com/tv/masterchef/masterchef-junior-season-8-canceled-renewed-gordon-ramsay-daphne-oz/","thumbnailUrl":"https://cdn.pastemagazine.com/www/articles/2021/11/09/gordon-ramsay-masterchef-junior-main.jpg","image":{"@type":"ImageObject","url":"https://cdn.pastemagazine.com/www/articles/2021/11/09/gordon-ramsay-masterchef-junior-main.jpg","width":633,"height":356},"publisher":{"@type":"Organization","url":"https://pastemagazine.com/","name":"Paste Magazine","logo":{"@type":"ImageObject","url":"https://cdn.pastemagazine.com/images/master-header-logo.png","width":650,"height":179},"potentialAction":{"@type":"SearchAction","target":"https://pastemagazine.com/search?t={search_term_string}","query-input":"required name=search_term_string"}},"keywords":["cooking shows","daphne oz","fox","gordon ramsay","masterchef","masterchef junior"]},{"@type":"BreadcrumbList","@id":"https://www.pastemagazine.com/tv/masterchef/masterchef-junior-season-8-canceled-renewed-gordon-ramsay-daphne-oz/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"/","url":"https://pastemagazine.com/","name":"Paste Magazine"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"/tv","url":"https://pastemagazine.com/tv","name":"Paste TV"}},{"@type":"ListItem","position":3,"item":{"@type":"WebPage","@id":"/articles/tv/features/","url":"https://pastemagazine.com/articles/tv/features/","name":"Most Recent TV Features"}},{"@type":"ListItem","position":4,"item":{"@type":"WebPage","@id":"/search?t=masterchef","url":"https://pastemagazine.com/search?t=masterchef","name":"Masterchef"}}]}]</script>
<script>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];</script>
<script>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</script>
<script>let retries=0,alreadySent=false;window.gtmEventSend=function(){if(dataLayer && !alreadySent){alreadySent=true;dataLayer.push({'event':'detectioncomplete'});}else if(retries<6 && !alreadySent){retries++;setTimeout(gtmEventSend,250);}}</script>

</head>
  <body class="undecided">
    <!-- Google Tag Manager (noscript) -->
    
    <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-P8HM6Q9" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
    <!-- End Google Tag Manager (noscript) -->
    <div class="screen"></div>
    <form method="post" action="/tv/masterchef/masterchef-junior-season-8-canceled-renewed-gordon-ramsay-daphne-oz/" id="PageForm">
<div class="aspNetHidden">
<input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="AvXLMs/YIo5C73os+Wg/CmoqfgN5fkbq0GUlKh3oAJss6YO/blYoWmp04q2/CfuQoAhcM+Dlv2boGcvKy0U3JxIoddMwtz6wMUcEb6JhAPg=" />
</div>

      <div id="top_leaderboard">
  <script>adCommands.push(function(ads){ads.prime("top_leaderboard")});</script>
</div>
<div class="expanded site-navigation" id="site_navigation" data-pagetype="Article">
  <div class="grid-container">
    <header id="master-header" class="grid-y detail top-bar">
      <div class="top-bar-container grid-x">
        <div class="top-bar-right hide-for-large cell">
          <a href="#" class="menu" aria-label="Section Menu" data-toggle="small-navigation-menu">Sections <i class="icon-menu"><!--icon--></i></a>
          <ul class="vertical dropdown-pane menu" id="small-navigation-menu" data-dropdown="" data-position="left" data-alignment="top" data-close-on-click="true" data-auto-focus="false">
            <li>
              <a href="/music" class="large-1 cell">Music</a>
            </li>
            <li>
              <a href="/movies" class="large-1 cell">Movies</a>
            </li>
            <li>
              <a href="/tv" class="active">TV</a>
            </li>
            <li>
              <a href="/comedy" class="large-1 cell">Comedy</a>
            </li>
            <li>
              <a href="/games" class="large-1 cell">Games</a>
            </li>
            <li>
              <a href="/books" class="large-1 cell">Books</a>
            </li>
            <li>
              <a href="/drink" class="large-1 cell">Drink</a>
            </li>
            <li>
              <a href="/politics" class="large-1 cell">Politics</a>
            </li>
            <li class="empty">
              <!--to force order-->
            </li>
            <li class="hide-not-large">
              <a href="/articles/article-type/news/">News</a>
            </li>
            <li class="hide-not-large">
              <a href="/noisetrade/music/">NoiseTrade</a>
            </li>
            <li class="hide-not-large">
              <a href="/studio">Video</a>
            </li>
            <li>
              <a href="/podcasts">Podcasts</a>
            </li>
            <li class="hide-not-large">
              <a href="/daytrotter">Daytrotter</a>
            </li>
            <li class="hide-not-large">
              <a href="/crawdaddy">Crawdaddy</a>
            </li>
            <li class="hide-not-large">
              <a target="_kb" href="https://www.kingbiscuit.com/">KB Radio</a>
            </li>
            <li>
              <a href="https://www.wolfgangs.com/paste-magazine-merch/" target="_blank" rel="noopener">Merch</a>
            </li>
            <li>
              <a href="/advertise">Advertise</a>
            </li>
            <li>
              <a href="/movies/best-movies-on-netflix/">Netflix</a>
            </li>
            <li>
              <a href="/movies/best-movies-amazon-prime/">Amazon</a>
            </li>
          </ul>
        </div>
        <div class="title-bar grid-x cell align-bottom">
          <div class="large-1 medium-1 small-5 cell logo">
            <a href="/">
              <svg id="Layer_1" data-name="Layer 1" viewBox="0 0 650 179.07" xmlns="http://www.w3.org/2000/svg">
                <defs>
                  <style>path{fill:#363636;}</style>
                </defs>
                <title>Paste Magazine</title>
                <path d="M-23,430c32.81.05,65.63-.15,98.44.3A80.51,80.51,0,0,1,109.31,438c15.81,7.56,23.79,20.31,24.42,37.65.64,17.58-6.38,30.94-22.21,39.32-12.48,6.61-25.85,9.62-39.84,10-10.33.24-20.66.22-31,0-3.54-.06-4.54,1.16-4.52,4.58q.18,30.48,0,61c0,3.52,1.15,4.63,4.62,4.52,7.44-.21,14.89-.06,22.62-.06V604H-23v-9H2.77V440H-23Zm60.22,9.06a13.11,13.11,0,0,0-.87,2.61q-.08,35.46-.13,70.93c0,2.71,1.33,3.34,3.73,3.32,10.66-.1,21.32,0,32-.13,10.26-.12,17.35-5.09,21.22-14.56,6.16-15.11,6.39-30.46,1.29-45.86-2.46-7.44-7.51-13.3-15.4-14.09C65.05,439.88,51,439.73,37.22,439.06Z" transform="translate(23 -427.93)" />
                <path d="M173,607c-1.92-.47-3.84-1-5.78-1.41-21.1-4.74-33.91-22-32.63-44,1.3-22.15,11.19-38,33.16-44.78q18.81-5.85,37.67-11.57c27-8.15,26.39-16.89,24.43-39.1-1.23-14-11.62-23.39-27-24.85-7.66-.72-15.63.06-23.29,1.27-10.07,1.59-17.22,7.85-21.11,17.23-2.34,5.64-3.58,11.74-5.62,17.53-.55,1.58-2.2,2.79-3.34,4.17-.64-1.57-1.81-3.13-1.83-4.71-.24-12.65-.19-25.31-.39-38-.06-4.11,1.88-5.37,5.7-5.81,13-1.5,26-3.34,39.07-5.05h12c2.77.44,5.53.9,8.31,1.32,24.22,3.64,37,17.29,38.5,42.25.87,14.77.68,29.62.75,44.43.11,22,0,44,0,66,0,10.76,3,14.22,13.61,15.94,1.8.3,3.73.29,5.38,1s2.76,1.93,4.12,2.94c-1.49.72-2.95,2-4.46,2-6,.24-12,.1-18,.1h-7c-8.12,0-8.12,0-11.14-7.58-2.7-6.76-3.07-6.86-9-2.73a73.15,73.15,0,0,1-32.34,12.32c-1.63.22-3.21.7-4.82,1.06Zm57.46-67.13c0-7.66.12-15.32,0-23-.1-5.29-2.06-6.57-7-4.74q-23.65,8.73-47.23,17.64a27.25,27.25,0,0,0-15,13.27c-6.19,11.83-3.68,32.87,5.89,42.16a29.83,29.83,0,0,0,14.07,7.72c14.31,2.87,27.42-1,38.66-10.35a28.14,28.14,0,0,0,10.66-22.73C230.43,553.2,230.47,546.54,230.46,539.87Z" transform="translate(23 -427.93)" />
                <path d="M340,428c5.45,1.42,11.08,2.34,16.28,4.39,5.36,2.1,10.29,5.3,15.59,8.11,4.72-2.23,6-10.39,13.77-9.36v46.52h-7.35c-1-11.74-7.82-20.39-16.15-28.12-15.35-14.24-40.23-14.54-54.46-.65-13.06,12.75-9.67,29.86,7.55,36,11.9,4.25,24.14,7.51,36.22,11.24,2.86.88,5.72,1.79,8.52,2.84,18.88,7.15,30.54,20.4,33.34,40.62,2.61,18.82-.69,36.21-14.23,50.55-15.06,16-41.2,20.94-63.45,11.93-5.35-2.17-10.37-5.15-15.86-7.91-5.51,2.14-8,10.35-16.2,9.86V552.42h6.89c1.48,4.45,2.78,9.06,4.52,13.5,9.84,25.07,36.86,36.49,61.64,26.16,14.51-6.06,23-18,22.48-31.63-.23-6.55-2.39-12.5-8-15.86A184,184,0,0,0,346.35,532c-8.28-3.4-17.07-5.56-25.65-8.22-32.73-10.17-41-41.25-32.19-66.28,5.66-16.11,18.2-24.91,34.68-28.37,1.61-.34,3.21-.75,4.81-1.13Z" transform="translate(23 -427.93)" />
                <path d="M616.8,570.12l9.63,8.64c-1.67,1.84-3.11,3.58-4.7,5.17-26.38,26.35-73.09,29.56-102.91,7.1-18.08-13.62-25.64-34-19.75-53.56,4.15-13.81,13.89-22.8,26.18-29.39,4-2.17,8.27-4,12.83-6.13-3.89-2.17-7.46-3.86-10.71-6-16.35-10.85-20-30.8-8.66-46.7,19.31-27.11,69.5-27.3,88.45.07-2.52,2.4-5.11,4.84-7.91,7.5-6.75-7.16-14.49-11.61-24.11-12.4-19.19-1.58-33.29,12.48-30.33,30.33,1.87,11.24,11.67,19.61,24.5,20.4,6.61.41,13.27.07,20.27.07v12.41H579.17a53,53,0,0,0-28.53,7.76c-25.12,15.62-25.59,49.34-.95,65.74,19.49,13,47,10,63.31-6.86C614.16,573.05,615.26,571.8,616.8,570.12Z" transform="translate(23 -427.93)" />
                <path d="M420.11,481.56h-20V469.69H420V431.85l33.92-2.18v39.89h30.23v12H454.07v5.93q0,42.72,0,85.46a51.83,51.83,0,0,0,.28,6c.61,5.39,2.2,10.45,8.14,11.92,6.18,1.52,12.19.54,16.27-4.84,2.86-3.76,4.91-8.15,7.46-12.51l5,2.61c-1.74,13.29-14.42,26.2-28.52,27.55-8.66.82-17.59,0-26.28-1s-13.72-7.05-15.25-15.61a68.72,68.72,0,0,1-1-11.9c-.08-29,0-58,0-87Z" transform="translate(23 -427.93)" />
              </svg>
            </a>
          </div><div class="grid-x article-shares-links four">
  <a href="https://www.pastemagazine.com/tv/masterchef/masterchef-junior-season-8-canceled-renewed-gordon-ramsay-daphne-oz/" data-title="Whatever Happened to Season 8 of MasterChef Junior?" class="small-3 icon-facebook">Share</a>
  <a href="https://www.pastemagazine.com/tv/masterchef/masterchef-junior-season-8-canceled-renewed-gordon-ramsay-daphne-oz/" data-title="Whatever Happened to Season 8 of MasterChef Junior?" class="small-3 icon-twitter">Tweet</a>
  <a href="https://www.pastemagazine.com/tv/masterchef/masterchef-junior-season-8-canceled-renewed-gordon-ramsay-daphne-oz/" data-title="Whatever Happened to Season 8 of MasterChef Junior?" class="small-3 icon-reddit-alien only-view-large">Submit</a>
  <a href="https://www.pastemagazine.com/tv/masterchef/masterchef-junior-season-8-canceled-renewed-gordon-ramsay-daphne-oz/" data-title="Whatever Happened to Season 8 of MasterChef Junior?" data-image="https://cdn.pastemagazine.com/www/articles/2021/11/09/gordon-ramsay-masterchef-junior-main.jpg" class="small-3 icon-pinterest">Pin</a>
</div></div>
        <nav>
          <div class="show-for-medium cell horizontal">
            <a href="/noisetrade/music/" class="icon-rss large-auto">NoiseTrade</a>
            <b class="div">
              <!--divider-->
            </b>
            <a href="/studio" class="icon-video large-auto">Video</a>
            <b class="div">
              <!--divider-->
            </b>
            <a href="/articles/article-type/news/" class="icon-newspaper large-auto">News</a>
            <b class="div">
              <!--divider-->
            </b>
            <a href="/daytrotter" class="icon-daytrotter-horse large-auto">Daytrotter</a>
            <b class="div">
              <!--divider-->
            </b>
            <a href="/crawdaddy" class="icon-crawdaddy large-auto">Crawdaddy</a>
            <b class="div">
              <!--divider-->
            </b>
            <a target="_kb" href="https://www.kingbiscuit.com/" class="icon-kb large-auto">KB Radio</a>
          </div>
          <a href="/music">Music</a>
          <a href="/movies">Movies</a>
          <a href="/tv" class="active">TV</a>
          <a href="/comedy">Comedy</a>
          <a href="/games">Games</a>
          <a href="/books">Books</a>
          <a href="/drink">Drink</a>
          <a href="/politics">Politics</a>
          <a href="/movies/best-movies-on-netflix/">Netflix</a>
          <a href="/movies/best-movies-amazon-prime/">Amazon</a>
          <a class="large-auto medium-auto cell search closed icon-search" href="/search" aria-label="Search">
            <!--search-->
          </a>
          <div class="top-bar-right show-for-large cell">
            <a href="#" class="menu" aria-label="Section Menu" data-toggle="large-navigation-menu">
              <i class="icon-menu">
                <!--icon-->
              </i>
            </a>
            <ul class="vertical dropdown-pane menu" id="large-navigation-menu" data-dropdown="" data-position="left" data-alignment="top" data-close-on-click="true" data-auto-focus="false">
              <li>
                <a href="/noisetrade/music/">NoiseTrade</a>
              </li>
              <li>
                <a href="/studio">Video</a>
              </li>
              <li>
                <a href="/articles/article-type/news/">News</a>
              </li>
              <li>
                <a href="/daytrotter">Daytrotter</a>
              </li>
              <li>
                <a href="/crawdaddy">Crawdaddy</a>
              </li>
              <li>
                <a target="_kb" href="https://www.kingbiscuit.com/">KB Radio</a>
              </li>
            </ul>
          </div>
        </nav>
      </div></header>
    <div class="header-top-ad cell center dfp">
    </div>
  </div>
</div>
      <main class="expanded site-body" id="site_body">
        <div class="grid-container">
          
   
<div id="article_detail_wrapper" class="grid-x article-wrapper">
  <div class="large-12 cell">
    <div class="grid-x small-up-1 medium-up-2 large-up-12">
      <div class="large-auto medium-auto small-auto">
        <article id="article-detail-container">
  <div class="header" data-entry-id="357324">
    <h1 class="title">Whatever Happened to Season 8 of <i>MasterChef Junior</i>?</h1>
    <div class="bylinepublished">By <a class="ovr" href="/writers?name=jim+vorel">Jim Vorel</a>  |  November 9, 2021  |  3:14pm</div>
    <i class="extra-byline">Photos Courtesy of FOX</i>
    <b class="type">
      <a class="non" href="/tv">TV</a> <a class="non" href="/articles/tv/features/">Features</a> <a class="non" href="/search?t=masterchef">masterchef</a></b>
  </div>
  <div class="grid-x article-shares-links four">
    <a href="https://www.pastemagazine.com/tv/masterchef/masterchef-junior-season-8-canceled-renewed-gordon-ramsay-daphne-oz/" data-title="Whatever Happened to Season 8 of MasterChef Junior?" class="small-3 icon-facebook">Share</a>
    <a href="https://www.pastemagazine.com/tv/masterchef/masterchef-junior-season-8-canceled-renewed-gordon-ramsay-daphne-oz/" data-title="Whatever Happened to Season 8 of MasterChef Junior?" class="small-3 icon-twitter">Tweet</a>
    <a href="https://www.pastemagazine.com/tv/masterchef/masterchef-junior-season-8-canceled-renewed-gordon-ramsay-daphne-oz/" data-title="Whatever Happened to Season 8 of MasterChef Junior?" class="small-3 icon-reddit-alien only-view-large">Submit</a>
    <a href="https://www.pastemagazine.com/tv/masterchef/masterchef-junior-season-8-canceled-renewed-gordon-ramsay-daphne-oz/" data-title="Whatever Happened to Season 8 of MasterChef Junior?" data-image="https://cdn.pastemagazine.com/www/articles/2021/11/09/gordon-ramsay-masterchef-junior-main.jpg" class="small-3 icon-pinterest">Pin</a>
  </div>
  <div class="main-image">
    <img src="https://cdn.pastemagazine.com/www/articles/2021/11/09/gordon-ramsay-masterchef-junior-main.jpg" alt="Whatever Happened to Season 8 of &lt;i&gt;MasterChef Junior&lt;/i&gt;?" />
  </div>
  <div class="copy entry manual-ads">
    <p>Back in the early days of the pandemic, midway through 2020, in a time when it felt like surely this strange period of national despondency would be over in the space of a few months, I was on the hunt for a new TV series to binge. Trapped inside for long periods in a new and disturbing world, my wife and I searched for lighthearted, escapist programming like so many other Americans surely were at the same time. And being a pair of food geeks, we watched a lot of random cooking competition shows. But something clicked when we finally landed on FOX’s <i>MasterChef Junior</i>. </p>
    <p>I have never really followed any of the top-of-the-line, season-long cooking competition series. <i>Top Chef</i> was of little interest to me; ditto the original <i>MasterChef</i> from Gordon Ramsay. In their place, I tended to prefer the one-and-done simplicity of the likes of <i>Chopped</i>, <i>Iron Chef America</i>, or the the sheer silliness/gimmickry of the likes of <i>Beat Bobby Flay</i>. Those are the kinds of shows you can throw on at any time, without context, and be mindlessly entertained, while maybe getting an idea for a Sunday dinner. But when forced to spend more time than ever at home, the ongoing nature and storylines of a bigger series like <i>MasterChef</i> became more attractive. Watching became a nightly ritual; a way to stave off the ennui of the world we were living in.</p>
    <p>And then of course, there are the kids. <i>MasterChef Junior</i> maintains a particularly carefree and absurd disposition, balancing embarrassingly cheesy competitions and tomfoolery with <i>shockingly</i> talented 8 to 13-year-old cooks who routinely make you wonder how it’s possible for anyone to become so skilled, so fast. Oftentimes frustrating, but simultaneously joyful, any given <i>MasterChef Junior</i> season can take you on an emotional rollercoaster ride perfect for helping one ignore the deaths of hundreds of thousands of Americans for a few more minutes. Suffice to say, my wife and I steadily plowed through seven full seasons of <i>MasterChef Junior</i> before running out of new content. The well depleted, I then turned my attentions elsewhere.</p>
    <p>Until recently, that is, when I began to wonder if we’d ever see any more <i>MasterChef Junior</i>, or if there was finally an eighth season on the way. And to my surprise, what I found was that not only had more <i>MasterChef Junior</i> been filmed, but it was filmed <i>roughly 2.5 years ago</i> at this point. The lost Season 8 has simply never been released, and fans have to wonder if they’ll ever actually end up seeing it. </p>
    <p>As a fan of this series, I wanted to look a little deeper into the nature of this hold-up, and speculate on where this leaves <i>MasterChef Junior</i> today.</p>
    <div class="dfp" data-chars="">
      <div id="mid_leaderboard_rectangle_1">
        <script>adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_1")});</script>
      </div>
    </div>
    <hr />
    <h2>
      <a class="big jumplink" id="what-we-know-about-masterchef-junior">What We Know About <i>MasterChef Junior</i> Season 8</a>
    </h2>
    <p />
    <div class="standard-embed">
      <iframe src="" xdata-src="https://www.youtube.com/embed/SHC1Fq5uNf4?rel=0&amp;showinfo=0" allowfullscreen="allowfullscreen" style="background:#000000" width="100%"> </iframe>
    </div>
    <p>The seventh season of <i>MasterChef Junior</i> aired in early 2019, and it appears that the eighth season began filming shortly thereafter—photos from filming <a href="https://people.com/parents/daphne-oz-hardest-pregnancy-masterchef-junior-exclusive/" class="ovr" target="_blank">appear in several articles</a> written in July and August of 2019. </p>
    <p>The biggest change regarding this season was the departure of veteran judge Christina Tosi, the CEO of New York bakery company Milk Bar, who had been with the show since Season 4. In her place, the show added Daphne Oz, the daughter of controversial TV figure Dr. Mehmet Oz, and an accomplished TV personality in her own right. Daphne Oz had previously been a cohost of ABC’s <i>The Chew</i> for six seasons—she’s also an author and mother of four, and filmed this <i>MasterChef Junior</i> season while pregnant with her most recent child. Back in July of 2020, Daphne Oz <a href="https://www.instagram.com/p/CCq8MsJF4A6/?utm_source=ig_embed&amp;ig_rid=46822ac3-8022-4c20-9e2c-29d49370d98d" class="ovr" target="_blank">excitedly posted video on her Instagram account</a> highlighting her addition to the judges for <i>MasterChef Junior</i>. There’s almost no other footage of this season that exists on the web, though I was able to find <a href="https://www.facebook.com/watch/?v=3117263358384168" class="ovr" target="_blank">this Oz cooking demonstration</a> on Facebook. Oz was joined by returning judges Gordon Ramsay and Aarón Sánchez. </p>
    <p>Season 8 of the series, therefore, seemed to sit in stasis for about a year between filming in mid-2019 and being announced in mid-2020 for a Sept. 2020 premiere. For unknown reasons, however, the series was bumped from its Sept. 2020 slot, which would have followed <i>The Voice</i> on FOX’s schedule. Instead, that position was ultimately taken by the Ken Jeong-hosted singing competition <i>I Can See Your Voice</i>.</p>
    <p>What has followed, meanwhile, has been radio silence on <i>MasterChef Junior</i>, as the show never received another official premiere date—fans expected to hear that the show would return in early 2021, but no date ever surfaced. Some 11 months later, we’re now pushing toward the end-of-year season in 2021, and there’s still been no official acknowledgement of this lost season. It seems to have fallen off the radar entirely.</p>
    <p>Reaching out to FOX for comment, a representative of the network was unable to offer much clarification to <i>Paste</i>, saying only that the show “is not currently on the schedule,” while simultaneously implying that it has never been officially canceled. I would speculate that the season is indeed still intended to air someday, but the obvious question becomes “why hasn’t it already?” </p>
    <p>Moreover, how strange must these past 2.5 years have been for whichever kid competed on and <i>won</i> the never-aired season of <i>MasterChef Junior</i>? Imagine if you’re a 9-year-old home cook who spends a few months battling through a TV reality show, only for 2.5 years to then pass and have that show you starred in still nowhere near the network’s schedule. It’s entirely likely that the winner of Season 8 won’t even be <i>recognizable</i> by the time the season actually airs, because they’ll have grown so much in the interim. </p>
    <div class="dfp" data-chars="">
      <div id="mid_leaderboard_rectangle_2">
        <script>adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_2")});</script>
      </div>
    </div>
    <hr />
    <h2>
      <a class="big jumplink" id="so-what-s-the-hold-up-">So What’s the Hold Up?</a>
    </h2>
    <p />
    <div class="standard-embed">
      <iframe src="" xdata-src="https://www.youtube.com/embed/7GAWvFfrOuA?rel=0&amp;showinfo=0" allowfullscreen="allowfullscreen" style="background:#000000" width="100%"> </iframe>
    </div>
    <p>It almost goes without saying that the COVID-19 pandemic no doubt played some role in this delay, in one way or another. Even though Season 8 of the series was filmed almost a year before the virus made its way stateside, it was originally intended to air at a time when the pandemic was upending TV schedules and film releases around the world. A cascading series of cancelations and rescheduling could easily account for the show’s original loss of its Sept. 2020 premiere date. <!--work-around to avoid self-close--></p>
    <p>Then there’s the perhaps overcrowded nature of similar shows on FOX itself, which agreed to a big new overall deal <a href="https://www.hollywoodreporter.com/tv/tv-news/gordon-ramsay-fox-deal-1234992597/" class="ovr" target="_blank">with chef Gordon Ramsay in August of 2021. </a> Ramsay has been a regular at FOX ever since the original <i>Hell’s Kitchen</i> season in 2005, and has since masterminded <i>Kitchen Nightmares</i>, <i>MasterChef</i>, <i>MasterChef Junior</i>, <i>24 Hours to Hell and Back</i>, and the <a href="https://www.hollywoodreporter.com/tv/tv-news/gordon-ramsay-fox-next-level-chef-1234954207/" class="ovr" target="_blank">upcoming cooking competition series <i>Next Level Chef</i>,</a> which is currently scheduled to premiere on Jan. 2, 2022 on the network. There might be some fear of a Gordon Ramsay burnout, particularly with the most recent season of the adult <i>MasterChef</i> airing from June-Sept. 2021.  </p>
    <p>Personally, though, I can’t help but wonder if the presence of judge Daphne Oz, seen as a boon and a publicity generating casting back in mid-2019, may have taken on different and less desirable connotations during the middle of the COVID-19 pandemic. Her father, TV legend Dr. Oz, has been a lightning rod for years for his frequent promotion of pseudoscience and “alternative” medicine, and became only a more polarizing figure during the Trump presidency when Trump appointed him to the President’s Council on Sports, Fitness and Nutrition. Dr. Mehmet Oz may have even played a part in Donald Trump’s advocacy for antimalarial drug hydroxychloroquine as a potential COVID treatment, given that Trump began promoting the drug after Oz first promoted it on multiple Fox News broadcasts in March 2020. Could it be that FOX was concerned about some kind of blowback related to another Oz appearing on <i>MasterChef Junior</i>, at the same time as Dr. Oz was receiving so many blistering headlines? One can imagine a scenario where producers were waiting on setting a new date for Season 8 of the series at a time “after the pandemic,” only to find that this pandemic has stretched on indefinitely. And meanwhile, you’re left with an increasingly stale season of reality TV, that within a few months will be closer to 3 years old than it is 2 years old. </p>
    <p>While I can’t say for certain why we haven’t seen <i>MasterChef Junior</i> for so long, my family, like many others, are missing the simple joys it provided us in the earliest days of the pandemic. Here’s hoping that it eventually finds its way out of its long stay in television purgatory. </p>
    <hr />
    <p>
      <br />
      <i> For all the latest TV news, reviews, lists and features, follow <a href="https://twitter.com/paste_tv" class="ovr" target="_blank">@Paste_TV</a>.</i>
    </p>
    <div class="dfp" data-chars="">
      <div id="mid_leaderboard_rectangle_3">
        <script>adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_3")});</script>
      </div>
    </div>
  </div><div class="grid-x grid-padding-x tags"><b class="large-1 medium-1 small-1 cell label">Tags</b><div class="large-11 medium-11 small-11 cell"><h2><a class="non" href="/tag/cooking+shows">cooking shows</a></h2><h2><a class="non" href="/tag/daphne+oz">daphne oz</a></h2><h2><a class="non" href="/tag/fox">fox</a></h2><h2><a class="non" href="/tag/gordon+ramsay">gordon ramsay</a></h2><h2><a class="non" href="/tag/masterchef">masterchef</a></h2><h2><a class="non" href="/tag/masterchef+junior">masterchef junior</a></h2></div></div></article>
        <div class="dfp"><div id="mid_leaderboard_rectangle_4"><script>adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_4")});</script></div></div><div class="grid-x articles-standard" id="article-detail-studio-highlights">
  <div class="large-12 cell articles-header" style="height: auto;">
    <b class="float-left hed">Also in TV</b>
    <ul class="no-bullet articles grid-margin-x flex-container flex-dir-column">
      <li class="grid-x grid-padding-x">
        <a href="/tv/masterchef/masterchef-junior-season-8-canceled-renewed-gordon-ramsay-daphne-oz/" class="auto cell copy-container noimage">
          <b class="title">Whatever Happened to Season 8 of <i>MasterChef Junior</i>?</b>
          <b class="byline">By Jim Vorel</b>
          <b class="time" data-iso-date="2021-11-09T15:14:08-07:00">November 9, 2021  |  3:14pm</b>
        </a>
      </li>
      <li class="grid-x grid-padding-x">
        <a href="/tv/paramount-plus/jeremy-renner-interview-mayor-of-kingstown-hawkeye/" class="auto cell copy-container noimage">
          <b class="title">Jeremy Renner on the Emotional Layers of <i>Mayor of Kingstown</i> and Reuniting with Taylor Sheridan</b>
          <b class="byline">By Leila Jordan</b>
          <b class="time" data-iso-date="2021-11-09T12:35:14-07:00">November 9, 2021  |  12:35pm</b>
        </a>
      </li>
      <li class="grid-x grid-padding-x">
        <a href="/tv/netflix/narcos-mexico-season-3-review-ending-spoilers/" class="auto cell copy-container noimage">
          <b class="title"><i>Narcos: Mexico</i>'s Third and Final Season Brutally Proved You Can't Tame Trafficking</b>
          <b class="byline">By Allison Keene</b>
          <b class="time" data-iso-date="2021-11-09T11:18:32-07:00">November 9, 2021  |  11:18am</b>
        </a>
      </li>
      <li class="grid-x grid-padding-x">
        <a href="/movies/highway-to-heaven-waltons-reboot/" class="auto cell copy-container noimage">
          <b class="title"><i>Highway to Heaven</i> and <i>The Waltons</i> TV Movies Shed Light on Nostalgia's Newest Tactic</b>
          <b class="byline">By Amy Amatangelo</b>
          <b class="time" data-iso-date="2021-11-08T14:00:28-07:00">November 8, 2021  |  2:00pm</b>
        </a>
      </li>
      <li class="grid-x grid-padding-x">
        <a href="/tv/hbo/succession-roman-gerri-relationship-romance/" class="auto cell copy-container noimage">
          <b class="title"><i>Succession</i>: Why We're All So Obsessed with Gerri and Roman</b>
          <b class="byline">By Lacy Baugher Milas</b>
          <b class="time" data-iso-date="2021-11-08T10:45:05-07:00">November 8, 2021  |  10:45am</b>
        </a>
      </li>
      <li class="grid-x grid-padding-x">
        <a href="/tv/netflix/adi-shankar-interview-guardians-of-justice-will-sa/" class="auto cell copy-container noimage">
          <b class="title">Adi Shankar and <i>The Guardians of Justice (Will Save You!)</i> from Normal Television</b>
          <b class="byline">By Allison Keene</b>
          <b class="time" data-iso-date="2021-11-05T14:32:04-07:00">November 5, 2021  |  2:32pm</b>
        </a>
      </li>
    </ul>
  </div>
</div><div class="dfp"><div id="mid_leaderboard_rectangle_5"><script>adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_5")});</script></div></div><!--Detail Page Bottom Rendered: 11/9/2021 1:24:52 PM -->

      </div>
      <aside class="large-3 medium-3 small-auto">
<!--MOREMEDIATYPEORARTICLETYPE-->
<div class="dfp"><div id="top_rectangle"><script>adCommands.push(function(ads){ads.prime("top_rectangle")});</script></div></div>
<div class="grid-x articles-abbreviated" id="article-detail-most-read">
  <div class="large-12 cell articles-header">
    <a href="/articles/tv/most-read/" class="float-left hed">Most Popular</a>
  </div>
  <ul class="articles grid-margin-x flex-container flex-dir-column">
    <li class="grid-x grid-padding-x">
      <a href="/tv/bobs-burgers/bobs-burgers-decline-quality-season-12-13-renewed-canceled/" class="auto cell copy-container noimage">
        <b class="title">It's Time to Stick a Fork in <i>Bob's Burgers</i></b>
        <b class="byline hide-for-large">By Jim Vorel</b>
        <b class="time hide-for-medium" data-iso-date="2021-11-02T11:14:04-07:00">November 2, 2021</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/tv/ted-lasso/the-best-quotes-from-ted-lasso/" class="auto cell copy-container noimage">
        <b class="title">The Best Quotes from <i>Ted Lasso</i></b>
        <b class="byline hide-for-large">By Josh Jackson</b>
        <b class="time hide-for-medium" data-iso-date="2021-11-03T16:14:08-07:00">November 3, 2021</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/movies/netflix/popular-on-netflix-daily-top-10/" class="auto cell copy-container noimage">
        <b class="title">Most Popular on Netflix: A Look at Today's Top 10</b>
        <b class="byline hide-for-large">By Josh Jackson</b>
        <b class="time hide-for-medium" data-iso-date="2021-11-08T16:18:00-07:00">November 8, 2021</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/tv/netflix/arcane-review-league-of-legends-tv-show/" class="auto cell copy-container noimage">
        <b class="title">Netflix's <i>Arcane: League of Legends</i> Series Is a Surprisingly Vital Videogame Adaptation</b>
        <b class="byline hide-for-large">By Tara Bennett</b>
        <b class="time hide-for-medium" data-iso-date="2021-11-06T22:00:04-07:00">November 6, 2021</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/tv/apple-tv-/best-apple-shows-ranked/" class="auto cell copy-container noimage">
        <b class="title">The 21 Best Apple TV+ Series, Ranked</b>
        <b class="byline hide-for-large">By Paste Staff and TV Writers</b>
        <b class="time hide-for-medium" data-iso-date="2021-10-13T09:33:04-07:00">October 13, 2021</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/tv/frank-herbert/dune-miniseries-2000-syfy/" class="auto cell copy-container noimage">
        <b class="title">TV Rewind: How Syfy's Forgotten <i>Dune</i> Miniseries Made the Most of Herbert's Complex Story</b>
        <b class="byline hide-for-large">By Austin Jones</b>
        <b class="time hide-for-medium" data-iso-date="2021-11-05T11:35:09-07:00">November 5, 2021</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/tv/best-on-netflix/best-tv-on-netflix/" class="auto cell copy-container noimage">
        <b class="title">The 100 Best TV Shows on Netflix, Ranked (November 2021)</b>
        <b class="byline hide-for-large">By Paste Staff &amp; TV Writers</b>
        <b class="time hide-for-medium" data-iso-date="2021-11-02T12:23:00-07:00">November 2, 2021</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/comedy/netflix/the-50-best-sitcoms-on-netflix-right-now/" class="auto cell copy-container noimage">
        <b class="title">The Best Sitcoms on Netflix Right Now (November 2021)</b>
        <b class="byline hide-for-large">By Garrett Martin and Paste Staff</b>
        <b class="time hide-for-medium" data-iso-date="2021-11-01T11:45:00-07:00">November 1, 2021</b>
      </a>
    </li>
    <li class="more">
      <a href="/articles/tv/most-read/">More TV Most Popular</a>
    </li>
  </ul>
</div><div class="dfp"><div id="middle_rectangle"><script>adCommands.push(function(ads){ads.prime("middle_rectangle")});</script></div></div>
<div class="grid-x articles-abbreviated" id="article-detail-news">
  <div class="large-12 cell articles-header">
    <a href="/articles/tv/news/" class="float-left hed">News</a>
  </div>
  <ul class="articles grid-margin-x flex-container flex-dir-column">
    <li class="grid-x grid-padding-x">
      <a href="/comedy/the-righteous-gemstones/righteous-gemstones-season-2-trailer/" class="auto cell copy-container noimage">
        <b class="title">Here's the First Trailer for <i>The Righteous Gemstones</i> Season 2</b>
        <b class="byline hide-for-large">By Garrett Martin</b>
        <b class="time hide-for-medium" data-iso-date="2021-11-05T14:20:31-07:00">November 5, 2021</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/movies/star-wars/book-of-boba-fett-trailer-disney-plus-release-date/" class="auto cell copy-container noimage">
        <b class="title">Bounty Hunters Unite, it's the First <i>Book of Boba Fett</i> Trailer</b>
        <b class="byline hide-for-large">By Jim Vorel</b>
        <b class="time hide-for-medium" data-iso-date="2021-11-01T10:38:00-07:00">November 1, 2021</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/tv/amazon-prime/wheel-of-time-tv-series-trailer-3d/" class="auto cell copy-container noimage">
        <b class="title">Amazon's Upcoming <i>Wheel of Time</i> Series Gets a New Immersive 3D Trailer</b>
        <b class="byline hide-for-large">By Leila Jordan</b>
        <b class="time hide-for-medium" data-iso-date="2021-10-28T13:56:04-07:00">October 28, 2021</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/movies/denis-villeneuve-/dune-sopranos-sequels/" class="auto cell copy-container noimage">
        <b class="title">Will the <i>Dune</i> Sequel Happen? "I Think You Pretty Much Know the Answer to This," Says WB CEO</b>
        <b class="byline hide-for-large">By Aurora Amidon</b>
        <b class="time hide-for-medium" data-iso-date="2021-10-21T10:43:46-07:00">October 21, 2021</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/tv/netflix/cowboy-bebop-teaser-trailer-lost-session/" class="auto cell copy-container noimage">
        <b class="title">A Stylish New <i>Cowboy Bebop</i> Teaser Presents the "Lost Session"</b>
        <b class="byline hide-for-large">By Leila Jordan</b>
        <b class="time hide-for-medium" data-iso-date="2021-10-19T13:53:04-07:00">October 19, 2021</b>
      </a>
    </li>
    <li class="more">
      <a href="/articles/tv/news/">More Comedy News</a>
    </li>
  </ul>
</div>      <div id="right-column-sticky" class="dfp cell" data-sticky-container><div class="sticky" data-sticky data-sticky-on="large" data-anchor="right-column-sticky"><div id="bottom_rectangle"><script>adCommands.push(function(ads){ads.prime("bottom_rectangle")});</script></div></div></div>
<!--Detail Page Right Column Rendered: 11/9/2021 1:24:52 PM -->
</aside>

    </div>
  </div>
</div>

        </div>
      </main>
      <footer id="master-footer" class="row">
  <ul>
    <li><a href="/about">About</a></li>
    <li><a href="/advertise">Advertise</a></li>
    <li><a href="/contributor-information">Masthead</a></li>
    <li><a href="/privacy">Privacy</a></li>
    <li><a href="/copyright">Copyright</a></li>
    <li class="break"></li>
    <li><a href="/newsletter">Newsletter</a></li>
	<li><a href="https://www.wolfgangs.com/paste-magazine-merch/" target="_blank" rel="noopener">Merch</a></li>
    <li><a class="non" href="/install-the-paste-app.html">Mobile App</a></li>
	<li><a href="https://www.facebook.com/PasteMagazine" target="_blank" rel="noopener">Facebook</a></li>
	<li><a href="https://twitter.com/pastemagazine" target="_blank" rel="noopener">Twitter</a></li>
    <li><a href="/customer-service">Contact Us</a></li>
  </ul>
  <p>&copy; 2021 Paste Media Group. All Rights Reserved</p>
</footer>


      <div id="bottom-fixed-unit" class="dfp"><div><div id="bottom_leaderboard"><script>adCommands.push(function(ads){ads.prime("bottom_leaderboard")});</script></div></div></div>
    
<div class="aspNetHidden">

	<input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="4408B798" />
</div></form>
    <script src="https://www.pastemagazine.com/pastemagazine.js/article/javascript.js?cb=39.2021.11029.11229.2"></script>
<!--Rendered: 11/9/2021 1:24:52 PM -->
<!--HealthCheckOK:PM-->

  </body>
</html>
