<!doctype html>
<html class="no-js" lang="en" dir="ltr">
  <head id="Meta_HeadTag"><title>Arctic Monkeys Announce Live Album &#39;Arctic Monkeys – Live At The Royal Albert Hall&#39; - Paste</title><meta charset="utf-8" />
<link rel="shortcut icon" href="/pastemagazine.img/favicon.ico" type="image/vnd.microsoft.icon"/>
<script>
var pm = {
   servers: {
       pastemagazine: "www.pastemagazine.com",
       wolfgangs: "www.wolfgangs.com"
   },
   version: "39.2020.11016.11430.2",
   page: {"type":"Article","mediaType":"Music","articleType":"News","articleId":347183,"author":"Paris Rosenthal ","services":"/pastemagazine.svc/pastemagazine/","isMobile":false,"isIos":false,"videoEmbedPlayerId":30540132,"testGroup":"true","adblocker":true}
};
</script>
<!-- Google Tag Manager -->
<script id="gtm-script">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P8HM6Q9');</script>
<!-- End Google Tag Manager -->
<script>window.pageloadTimer = new Date()</script>
<link rel="standout" href="https://www.pastemagazine.com/music/new-wave/the-best-new-wave-albums/" />
<link rel="alternate" type="application/rss+xml" title="Recent Paste Articles" href="https://www.pastemagazine.com/recent.xml" />
<link rel="canonical" href="https://www.pastemagazine.com/music/arctic-monkeys/arctic-monkeys-announce-live-album-arctic-monkeys/" />
<meta http-equiv="x-ua-compatible" content="ie=edge" />
<meta name="title" content="Arctic Monkeys Announce Live Album 'Arctic Monkeys – Live At The Royal Albert Hall' - Paste Magazine" />
<meta name="description" content="The forthcoming album will arrive on Dec. 4 via Domino" />
<meta name="keywords" content="live at the royal albert hall, arctic monkeys, Arctic Monkeys Announce Live Album 'Arctic Monkeys – Live At The Royal Albert Hall', News, News, Articles, Paste" />
<meta name="news_keywords" content="live at the royal albert hall, arctic monkeys" />
<meta property="fb:admins" content="679468950" />
<meta property="fb:admins" content="1185614656" />
<meta property="fb:app_id" content="127550380613969" />
<meta property="fb:pages" content="18512903240" />
<meta name="apple-mobile-web-app-title" content="Paste Magazine"/>
<link rel="icon" sizes="196x196" href="https://cdn.pastemagazine.com/images/mobile-icon-196.png"/>
<link rel="icon" sizes="128x128" href="https://cdn.pastemagazine.com/images/mobile-icon-128.png" />
<link rel="apple-touch-icon" sizes="57x57" href="https://cdn.pastemagazine.com/images/mobile-icon-57.png" />
<link rel="apple-touch-icon" sizes="72x72" href="https://cdn.pastemagazine.com/images/mobile-icon-72.png" />
<link rel="apple-touch-icon" sizes="144x144" href="https://cdn.pastemagazine.com/images/mobile-icon-144.png" />
<meta property="og:image" content="https://cdn.pastemagazine.com/www/articles/ArcticMonkeys_RoyalAlbertHall_main.jpg" />
<meta property="og:image:width" content="854" />
<meta property="og:image:height" content="480" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.pastemagazine.com/music/arctic-monkeys/arctic-monkeys-announce-live-album-arctic-monkeys/" />
<meta property="og:title" content="Arctic Monkeys Announce Live Album Arctic Monkeys - Live At The Royal Albert Hall" />
<meta property="og:site_name" content="pastemagazine.com" />
<meta property="og:description" content="The forthcoming album will arrive on Dec. 4 via Domino" />
<meta property="article:tag" content="live at the royal albert hall" />
<meta property="article:tag" content="arctic monkeys" />
<meta property="article:section" content="Music" />
<meta property="article:published_time" content="2020-10-28T10:45:19-07:00" />
<meta property="article:modified_time" content="2020-10-28T11:39:00-07:00" />
<meta property="article:publisher" content="https://www.facebook.com/PasteMagazine" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@pastemagazine" />
<meta name="twitter:title" content="Arctic Monkeys Announce Live Album Arctic Monkeys - Live At The Royal Albert Hall" />
<meta name="twitter:description" content="The forthcoming album will arrive on Dec. 4 via Domino" />
<meta name="twitter:image" content="https://cdn.pastemagazine.com/www/articles/ArcticMonkeys_RoyalAlbertHall_main.jpg" />
<meta name="p:domain_verify" content="8f36922bc91ba221f10d82c407d8b6a9"/>
<meta name="viewport" content="viewport-fit=cover, width=device-width, initial-scale=1.0, maximum-scale=1.0" />
<link rel="prefetch" href="https://securepubads.g.doubleclick.net/tag/js/gpt.js" />
<link rel="prefetch" href="//c.amazon-adsystem.com/aax2/apstag.js" />
<link rel="dns-prefetch" href="https://hb.adtelligent.com" />
<link rel="dns-prefetch" href="https://ib.adnxs.com" />
<link rel="dns-prefetch" href="https://web.hb.ad.cpe.dotomi.comm" />
<link rel="dns-prefetch" href="https://ap.lijit.com" />
<link rel="dns-prefetch" href="https://cdn.ampproject.org" />
<link rel="dns-prefetch" href="https://aax-eu.amazon-adsystem.com" />
<link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin />
<link rel="preload" as="font" type="font/woff" href="/pastemagazine.fnt/montserrat-regular-webfont.woff" crossorigin />
<link rel="preload" as="font" type="font/woff" href="/pastemagazine.fnt/montserrat-bold-webfont.woff" crossorigin />
<link rel="preload" as="font" type="font/woff" href="/pastemagazine.fnt/28EF9A_0_0.woff" crossorigin />
<link rel="preload" as="font" type="font/woff" href="/pastemagazine.fnt/28EF9A_1_0.woff" crossorigin />
<script type="application/ld+json">[{"@context":"https://schema.org","@type":"Article","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.pastemagazine.com/music/arctic-monkeys/arctic-monkeys-announce-live-album-arctic-monkeys/","inLanguage":"en-US"},"datePublished":"2020-10-28T10:45:19-07:00","dateModified":"2020-10-28T11:39:00-07:00","articleSection":"Music","author":{"@type":"Person","name":"Paris Rosenthal "},"headline":"Arctic Monkeys Announce Live Album \u0027Arctic Monkeys – Live At The Royal Albert Hall\u0027","url":"https://www.pastemagazine.com/music/arctic-monkeys/arctic-monkeys-announce-live-album-arctic-monkeys/","thumbnailUrl":"https://cdn.pastemagazine.com/www/articles/ArcticMonkeys_RoyalAlbertHall_main.jpg","image":{"@type":"ImageObject","url":"https://cdn.pastemagazine.com/www/articles/ArcticMonkeys_RoyalAlbertHall_main.jpg","width":633,"height":356},"publisher":{"@type":"Organization","url":"https://pastemagazine.com/","name":"Paste Magazine","logo":{"@type":"ImageObject","url":"https://cdn.pastemagazine.com/images/master-header-logo.png","width":650,"height":179},"potentialAction":{"@type":"SearchAction","target":"https://pastemagazine.com/search?t={search_term_string}","query-input":"required name=search_term_string"}},"keywords":["live at the royal albert hall","arctic monkeys"]},{"@type":"BreadcrumbList","@id":"https://www.pastemagazine.com/music/arctic-monkeys/arctic-monkeys-announce-live-album-arctic-monkeys/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"/","url":"https://pastemagazine.com/","name":"Paste Magazine"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"/music","url":"https://pastemagazine.com/music","name":"Paste Music"}},{"@type":"ListItem","position":3,"item":{"@type":"WebPage","@id":"/articles/music/news/","url":"https://pastemagazine.com/articles/music/news/","name":"Most Recent Music News"}},{"@type":"ListItem","position":4,"item":{"@type":"WebPage","@id":"/search?t=Arctic+Monkeys","url":"https://pastemagazine.com/search?t=Arctic+Monkeys","name":"Arctic Monkeys"}}]}]</script>
<style>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</style>
<link rel="stylesheet" type="text/css" href="https://www.pastemagazine.com/pastemagazine.css/stylesheet.css?cb=39.2020.11016.11430.2"/>

<script>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];</script>
<script src="https://cdn.conversant.mgr.consensu.org/gdpr/cmp/gdpr-cmp-stub.js"></script>
<script>window.pubcid_options = {type: 'cookie'};</script>
<script src="/pastemagazine.js/pubcid.min.js"></script>
<script> var cnvr_launcher_options={lid:280} </script>
<script src="https://secure.cdn.fastclick.net/js/cnvr-launcher/latest/launcher-stub.min.js"></script>
<script src="https://tagan.adlightning.com/pastemagazine/op.js"></script>
<script async="async" src="https://c.amazon-adsystem.com/aax2/apstag.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>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</script>
<script>let retries=0,alreadySent=false;window.gtmEventSend=function(){if(dataLayer && !alreadySent){alreadySent=true;dataLayer.push({'event':'detectioncomplete'});}else if(retries<6 && !alreadySent){retries++;setTimeout(gtmEventSend,250);}}</script>
<script id="ad_controller_library" async="async" src="/pastemagazine.js/ads.js?ver=a&cb=39.2020.11016.11430.2" onerror="gtmEventSend()"></script>

</head>
  <body class="undecided">
    <!-- Google Tag Manager (noscript) -->
    
    <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-P8HM6Q9" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
    <!-- End Google Tag Manager (noscript) -->
    <div class="screen"></div>
    <form method="post" action="/music/arctic-monkeys/arctic-monkeys-announce-live-album-arctic-monkeys/" id="PageForm">
<div class="aspNetHidden">
<input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="YT+ZRdeT1WG5OWdkjhBRpWHdJiebcGrUQCsD/VWL5/nSdQHjlnUZp5OJWPeX42ARcto9osSmwzeam/PH62djbtVI7eaD3DDOcTGc+roYyLc=" />
</div>

      <div class="expanded site-navigation" id="site_navigation" data-pagetype="Article">
  <div class="grid-container">
    <header id="master-header" class="grid-y detail top-bar sticky" data-sticky="" data-options="anchor: page; marginTop: 0; stickyOn: small;">
      <div class="header-top-ad cell center dfp">
        <div id="top_leaderboard">
          <script>adCommands.push(function(ads){ads.prime("top_leaderboard")});</script>
        </div>
      </div>
      <div class="title-bar grid-x cell align-bottom">
        <a href="/" class="large-1 medium-1 small-5 cell logo">
          <svg id="Layer_1" data-name="Layer 1" viewBox="0 0 650 179.07" xmlns="http://www.w3.org/2000/svg">
            <defs>
              <style>path{fill:#363636;}</style>
            </defs>
            <title>Paste Magazine</title>
            <path d="M-23,430c32.81.05,65.63-.15,98.44.3A80.51,80.51,0,0,1,109.31,438c15.81,7.56,23.79,20.31,24.42,37.65.64,17.58-6.38,30.94-22.21,39.32-12.48,6.61-25.85,9.62-39.84,10-10.33.24-20.66.22-31,0-3.54-.06-4.54,1.16-4.52,4.58q.18,30.48,0,61c0,3.52,1.15,4.63,4.62,4.52,7.44-.21,14.89-.06,22.62-.06V604H-23v-9H2.77V440H-23Zm60.22,9.06a13.11,13.11,0,0,0-.87,2.61q-.08,35.46-.13,70.93c0,2.71,1.33,3.34,3.73,3.32,10.66-.1,21.32,0,32-.13,10.26-.12,17.35-5.09,21.22-14.56,6.16-15.11,6.39-30.46,1.29-45.86-2.46-7.44-7.51-13.3-15.4-14.09C65.05,439.88,51,439.73,37.22,439.06Z" transform="translate(23 -427.93)" />
            <path d="M173,607c-1.92-.47-3.84-1-5.78-1.41-21.1-4.74-33.91-22-32.63-44,1.3-22.15,11.19-38,33.16-44.78q18.81-5.85,37.67-11.57c27-8.15,26.39-16.89,24.43-39.1-1.23-14-11.62-23.39-27-24.85-7.66-.72-15.63.06-23.29,1.27-10.07,1.59-17.22,7.85-21.11,17.23-2.34,5.64-3.58,11.74-5.62,17.53-.55,1.58-2.2,2.79-3.34,4.17-.64-1.57-1.81-3.13-1.83-4.71-.24-12.65-.19-25.31-.39-38-.06-4.11,1.88-5.37,5.7-5.81,13-1.5,26-3.34,39.07-5.05h12c2.77.44,5.53.9,8.31,1.32,24.22,3.64,37,17.29,38.5,42.25.87,14.77.68,29.62.75,44.43.11,22,0,44,0,66,0,10.76,3,14.22,13.61,15.94,1.8.3,3.73.29,5.38,1s2.76,1.93,4.12,2.94c-1.49.72-2.95,2-4.46,2-6,.24-12,.1-18,.1h-7c-8.12,0-8.12,0-11.14-7.58-2.7-6.76-3.07-6.86-9-2.73a73.15,73.15,0,0,1-32.34,12.32c-1.63.22-3.21.7-4.82,1.06Zm57.46-67.13c0-7.66.12-15.32,0-23-.1-5.29-2.06-6.57-7-4.74q-23.65,8.73-47.23,17.64a27.25,27.25,0,0,0-15,13.27c-6.19,11.83-3.68,32.87,5.89,42.16a29.83,29.83,0,0,0,14.07,7.72c14.31,2.87,27.42-1,38.66-10.35a28.14,28.14,0,0,0,10.66-22.73C230.43,553.2,230.47,546.54,230.46,539.87Z" transform="translate(23 -427.93)" />
            <path d="M340,428c5.45,1.42,11.08,2.34,16.28,4.39,5.36,2.1,10.29,5.3,15.59,8.11,4.72-2.23,6-10.39,13.77-9.36v46.52h-7.35c-1-11.74-7.82-20.39-16.15-28.12-15.35-14.24-40.23-14.54-54.46-.65-13.06,12.75-9.67,29.86,7.55,36,11.9,4.25,24.14,7.51,36.22,11.24,2.86.88,5.72,1.79,8.52,2.84,18.88,7.15,30.54,20.4,33.34,40.62,2.61,18.82-.69,36.21-14.23,50.55-15.06,16-41.2,20.94-63.45,11.93-5.35-2.17-10.37-5.15-15.86-7.91-5.51,2.14-8,10.35-16.2,9.86V552.42h6.89c1.48,4.45,2.78,9.06,4.52,13.5,9.84,25.07,36.86,36.49,61.64,26.16,14.51-6.06,23-18,22.48-31.63-.23-6.55-2.39-12.5-8-15.86A184,184,0,0,0,346.35,532c-8.28-3.4-17.07-5.56-25.65-8.22-32.73-10.17-41-41.25-32.19-66.28,5.66-16.11,18.2-24.91,34.68-28.37,1.61-.34,3.21-.75,4.81-1.13Z" transform="translate(23 -427.93)" />
            <path d="M616.8,570.12l9.63,8.64c-1.67,1.84-3.11,3.58-4.7,5.17-26.38,26.35-73.09,29.56-102.91,7.1-18.08-13.62-25.64-34-19.75-53.56,4.15-13.81,13.89-22.8,26.18-29.39,4-2.17,8.27-4,12.83-6.13-3.89-2.17-7.46-3.86-10.71-6-16.35-10.85-20-30.8-8.66-46.7,19.31-27.11,69.5-27.3,88.45.07-2.52,2.4-5.11,4.84-7.91,7.5-6.75-7.16-14.49-11.61-24.11-12.4-19.19-1.58-33.29,12.48-30.33,30.33,1.87,11.24,11.67,19.61,24.5,20.4,6.61.41,13.27.07,20.27.07v12.41H579.17a53,53,0,0,0-28.53,7.76c-25.12,15.62-25.59,49.34-.95,65.74,19.49,13,47,10,63.31-6.86C614.16,573.05,615.26,571.8,616.8,570.12Z" transform="translate(23 -427.93)" />
            <path d="M420.11,481.56h-20V469.69H420V431.85l33.92-2.18v39.89h30.23v12H454.07v5.93q0,42.72,0,85.46a51.83,51.83,0,0,0,.28,6c.61,5.39,2.2,10.45,8.14,11.92,6.18,1.52,12.19.54,16.27-4.84,2.86-3.76,4.91-8.15,7.46-12.51l5,2.61c-1.74,13.29-14.42,26.2-28.52,27.55-8.66.82-17.59,0-26.28-1s-13.72-7.05-15.25-15.61a68.72,68.72,0,0,1-1-11.9c-.08-29,0-58,0-87Z" transform="translate(23 -427.93)" />
          </svg>
        </a><div class="grid-x article-shares-links four">
  <a href="https://www.pastemagazine.com/music/arctic-monkeys/arctic-monkeys-announce-live-album-arctic-monkeys/" data-title="Arctic Monkeys Announce Live Album Arctic Monkeys - Live At The Royal Albert Hall" class="small-3 icon-facebook">Share</a>
  <a href="https://www.pastemagazine.com/music/arctic-monkeys/arctic-monkeys-announce-live-album-arctic-monkeys/" data-title="Arctic Monkeys Announce Live Album Arctic Monkeys - Live At The Royal Albert Hall" class="small-3 icon-twitter">Tweet</a>
  <a href="https://www.pastemagazine.com/music/arctic-monkeys/arctic-monkeys-announce-live-album-arctic-monkeys/" data-title="Arctic Monkeys Announce Live Album Arctic Monkeys - Live At The Royal Albert Hall" class="small-3 icon-reddit-alien only-view-large">Submit</a>
  <a href="https://www.pastemagazine.com/music/arctic-monkeys/arctic-monkeys-announce-live-album-arctic-monkeys/" data-title="Arctic Monkeys Announce Live Album Arctic Monkeys - Live At The Royal Albert Hall" data-image="https://cdn.pastemagazine.com/www/articles/ArcticMonkeys_RoyalAlbertHall_main.jpg" class="small-3 icon-pinterest">Pin</a>
</div><div class="large-auto medium-auto small-7 cell search"><input type="search" id="master-search" placeholder="Search" value="" aria-label="Search" /><a href="#" class="non icon-search" id="master-search-button" aria-label="Search"><!--search--></a></div><div class="show-for-medium cell horizontal"><a href="/noisetrade/music/" class="icon-rss large-auto">NoiseTrade</a><a href="/studio" class="icon-video large-auto">Video</a><a href="/articles/article-type/news/" class="icon-newspaper large-auto">News</a><a href="/daytrotter" class="icon-daytrotter-horse large-auto">Daytrotter</a></div><div class="top-bar-right show-for-small-only small-1 cell"><a href="#" class="icon-menu" aria-label="Section Menu" data-toggle="small-navigation-menu"><!--phone menu--></a><ul class="vertical dropdown-pane menu" id="small-navigation-menu" data-dropdown="" data-position="left" data-alignment="top" data-close-on-click="true" data-auto-focus="false"><li><a href="/music" class="active">Music</a></li><li><a href="/movies" class="large-1 cell">Movies</a></li><li><a href="/tv" class="large-1 cell">TV</a></li><li><a href="/comedy" class="large-1 cell">Comedy</a></li><li><a href="/games" class="large-1 cell">Games</a></li><li><a href="/books" class="large-1 cell">Books</a></li><li><a href="/drink" class="large-1 cell">Drink</a></li><li><a href="/politics" class="large-1 cell">Politics</a></li><li class="empty"><!--to force order--></li><li class="hide-not-small"><a href="/articles/article-type/news/">News</a></li><li class="hide-not-small"><a href="/noisetrade/music/">NoiseTrade</a></li><li class="hide-not-small"><a href="/studio">Video</a></li><li><a href="/podcasts">Podcasts</a></li><li class="hide-not-small"><a href="/daytrotter">Daytrotter</a></li><li><a href="https://www.wolfgangs.com/paste-magazine-merch/" target="_blank" rel="noopener">Merch</a></li><li><a href="/advertise">Advertise</a></li><li><a href="/netflix/">Netflix</a></li><li><a href="/amazon/">Amazon</a></li></ul></div></div>
      <nav class="show-for-medium">
        <a href="/music" class="active">Music</a>
        <a href="/movies">Movies</a>
        <a href="/tv">TV</a>
        <a href="/comedy">Comedy</a>
        <a href="/games">Games</a>
        <a href="/books">Books</a>
        <a href="/drink">Drink</a>
        <a href="/politics">Politics</a>
        <a href="/netflix/">Netflix</a>
        <a href="/amazon/">Amazon</a>
      </nav></header>
  </div>
</div>
<div class="expanded header-bottom-ad">
  <div class="grid-x large-12 cell center dfp">
    <div id="top_pushdown">
      <script>adCommands.push(function(ads){ads.prime("top_pushdown")});</script>
    </div>
  </div>
</div>
      <main class="expanded site-body" id="site_body">
        <div class="grid-container">
          
<div class="grid-x article-wrapper">
  <div class="large-12 cell">
    <div class="grid-x small-up-1 medium-up-2 large-up-12">
      <div class="large-auto medium-auto small-auto">
        <article id="article-detail-container">
  <div class="header" data-entry-id="347183">
    <h1 class="title">Arctic Monkeys Announce Live Album <i>Arctic Monkeys - Live At The Royal Albert Hall</i></h1>
    <div class="bylinepublished">By <a class="ovr" href="/writers?name=paris+rosenthal+">Paris Rosenthal </a>  |  October 28, 2020  |  11:39am</div>
    <i class="extra-byline">Photo by Andy Paradise</i>
    <b class="type">
      <a class="non" href="/music">Music</a> <a class="non" href="/articles/music/news/">News</a> <a class="non" href="/search?t=Arctic+Monkeys">Arctic Monkeys</a></b>
  </div>
  <div class="grid-x article-shares-links four">
    <a href="https://www.pastemagazine.com/music/arctic-monkeys/arctic-monkeys-announce-live-album-arctic-monkeys/" data-title="Arctic Monkeys Announce Live Album 'Arctic Monkeys – Live At The Royal Albert Hall'" class="small-3 icon-facebook">Share</a>
    <a href="https://www.pastemagazine.com/music/arctic-monkeys/arctic-monkeys-announce-live-album-arctic-monkeys/" data-title="Arctic Monkeys Announce Live Album 'Arctic Monkeys – Live At The Royal Albert Hall'" class="small-3 icon-twitter">Tweet</a>
    <a href="https://www.pastemagazine.com/music/arctic-monkeys/arctic-monkeys-announce-live-album-arctic-monkeys/" data-title="Arctic Monkeys Announce Live Album 'Arctic Monkeys – Live At The Royal Albert Hall'" class="small-3 icon-reddit-alien only-view-large">Submit</a>
    <a href="https://www.pastemagazine.com/music/arctic-monkeys/arctic-monkeys-announce-live-album-arctic-monkeys/" data-title="Arctic Monkeys Announce Live Album 'Arctic Monkeys – Live At The Royal Albert Hall'" data-image="https://cdn.pastemagazine.com/www/articles/ArcticMonkeys_RoyalAlbertHall_main.jpg" class="small-3 icon-pinterest">Pin</a>
  </div>
  <div class="main-image">
    <img src="https://cdn.pastemagazine.com/www/articles/ArcticMonkeys_RoyalAlbertHall_main.jpg" alt="Arctic Monkeys Announce Live Album &lt;i&gt;Arctic Monkeys - Live At The Royal Albert Hall&lt;/i&gt;" />
  </div>
  <div class="copy entry manual-ads">
    <p>
      <a href="https://www.pastemagazine.com/music/arctic-monkeys/on-this-day-in-2006-arctic-monkeys-released-their/" class="ovr">Arctic Monkeys</a> have announced a live album <i>Arctic Monkeys – Live At The Royal Albert Hall</i>, out on Dec. 4 via Domino. All proceeds from the album will go to <a href="https://www.warchild.org.uk/home" class="ovr" target="_blank">War Child UK</a>, to help fill the large deficit they are facing in 2021 due to COVID-19.</p>
    <p>Arctic Monkeys explain:<!--work-around to avoid self-close--></p>
    <p class="blockquote">On June 7, 2018 we played a very special show at London’s Royal Albert Hall. All the proceeds from that memorable night were donated to War Child UK in support of the vital work they do protecting, educating and rehabilitating children who have experienced the trauma of conflict and the horror of war. The situation that was bad in 2018 is now desperate and those children and their families need our help more than ever. To enable War Child UK to reduce their funding deficit and continue their valuable work, we are happy to be able to release a live album, recorded that evening at The Royal Albert Hall. All proceeds will go direct to the charity. We thank all our fans in advance for their support of this release and in turn for their support of War Child UK.</p>
    <p>The forthcoming album will be available on limited clear double vinyl, standard black double vinyl, double CD and digitally. The clear vinyl format comes with an exclusive concert poster.<!--work-around to avoid self-close--></p>
    <p>Watch the trailer for <i>Arctic Monkeys – Live At The Royal Albert Hall</i> below, and pre-order the album <a href="https://rah-us.arcticmonkeys.com/?_ga=2.171613984.1233549243.1603895491-294959509.1603723709" class="ovr" target="_blank">here</a>. Keep scrolling for the album artwork and tracklist.</p>
    <div class="responsive-embed widescreen">
      <div class="lazyload-youtube" data-values="{&quot;id&quot;:&quot;NIRsxmU0d8Q&quot;,&quot;width&quot;:688,&quot;height&quot;:432}">
        <!--YouTube-->
      </div>
    </div>
    <h2>
      <a class="big jumplink" id="album-artwork-arctic-monkeys-–-live-at-the-royal-albert-hall">
        <i>Arctic Monkeys – Live At The Royal Albert Hall</i> Album Artwork:</a>
    </h2>
    <p />
    <p>
      <img data-sources="[&quot;https://cdn.pastemagazine.com/www/articles/ArcticMonkeys_RoyalAlbertHall_albumartwork.jpg&quot;]" data-sizes="[]" alt="ArcticMonkeys_RoyalAlbertHall_albumartwork.jpg" class="mt-image-center lazyload" style="text-align: center; display: block; margin: 0 auto 20px;" />
      <!--work-around to avoid self-close-->
    </p>
    <h2>
      <a class="big jumplink" id="tracklist-arctic-monkeys-–-live-at-the-royal-albert-hall">
        <i>Arctic Monkeys – Live At The Royal Albert Hall</i> Tracklist:</a>
    </h2>
    <p>
      <br />
01. Four Out Of Five<br />
02. Brianstorm<br />
03. Crying Lightning<br />
04. Do I Wanna Know?<br />
05. Why’d You Only Call Me When You’re High?<br />
06. 505<br />
07. One Point Perspective<br />
08. Do Me A Favour<br />
09. Cornerstone<br />
10. Knee Socks<br />
11. Arabella<br />
12. Tranquility Base Hotel &amp; Casino                                                 <br />
13. She Looks Like Fun<br />
14. From The Ritz To The Rubble<br />
15. Pretty Visitors<br />
16. Don’t Sit Down ‘Cause I’ve Moved Your Chair<br />
17. I Bet You Look Good On The Dancefloor<br />
18.StarTreatment<br />
19. The View From The Afternoon<br />
20. R U Mine?</p>
    <div class="dfp" data-chars="">
      <div id="mid_leaderboard_rectangle_1">
        <script>adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_1")});</script>
      </div>
    </div>
  </div><div class="grid-x grid-padding-x tags"><b class="large-1 medium-1 small-1 cell label">Tags</b><ul class="large-11 medium-11 small-11 cell"><li><a class="non" href="/tag/live+at+the+royal+albert+hall">live at the royal albert hall</a></li><li><a class="non" href="/tag/arctic+monkeys">arctic monkeys</a></li></ul></div></article>
        <div class="dfp"><div id="mid_leaderboard_rectangle_2"><script>adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_2")});</script></div></div><div class="grid-x articles-standard">
  <div class="large-12 cell articles-header">
    <a class="float-left hed" href="/tag/Arctic+Monkeys">Also from Arctic Monkeys</a>
  </div>
  <ul class="no-bullet articles grid-margin-x flex-container flex-dir-column">
    <li class="grid-x grid-padding-x">
      <a href="/music/arctic-monkeys/arctic-monkeys-announce-live-album-arctic-monkeys/" aria-label="Arctic Monkeys Announce Live Album Arctic Monkeys - Live At The Royal Albert Hall" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/183/ArcticMonkeys_RoyalAlbertHall_lead-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/183/ArcticMonkeys_RoyalAlbertHall_lead-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/183/ArcticMonkeys_RoyalAlbertHall_lead-151x151.jpg&quot;]">
          <img alt="Arctic Monkeys Announce Live Album Arctic Monkeys - Live At The Royal Albert Hall" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/music/arctic-monkeys/arctic-monkeys-announce-live-album-arctic-monkeys/">
        <b class="title">Arctic Monkeys Announce Live Album <i>Arctic Monkeys - Live At The Royal Albert Hall</i></b>
        <b class="byline">By Paris Rosenthal </b>
        <b class="time" data-iso-date="2020-10-28T11:39:00-06:00">October 28, 2020  |  11:39am</b>
      </a>
    </li>
    <li class="more">
      <a href="/tag/Arctic+Monkeys">More from Arctic Monkeys</a>
    </li>
  </ul>
</div><div class="dfp"><div id="mid_leaderboard_rectangle_3"><script>adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_3")});</script></div></div><div class="grid-x articles-standard" id="article-detail-studio-highlights">
  <div class="large-12 cell articles-header">
    <b class="float-left hed">Also in Music</b>
  </div>
  <ul class="no-bullet articles grid-margin-x flex-container flex-dir-column">
    <li class="grid-x grid-padding-x">
      <a href="/music/arctic-monkeys/arctic-monkeys-announce-live-album-arctic-monkeys/" aria-label="Arctic Monkeys Announce Live Album Arctic Monkeys - Live At The Royal Albert Hall" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/183/ArcticMonkeys_RoyalAlbertHall_lead-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/183/ArcticMonkeys_RoyalAlbertHall_lead-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/183/ArcticMonkeys_RoyalAlbertHall_lead-151x151.jpg&quot;]">
          <img alt="Arctic Monkeys Announce Live Album Arctic Monkeys - Live At The Royal Albert Hall" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/music/arctic-monkeys/arctic-monkeys-announce-live-album-arctic-monkeys/">
        <b class="title">Arctic Monkeys Announce Live Album <i>Arctic Monkeys - Live At The Royal Albert Hall</i></b>
        <b class="byline">By Paris Rosenthal </b>
        <b class="time" data-iso-date="2020-10-28T11:39:00-06:00">October 28, 2020  |  11:39am</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/music/black-country-new-road/black-country-new-road-announce-debut-album/" aria-label="Black Country, New Road Announce Debut Album For the first time, Share New Single" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/184/bcnr2-lead-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/184/bcnr2-lead-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/184/bcnr2-lead-151x151.jpg&quot;]">
          <img alt="Black Country, New Road Announce Debut Album For the first time, Share New Single" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/music/black-country-new-road/black-country-new-road-announce-debut-album/">
        <b class="title">Black Country, New Road Announce Debut Album <i>For the first time</i>, Share New Single</b>
        <b class="byline">By Lizzie Manno</b>
        <b class="time" data-iso-date="2020-10-28T11:29:00-06:00">October 28, 2020  |  11:29am</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/music/crock-of-gold-shane-macgowan-trailer-documentary-pogues/" aria-label="Watch the First Trailer for Shane MacGowan Documentary Crock of Gold" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/182/shane-macgowan-doc-lead-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/182/shane-macgowan-doc-lead-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/182/shane-macgowan-doc-lead-151x151.jpg&quot;]">
          <img alt="Watch the First Trailer for Shane MacGowan Documentary Crock of Gold" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/music/crock-of-gold-shane-macgowan-trailer-documentary-pogues/">
        <b class="title">Watch the First Trailer for Shane MacGowan Documentary <i>Crock of Gold</i></b>
        <b class="byline">By Jim Vorel</b>
        <b class="time" data-iso-date="2020-10-28T10:49:00-06:00">October 28, 2020  |  10:49am</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/music/belle-and-sebastian/watch-belle-and-sebastian-announce-double-live-alb/" aria-label="Belle and Sebastian Announce Double Live Album What to Look for in Summer, Share New Videos" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/173/BelleandSebastianWhatToLookFor_lead-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/173/BelleandSebastianWhatToLookFor_lead-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/173/BelleandSebastianWhatToLookFor_lead-151x151.jpg&quot;]">
          <img alt="Belle and Sebastian Announce Double Live Album What to Look for in Summer, Share New Videos" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/music/belle-and-sebastian/watch-belle-and-sebastian-announce-double-live-alb/">
        <b class="title">Belle and Sebastian Announce Double Live Album <i>What to Look for in Summer</i>, Share New Videos</b>
        <b class="byline">By Paris Rosenthal </b>
        <b class="time" data-iso-date="2020-10-27T16:16:00-06:00">October 27, 2020  |  4:16pm</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/music/dirty-projectors/dirty-projectors-share-new-single-searching-spirit/" aria-label="Dirty Projectors Announce Final EP of Their 5EPs Collection, Share New Single" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/171/dirtyprojectors-ringroad-lead-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/171/dirtyprojectors-ringroad-lead-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/171/dirtyprojectors-ringroad-lead-151x151.jpg&quot;]">
          <img alt="Dirty Projectors Announce Final EP of Their 5EPs Collection, Share New Single" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/music/dirty-projectors/dirty-projectors-share-new-single-searching-spirit/">
        <b class="title">Dirty Projectors Announce Final EP of Their <i>5EPs</i> Collection, Share New Single</b>
        <b class="byline">By Lexi Lane</b>
        <b class="time" data-iso-date="2020-10-27T15:46:00-06:00">October 27, 2020  |  3:46pm</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/music/jordana/jordana-something-to-say-to-you/" aria-label="Jordana Announces New Album Something to Say to You, Shares New Single" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/176/jordana3-lead-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/176/jordana3-lead-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/176/jordana3-lead-151x151.jpg&quot;]">
          <img alt="Jordana Announces New Album Something to Say to You, Shares New Single" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/music/jordana/jordana-something-to-say-to-you/">
        <b class="title">Jordana Announces New Album <i>Something to Say to You</i>, Shares New Single</b>
        <b class="byline">By Lizzie Manno</b>
        <b class="time" data-iso-date="2020-10-27T15:29:00-06:00">October 27, 2020  |  3:29pm</b>
      </a>
    </li>
  </ul>
</div><div class="dfp"><div id="mid_leaderboard_rectangle_4"><script>adCommands.push(function(ads){ads.prime("mid_leaderboard_rectangle_4")});</script></div></div><!--Detail Page Bottom Rendered: 10/28/2020 9:12:23 AM -->

      </div>
      <aside class="large-3 medium-3 small-auto">
<div class="grid-x articles-abbreviated special_seo_pages_right_column hide-for-large">
  <ul class="articles grid-margin-x flex-container flex-dir-column">
    <li class="grid-x grid-padding-x netflix">
      <a class="auto cell image" href="/netflix/">
        <img src="https://cdn.pastemagazine.com/www/Netflix_Symbol_RGB.png" alt="Netflix" />
      </a>
      <a class="auto cell copy-container" href="/netflix/">
        <b class="title">NETFLIX MOVIES</b>
        Paste's guide to the best movies, TV and comedy on Netflix
      </a>
    </li>
  </ul>
</div>
<div class="grid-x articles-abbreviated special_seo_pages_right_column hide-for-large">
  <ul class="no-bullet articles grid-margin-x flex-container flex-dir-column">
    <li class="grid-x grid-padding-x amazon">
      <a class="auto cell image" href="/amazon/">
        <img src="https://cdn.pastemagazine.com/www/amazon_prime_video.png" alt="Amazon Prime Video" />
      </a>
      <a class="auto cell copy-container" href="/amazon/">
        <b class="title">AMAZON PRIME</b>
        Paste's guide to the best movies and TV on Amazon Prime
      </a>
    </li>
  </ul>
</div><!--MOREMEDIATYPEORARTICLETYPE-->
<div class="dfp"><div id="top_rectangle"><script>adCommands.push(function(ads){ads.prime("top_rectangle")});</script></div></div>
<div class="grid-x articles-abbreviated special_seo_pages_right_column show-for-large">
  <ul class="articles grid-margin-x flex-container flex-dir-column">
    <li class="grid-x grid-padding-x netflix">
      <a class="auto cell image" href="/netflix/">
        <img src="https://cdn.pastemagazine.com/www/Netflix_Symbol_RGB.png" alt="Netflix" />
      </a>
      <a class="auto cell copy-container" href="/netflix/">
        <b class="title">NETFLIX MOVIES</b>
        Paste's guide to the best movies, TV and comedy on Netflix
      </a>
    </li>
  </ul>
</div>
<div class="grid-x articles-abbreviated special_seo_pages_right_column show-for-large">
  <ul class="no-bullet articles grid-margin-x flex-container flex-dir-column">
    <li class="grid-x grid-padding-x amazon">
      <a class="auto cell image" href="/amazon/">
        <img src="https://cdn.pastemagazine.com/www/amazon_prime_video.png" alt="Amazon Prime Video" />
      </a>
      <a class="auto cell copy-container" href="/amazon/">
        <b class="title">AMAZON PRIME</b>
        Paste's guide to the best movies and TV on Amazon Prime
      </a>
    </li>
  </ul>
</div><div class="grid-x articles-abbreviated" id="article-detail-most-read">
  <div class="large-12 cell articles-header">
    <a href="/articles/music/most-read/" class="float-left hed">Most Popular</a>
  </div>
  <ul class="articles grid-margin-x flex-container flex-dir-column">
    <li class="grid-x grid-padding-x">
      <a href="/music/new-albums/albums-to-stream-adrianne-lenker-brutus/" aria-label="10 New Albums to Stream Today" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/120/AdrianneLenker_DragonEyes_Lead-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/120/AdrianneLenker_DragonEyes_Lead-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/120/AdrianneLenker_DragonEyes_Lead-151x151.jpg&quot;]">
          <img alt="10 New Albums to Stream Today" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/music/new-albums/albums-to-stream-adrianne-lenker-brutus/">
        <b class="title">10 New Albums to Stream Today</b>
        <b class="byline hide-for-large">By Lizzie Manno &amp; Paste Staff</b>
        <b class="time hide-for-medium" data-iso-date="2020-10-23T10:00:00-06:00">October 23, 2020</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/music/jason-isbell/is-songwriting-contagious-curmudgeon-column/" aria-label="The Curmudgeon: Is Songwriting Contagious?" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/064/isbell-hood-sq-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/064/isbell-hood-sq-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/064/isbell-hood-sq-151x151.jpg&quot;]">
          <img alt="The Curmudgeon: Is Songwriting Contagious?" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/music/jason-isbell/is-songwriting-contagious-curmudgeon-column/">
        <b class="title">The Curmudgeon: Is Songwriting Contagious?</b>
        <b class="byline hide-for-large">By Geoffrey Himes</b>
        <b class="time hide-for-medium" data-iso-date="2020-10-20T12:45:00-06:00">October 20, 2020</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/music/jerry-jeff-walker/jerry-jeff-walker-obiturary/" aria-label="Jerry Jeff Walker (1942-2020): The Cosmic Cowboy and Mr. Bojangles" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/148/jerry-jeff-walker-sq-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/148/jerry-jeff-walker-sq-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/148/jerry-jeff-walker-sq-151x151.jpg&quot;]">
          <img alt="Jerry Jeff Walker (1942-2020): The Cosmic Cowboy and Mr. Bojangles" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/music/jerry-jeff-walker/jerry-jeff-walker-obiturary/">
        <b class="title">Jerry Jeff Walker (1942-2020): The Cosmic Cowboy and Mr. Bojangles</b>
        <b class="byline hide-for-large">By Geoffrey Himes</b>
        <b class="time hide-for-medium" data-iso-date="2020-10-26T10:20:00-06:00">October 26, 2020</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/music/best-songs/best-songs-of-the-week-julien-baker/" aria-label="The 8 Best Songs of the Week" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/117/JulienBaker_FaithHealer_Lead-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/117/JulienBaker_FaithHealer_Lead-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/117/JulienBaker_FaithHealer_Lead-151x151.jpg&quot;]">
          <img alt="The 8 Best Songs of the Week" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/music/best-songs/best-songs-of-the-week-julien-baker/">
        <b class="title">The 8 Best Songs of the Week</b>
        <b class="byline hide-for-large">By Lizzie Manno &amp; Paste Staff</b>
        <b class="time hide-for-medium" data-iso-date="2020-10-23T12:20:00-06:00">October 23, 2020</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/music/scott-walker/scott-walker-best-songs/" aria-label="The 15 Best Scott Walker Songs" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/033/ScottWalker_KeystoneStringerGetty_Lead-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/033/ScottWalker_KeystoneStringerGetty_Lead-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/033/ScottWalker_KeystoneStringerGetty_Lead-151x151.jpg&quot;]">
          <img alt="The 15 Best Scott Walker Songs" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/music/scott-walker/scott-walker-best-songs/">
        <b class="title">The 15 Best Scott Walker Songs</b>
        <b class="byline hide-for-large">By Matty Monroe</b>
        <b class="time hide-for-medium" data-iso-date="2020-10-22T12:00:00-06:00">October 22, 2020</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/music/bruce-springsteen/letter-to-you-album-review/" aria-label="Bruce Springsteen Delivers Powerful Message on Letter to You" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/106/brucespringsteen_lettertoyou_lead-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/106/brucespringsteen_lettertoyou_lead-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/106/brucespringsteen_lettertoyou_lead-151x151.jpg&quot;]">
          <img alt="Bruce Springsteen Delivers Powerful Message on Letter to You" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/music/bruce-springsteen/letter-to-you-album-review/">
        <b class="title">Bruce Springsteen Delivers Powerful Message on <i>Letter to You</i></b>
        <b class="byline hide-for-large">By Eric R. Danton</b>
        <b class="time hide-for-medium" data-iso-date="2020-10-23T11:05:24-06:00">October 23, 2020</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/music/pj-harvey/gateways-pj-harveys-dry/" aria-label="Gateways: How PJ Harvey’s Dry Helped Me Grapple with My Femininity" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/101/PJ-Harvey-Dry-lead-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/101/PJ-Harvey-Dry-lead-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/101/PJ-Harvey-Dry-lead-151x151.jpg&quot;]">
          <img alt="Gateways: How PJ Harvey’s Dry Helped Me Grapple with My Femininity" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/music/pj-harvey/gateways-pj-harveys-dry/">
        <b class="title">Gateways: How PJ Harvey&#8217;s <i>Dry</i> Helped Me Grapple with My Femininity</b>
        <b class="byline hide-for-large">By Lizzie Manno</b>
        <b class="time hide-for-medium" data-iso-date="2020-10-27T11:00:00-06:00">October 27, 2020</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/music/the-mountain-goats/getting-into-knives-album-review/" aria-label="Your Shadow Has Something To Show You: How The Mountain Goats Help" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/107/themountaingoats_gettingintoknives_lead-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/107/themountaingoats_gettingintoknives_lead-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/107/themountaingoats_gettingintoknives_lead-151x151.jpg&quot;]">
          <img alt="Your Shadow Has Something To Show You: How The Mountain Goats Help" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/music/the-mountain-goats/getting-into-knives-album-review/">
        <b class="title">Your Shadow Has Something To Show You: How The Mountain Goats Help</b>
        <b class="byline hide-for-large">By David Dark</b>
        <b class="time hide-for-medium" data-iso-date="2020-10-23T13:21:05-06:00">October 23, 2020</b>
      </a>
    </li>
    <li class="more">
      <a href="/articles/music/most-read/">More Music Most Popular</a>
    </li>
  </ul>
</div><div class="dfp"><div id="middle_rectangle"><script>adCommands.push(function(ads){ads.prime("middle_rectangle")});</script></div></div>
<div class="grid-x articles-abbreviated" id="article-detail-news">
  <div class="large-12 cell articles-header">
    <a href="/articles/music/news/" class="float-left hed">News</a>
  </div>
  <ul class="articles grid-margin-x flex-container flex-dir-column">
    <li class="grid-x grid-padding-x">
      <a href="/music/arctic-monkeys/arctic-monkeys-announce-live-album-arctic-monkeys/" aria-label="Arctic Monkeys Announce Live Album Arctic Monkeys - Live At The Royal Albert Hall" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/183/ArcticMonkeys_RoyalAlbertHall_lead-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/183/ArcticMonkeys_RoyalAlbertHall_lead-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/183/ArcticMonkeys_RoyalAlbertHall_lead-151x151.jpg&quot;]">
          <img alt="Arctic Monkeys Announce Live Album Arctic Monkeys - Live At The Royal Albert Hall" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/music/arctic-monkeys/arctic-monkeys-announce-live-album-arctic-monkeys/">
        <b class="title">Arctic Monkeys Announce Live Album <i>Arctic Monkeys - Live At The Royal Albert Hall</i></b>
        <b class="byline hide-for-large">By Paris Rosenthal </b>
        <b class="time hide-for-medium" data-iso-date="2020-10-28T11:39:00-06:00">October 28, 2020</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/music/black-country-new-road/black-country-new-road-announce-debut-album/" aria-label="Black Country, New Road Announce Debut Album For the first time, Share New Single" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/184/bcnr2-lead-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/184/bcnr2-lead-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/184/bcnr2-lead-151x151.jpg&quot;]">
          <img alt="Black Country, New Road Announce Debut Album For the first time, Share New Single" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/music/black-country-new-road/black-country-new-road-announce-debut-album/">
        <b class="title">Black Country, New Road Announce Debut Album <i>For the first time</i>, Share New Single</b>
        <b class="byline hide-for-large">By Lizzie Manno</b>
        <b class="time hide-for-medium" data-iso-date="2020-10-28T11:29:00-06:00">October 28, 2020</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/music/crock-of-gold-shane-macgowan-trailer-documentary-pogues/" aria-label="Watch the First Trailer for Shane MacGowan Documentary Crock of Gold" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/182/shane-macgowan-doc-lead-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/182/shane-macgowan-doc-lead-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/182/shane-macgowan-doc-lead-151x151.jpg&quot;]">
          <img alt="Watch the First Trailer for Shane MacGowan Documentary Crock of Gold" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/music/crock-of-gold-shane-macgowan-trailer-documentary-pogues/">
        <b class="title">Watch the First Trailer for Shane MacGowan Documentary <i>Crock of Gold</i></b>
        <b class="byline hide-for-large">By Jim Vorel</b>
        <b class="time hide-for-medium" data-iso-date="2020-10-28T10:49:00-06:00">October 28, 2020</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/music/belle-and-sebastian/watch-belle-and-sebastian-announce-double-live-alb/" aria-label="Belle and Sebastian Announce Double Live Album What to Look for in Summer, Share New Videos" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/173/BelleandSebastianWhatToLookFor_lead-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/173/BelleandSebastianWhatToLookFor_lead-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/173/BelleandSebastianWhatToLookFor_lead-151x151.jpg&quot;]">
          <img alt="Belle and Sebastian Announce Double Live Album What to Look for in Summer, Share New Videos" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/music/belle-and-sebastian/watch-belle-and-sebastian-announce-double-live-alb/">
        <b class="title">Belle and Sebastian Announce Double Live Album <i>What to Look for in Summer</i>, Share New Videos</b>
        <b class="byline hide-for-large">By Paris Rosenthal </b>
        <b class="time hide-for-medium" data-iso-date="2020-10-27T16:16:00-06:00">October 27, 2020</b>
      </a>
    </li>
    <li class="grid-x grid-padding-x">
      <a href="/music/dirty-projectors/dirty-projectors-share-new-single-searching-spirit/" aria-label="Dirty Projectors Announce Final EP of Their 5EPs Collection, Share New Single" class="large-3 medium-3 cell image youtube">
        <picture data-sizes="[&quot;(min-width: 40em)&quot;,&quot;(min-width: 64em)&quot;]" class="lazyload" data-sources="[&quot;https://cdn.pastemagazine.com/www/opt/171/dirtyprojectors-ringroad-lead-72x72.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/171/dirtyprojectors-ringroad-lead-151x151.jpg&quot;,&quot;https://cdn.pastemagazine.com/www/opt/171/dirtyprojectors-ringroad-lead-151x151.jpg&quot;]">
          <img alt="Dirty Projectors Announce Final EP of Their 5EPs Collection, Share New Single" />
        </picture>
      </a>
      <a class="auto cell copy-container" href="/music/dirty-projectors/dirty-projectors-share-new-single-searching-spirit/">
        <b class="title">Dirty Projectors Announce Final EP of Their <i>5EPs</i> Collection, Share New Single</b>
        <b class="byline hide-for-large">By Lexi Lane</b>
        <b class="time hide-for-medium" data-iso-date="2020-10-27T15:46:00-06:00">October 27, 2020</b>
      </a>
    </li>
    <li class="more">
      <a href="/articles/music/news/">More Music News</a>
    </li>
  </ul>
</div>      <div id="right-column-sticky" class="dfp cell" data-sticky-container><div class="sticky" data-sticky data-sticky-on="large" data-anchor="right-column-sticky"><div id="bottom_rectangle"><script>adCommands.push(function(ads){ads.prime("bottom_rectangle")});</script></div></div></div>
<!--Detail Page Right Column Rendered: 10/28/2020 9:12:23 AM -->
</aside>

    </div>
  </div>
</div>

        </div>
      </main>
      <footer id="master-footer" class="row">
  <ul>
    <li><a href="/about">About</a></li>
    <li><a href="/advertise">Advertise</a></li>
    <li><a href="/contributor-information">Masthead</a></li>
    <li><a href="/privacy">Privacy</a></li>
    <li><a href="/copyright">Copyright</a></li>
    <li class="break"></li>
    <li><a href="/newsletter">Newsletter</a></li>
	<li><a href="https://www.wolfgangs.com/paste-magazine-merch/" target="_blank" rel="noopener">Merch</a></li>
    <li><a class="non" href="/install-the-paste-app.html">Mobile App</a></li>
	<li><a href="https://www.facebook.com/PasteMagazine" target="_blank" rel="noopener">Facebook</a></li>
	<li><a href="https://twitter.com/pastemagazine" target="_blank" rel="noopener">Twitter</a></li>
    <li><a href="/customer-service">Contact Us</a></li>
  </ul>
  <p>&copy; 2020 Paste Media Group. All Rights Reserved</p>
</footer>
<script async src="https://ap.lijit.com/www/sovrn_beacon_standalone/sovrn_standalone_beacon.js?iid=13403293" id="sBeacon"></script>
<script>var captify_kw_query_12314 = "";(function(c,a,p,t,i,f,y){i=c.createElement(a);t=c.getElementsByTagName(a)[0];i.type='text/javascript';i.async=true;i.src=p;t.parentNode.insertBefore(i,t);})(document,'script','https://p.cpx.to/p/12314/px.js');</script>
      <div id="bottom-fixed-unit" class="dfp"><div><div id="bottom_leaderboard"><script>adCommands.push(function(ads){ads.prime("bottom_leaderboard")});</script></div><a href="#" class="non icon-cancel"><!--hide button--></a></div></div>
    
<div class="aspNetHidden">

	<input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="4408B798" />
</div></form>
    <script src="https://www.pastemagazine.com/pastemagazine.js/javascript.js?cb=39.2020.11016.11430.2"></script>
<!--Rendered: 10/28/2020 9:12:23 AM -->
<!--HealthCheckOK:PM-->

  </body>
</html>
